View Full Version : G73JH: Stock vBios, which ati drivers? (Minecraft Crash)

03-17-2013, 01:22 AM

I am having issues with minecraft crashing on launch and creating an hs_er_pid### text file (which I will post below). From what I have gathered from other g73 users updating the ati drivers resolves this problem. However, I am adverse to updating the vBios (and the Bios) as my computer is out of warranty and otherwise stable as far as I can tell.

So to the question from the title: With stock vbios installed up to which version of ati drivers can I install? I was led to believe up to version 10.1 was supported but I would like confirmation if possible.

If you have some other solution to my problem that doesn't involve flashing my vBios and/or Bios, I would appreciate a response but after a fair amount of googling I believe that the problem is the video drivers.

Additional Details:
Model: Asus G73JH
Video Card: ATI Mobility Radeon HD 5870
Bios Version: 08.00.10 (Date: 10/30/09)
vBios Version: G730552.011 (Date: 08/09/10)
Video Card Drivers: 8.683.0.0 (Date: 12/17/09)
I have already tried completely reinstalling Java.

The hs_er_pid file:

# A fatal error has been detected by the Java Runtime Environment:
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000006903d218, pid=6708, tid=5576
# JRE version: 7.0_17-b02
# Java VM: Java HotSpot(TM) 64-Bit Server VM (23.7-b01 mixed mode windows-amd64 compressed oops)
# Problematic frame:
# C [atio6axx.dll+0xd218] DrvSwapBuffers+0xb8
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
# If you would like to submit a bug report, please visit:
# http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

--------------- T H R E A D ---------------

Current thread (0x00000000128c6800): JavaThread "Minecraft main thread" daemon [_thread_in_native, id=5576, stack(0x00000000137d0000,0x00000000138d0000)]

siginfo: ExceptionCode=0xc0000005, reading address 0x0000000000000010

RAX=0x0000000000000000, RBX=0x0000000000000001, RCX=0x0000000000000000, RDX=0x0000000000020000
RSP=0x00000000138cdf70, RBP=0x000000007101208a, RSI=0x000007fefaeffac0, RDI=0x00000000004b2830
R8 =0x0000000000000011, R9 =0x0000000000000022, R10=0x0000000000000011, R11=0x0000000000000003
R12=0x00000000138ce210, R13=0x000000006907f1f0, R14=0x000000006903c5c0, R15=0x00000000ffffffff
RIP=0x000000006903d218, EFLAGS=0x0000000000010206

Top of Stack: (sp=0x00000000138cdf70)
0x00000000138cdf70: 0000000000000001 000000007101208a
0x00000000138cdf80: 000007fefaeffac0 000007fefaeffac0
0x00000000138cdf90: 00000000004b2830 000000006903c5e9
0x00000000138cdfa0: 0000000000000001 00000000138ce210
0x00000000138cdfb0: 0000000000120011 000007fefae11bf8
0x00000000138cdfc0: 00000000004b2790 000007fefae37cc0
0x00000000138cdfd0: 00000000004b2790 000000006907f200
0x00000000138cdfe0: 000007fefaeffab8 0000000069030000
0x00000000138cdff0: 0000000000000001 00000000138ce7a0
0x00000000138ce000: 0000000000000000 0000000000000000
0x00000000138ce010: 0000000000000001 000007fefae37f93
0x00000000138ce020: 000000007101208a 00000000ffffffff
0x00000000138ce030: 0000000034011eb8 000007feff570000
0x00000000138ce040: 00000000138ce090 00000000128c6800
0x00000000138ce050: 0000000000000000 0000000000000000
0x00000000138ce060: 5c2e5c5c000001a8 3159414c50534944

Instructions: (pc=0x000000006903d218)
0x000000006903d1f8: fe 00 00 00 00 00 8b 81 00 03 00 00 48 8b 0d 6d
0x000000006903d208: 8b 02 01 33 d2 89 05 69 37 fe 00 e8 a8 c5 04 00
0x000000006903d218: 8b 48 10 48 8b 05 56 89 02 01 48 89 48 38 e8 d5
0x000000006903d228: 91 05 00 8b c8 e8 ae 9b 00 00 48 8b 0d 3f 89 02

Register to memory mapping:

RAX=0x0000000000000000 is an unknown value
RBX=0x0000000000000001 is an unknown value
RCX=0x0000000000000000 is an unknown value
RDX=0x0000000000020000 is an unknown value
RSP=0x00000000138cdf70 is pointing into the stack for thread: 0x00000000128c6800
RBP=0x000000007101208a is an unknown value
RSI=0x000007fefaeffac0 is an unknown value
RDI=0x00000000004b2830 is an unknown value
R8 =0x0000000000000011 is an unknown value
R9 =0x0000000000000022 is an unknown value
R10=0x0000000000000011 is an unknown value
R11=0x0000000000000003 is an unknown value
R12=0x00000000138ce210 is pointing into the stack for thread: 0x00000000128c6800
R13=0x000000006907f1f0 is an unknown value
R14=0x000000006903c5c0 is an unknown value
R15=0x00000000ffffffff is an unknown value

Stack: [0x00000000137d0000,0x00000000138d0000], sp=0x00000000138cdf70, free space=1015k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [atio6axx.dll+0xd218] DrvSwapBuffers+0xb8

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelForma t(JIILorg/lwjgl/opengl/PixelFormat;Ljava/nio/IntBuffer;ZZZZ)I+0
j org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat (JIILorg/lwjgl/opengl/PixelFormat;Ljava/nio/IntBuffer;ZZZZ)I+15
j org.lwjgl.opengl.WindowsDisplay.createWindow(Lorg/lwjgl/opengl/DisplayMode;Ljava/awt/Canvas;II)V+176
j org.lwjgl.opengl.Display.createWindow()V+68
j org.lwjgl.opengl.Display.create(Lorg/lwjgl/opengl/PixelFormat;Lorg/lwjgl/opengl/Drawable;Lorg/lwjgl/opengl/ContextAttribs;)V+63
j org.lwjgl.opengl.Display.create(Lorg/lwjgl/opengl/PixelFormat;)V+9
j org.lwjgl.opengl.Display.create()V+13
j net.minecraft.client.Minecraft.a()V+135
j net.minecraft.client.Minecraft.run()V+6
j java.lang.Thread.run()V+11
v ~StubRoutines::call_stub

--------------- P R O C E S S ---------------

Java Threads: ( => current thread )
=>0x00000000128c6800 JavaThread "Minecraft main thread" daemon [_thread_in_native, id=5576, stack(0x00000000137d0000,0x00000000138d0000)]
0x00000000128c6000 JavaThread "Timer hack thread" daemon [_thread_blocked, id=11080, stack(0x0000000013640000,0x0000000013740000)]
0x00000000021ac800 JavaThread "DestroyJavaVM" [_thread_blocked, id=11032, stack(0x00000000024f0000,0x00000000025f0000)]
0x0000000012a0d800 JavaThread "D3D Screen Updater" daemon [_thread_blocked, id=3600, stack(0x0000000015230000,0x0000000015330000)]
0x000000001295f000 JavaThread "AWT-EventQueue-0" [_thread_blocked, id=15760, stack(0x0000000013130000,0x0000000013230000)]
0x000000000deaf000 JavaThread "AWT-Windows" daemon [_thread_in_native, id=9588, stack(0x000000000ebf0000,0x000000000ecf0000)]
0x000000000deae000 JavaThread "AWT-Shutdown" [_thread_blocked, id=3584, stack(0x000000000ea40000,0x000000000eb40000)]
0x000000000ddb1000 JavaThread "Java2D Disposer" daemon [_thread_blocked, id=11564, stack(0x000000000e7a0000,0x000000000e8a0000)]
0x000000000dd73000 JavaThread "Service Thread" daemon [_thread_blocked, id=6052, stack(0x000000000e5e0000,0x000000000e6e0000)]
0x000000000dd62800 JavaThread "C2 CompilerThread1" daemon [_thread_blocked, id=15612, stack(0x000000000e2d0000,0x000000000e3d0000)]
0x000000000dd4d000 JavaThread "C2 CompilerThread0" daemon [_thread_blocked, id=8660, stack(0x0000000002270000,0x0000000002370000)]
0x000000000dd4c800 JavaThread "Attach Listener" daemon [_thread_blocked, id=10876, stack(0x000000000e460000,0x000000000e560000)]
0x000000000dd4b800 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=1296, stack(0x000000000e1c0000,0x000000000e2c0000)]
0x000000000bcf8800 JavaThread "Finalizer" daemon [_thread_blocked, id=12208, stack(0x000000000dc00000,0x000000000dd00000)]
0x000000000bcf0800 JavaThread "Reference Handler" daemon [_thread_blocked, id=12560, stack(0x000000000d8f0000,0x000000000d9f0000)]

That is oinly part of the file since it exceeds the character limit but I can post the rest in additional replies if needed

03-19-2013, 12:44 AM
Welcome to the ROG forums!

Was hoping someone else would reply since I haven't heard much about running Minecraft with the G73Jh or have much to say about the VBIOS, but I'll give you my opinion about vga drivers below if you are interested.

Before doing that, just make sure any other programs or games you ran before okay are still running okay now and there isn't some other related problem with software or hardware causing this Minecraft issue.

Check this link (http://support.asus.com/Download.aspx?SLanguage=en&m=G73Jh&p=3&s=252) for the latest bios and approved drivers from ASUS for the G73Jh, but updating the bios may be the last thing to try if at all since a bad flash can completely kill your unit and may not even be worth the risk if you are out of warranty.
The latest ASUS approved vga driver for the G73Jh is version V8.683.0.0 from 01/29/2010 which if you haven't tried, you may want to, but you probably want to start looking for newer vga drivers for this newer game if it doesn't help.

ASUS also has unapproved vga drivers on their site you can try (I suppose I should recommend you back up first if necessary to be safe) if you check tihs link (http://support.asus.com/download.aspx?SLanguage=en&p=3&m=VGA&hashedid=n%2fa), but they are not listed by model or updated indefinitely for your notebook model, so I would look for something older (driver posted dates are listed on the site too) that has similar but higher (or lower versions but posted more recently?) versions than your driver and I see ATI driver versions like 8.672.0.0 posted on 2010.04.07 and version V8.692.1.0 posted on 2010.04.15 as well as others that you might consider trying although they are still rather old.

Finally, I don't know a whole lot about the ATI vga drivers posted elsewhere and how well they will work, but may be another thing to check into as well.

Anyway hope this helps (or someone else posts more helpful suggestions if mine don't help).

03-19-2013, 02:01 AM
Thanks for the response, I was beginning to worry that the post was going to fade into obscurity.

Before doing that, just make sure any other programs or games you ran before okay are still running okay now and there isn't some other related problem with software or hardware causing this Minecraft issue.

Everything else is running normaly, newer games are running normally.

The latest ASUS approved vga driver for the G73Jh is version V8.683.0.0 from 01/29/2010 ...

Those are my current (and stock) drivers.

ASUS also has unapproved vga drivers on their site you can try.

Sadly I was hoping someone would know which drivers were compatible before moving on to trial and error as I have heard horror stories about GSOD, overheating and so on.

If the stock drivers are the only ones compatible with my version of vBios I will probably just leave the game as unplayable since it is the only one with which I have encountered problems and I don't want to risk bricking my machine. It's frustrating that I can't play an older game when new ones run flawlessly.

Thanks agian for the response.

03-19-2013, 06:05 PM

Not sure if you want to pursue it, but if you didn't already know, our ROG site (http://rog.asus.com/notebook/17-inch/g73jh/) shows the G73Jh is using the ATI Mobility™ Radeon® HD5870, so you may want to search the internet or Minecraft forums for any issues with this combination too.

I'm hesitant to give out the link since I really don't know much about it and how well it works, but searching on yahoo for "minecraft problems with ATI Mobility™ Radeon® HD5870" did find an older Minecraft forum article about fixing OpenGL issues in ATI drivers, so you may want to look into this more.
Let me know if you want the link by Private Message (PM) and if you have a spare hard drive around to use, it would be safer to try this way in case there are any problems.

You can also try searching that "EXCEPTION_ACCESS_VIOLATION" error message you were seeing for more suggestions/possible solutions which I haven't looked into much yet although you seem to be aware it is related to Java according to the rest of the error report.

Hope this helps.

04-02-2013, 12:36 AM
This G73Jh user reports they were able to get Minecraft running, so wanted to try to link to this thread 'G73JH (Best Buy Version) Video Card Issue' (http://rog.asus.com/forum/showthread.php?31383-G73JH-(Best-Buy-Version)-Video-Card-Issue&country=&status=) for anybody else that may be interested, but not sure how straightforward it is.

04-02-2013, 12:56 PM
As you will see from the link above, the poster who was able to get Minecraft to work had UPDATED HIS vBIOS back in 2011 so that it could use the latest ATI drivers from their own website. The vBIOS update is posted on various forums, but is risky to do, and you must be absolutely sure to get the correct one and follow the instructions for updating the vBIOS meticulously.