PDA

View Full Version : [Problem] K53U Bad Bios



sloox
07-22-2011, 10:34 PM
Hi all

I have recently bought an Asus K53U AMD Brazos notebook.
I ran the Asus Update utility and just checked all and let it update.
However the update utility seems to have messed up the Bios install,
as the entire machine stalled while it was installing, the fan speeds went to full.
I let it run for about 10 minutes just incase but nothing was responding.
I tried to restart by pushing the button down for 10 or so seconds which nothing happened.
I forced it to restart by unplugging the power and pulling out the battery.

Now the laptop does not respond at all to anything.
I cannot turn it on, No lights appear when the charger is plugged in, with/ without the battery inserted.

I have read around and heard of methods to create a "crisis" recovery flash drive. Is this possible? will it help me seeing that the laptop does not turn on at all. (just in case : Not turn on at all means: No lights anywhere, No Fan spinning, No CD/DVD drive noises, No Screen Flicker, etc)

I have also read that there may be certain keys to press while start up that might get it to start?
or that u can maybe flash it through a cd??

Any tips or advice will be greatly appreciated.

Regards

valentin007
08-17-2011, 05:19 PM
Have you tryed to take out memory module and CMOS batery?