View Full Version : g46: USB-IF xHCI USB Host Controller has a driver problem

City Builder
03-21-2013, 01:07 AM
brand new g46 out of a sealed box and have this device with problems:
USB-IF xHCI USB Host Controller has a driver problem

Tried reinstalling driver but did not fix

any solutions?


03-21-2013, 01:39 AM
Delete it from Device manager, reboot and download the latest USB 3.0 drivers from Intel and install. I'm not familiar with the G46 if you have Asus Charger Plus uninstall it form Control Panel/Programs Features. Reboot twice and reinstall it if you use or need it.

03-21-2013, 05:50 AM
is it exclamation mark in device manager? please find the driver for win 8.

City Builder
03-21-2013, 05:53 AM
Ive seen that topic but did not find a valid download for any drivers. Being as how this laptop ships with Windows 8, I would expect for Asus to have the updated driver available somplace, not so?

yes exclamation mark i device manager

Heat Mizer
03-21-2013, 07:38 PM
If what you're saying is that you got this error before you did anything to a new G46VW out of the box, then I'd return it at once. Nobody else has reported this problem and I certainly don't have it. Best guess is a hardware issue or it was an open box computer that someone failed to do a clean install on or similar...

City Builder
03-21-2013, 07:40 PM
unfortunately maybe nobody report it here but check link above, many asus owners have this problem.

03-21-2013, 10:43 PM
I too have seen this after restoring my system. On both occasions I just deleted it. If I remember correctly it reports that it is installed properly but not functioning. Tested all my hardware and stuff functions correctly so I'm not sure what it is used for. However you can find all your factory installed drivers at C:\eSupport\eDriver or the latest at http://www.asus.com/ROG/G46VW/#support_Download_36
One point of interest, if stuff works, don't bother updating unless you need to, especially true of the BIOS update. I've seen around the forums some users experiencing difficulties after flashing the BIOS (on various ROG notebooks). Do update the graphic card drivers though. :)

City Builder
03-21-2013, 11:15 PM
Okay well I uninstalled it and now my notebooks camera works like it should. While that was preset in device manager anytime I'd try to use lifeframe it would just tell me the camera was disabled. After uninstalling that device, the camera works as it should.

Thanks for the replies.

08-15-2013, 03:45 PM
Just noticed this with my G46V. It only started AFTER I enabled USB device charging while the laptop is off.

08-15-2013, 08:05 PM
Yea Charger Plus has caused problems from the start with this series of Notebooks

City Builder
08-16-2013, 06:11 AM
That's the one that I used and it worked out fine for me.

10-16-2013, 11:17 PM
I had the same problem, and uninstalling the driver worked for me. When I went looking for the driver to re-install, I found this on the Intel site:

Windows 8* has a native in-box USB 3.0 driver. Intel is not releasing a specific Intel® USB 3.0 eXtensible Host Controller Driver for Windows 8.
So even Intel says to uninstall the driver. Hope this helps someone else down the line.

10-17-2013, 12:11 AM
Not sure how well this will work for everybody, but after updating the Intel WiDi/Wireless Display Application software to Version V3.5.41.0 that is posted on the ASUS G46VW download site (http://www.asus.com/ROG_ROG/G46VW/#support) under the 'utilities' section, it cleared up the mark for me.
Haven't tried the updated driver from Intel's website and curious if it may do the same thing.
If anyone is interested, below are some before and after pictures.

USB-IF xHCI USB Host Controller device manager error with Intel WiDi version V3.5.34.0:


USB-IF xHCI USB Host Controller device manager property with Intel WiDi version V3.5.41.0: