PDA

View Full Version : G75VW Running Slow



Aether92
03-22-2013, 03:38 AM
Hey guys.

Here's my problem, I've had my G75 for around 7 months now and lately I've noticed it's been running slow while initially opening a program (mainly on an internet browser).
for example, opening Google Chrome can take up to 30 seconds to load my homepage (Google) while it sits on a blank screen saying its loading.
Once this initial opening is done it usually runs fast as usual.
I have tried on 3 different internet networks so I know that's not the problem.

I have also noticed that it just takes some time to respond to programs generally, but much less frequently.

Anyone have any idea what the problem could be, or even just some general ideas on speeding up my laptop?

Thanks

SpeedyPC
03-22-2013, 04:00 AM
When was the last time you've defrag you're HD, and do a regular disk clean up to clean out any left over on you're HD.

Most cases you're internet broadband might be having a bad pin connection when receiving in & outbound traffic

Aether92
03-22-2013, 04:08 AM
I've been doing regular defrags and cleanups thinking that might have been the problem but that hasn't helped...

Vicodin
03-22-2013, 04:09 AM
How much ram you have? If you have 2gb of ram to spare download fancy cache. You wont regret it.

Pitcher@asus
03-22-2013, 04:10 AM
i think it is system problem, could you do the defragment than try again, if you agree, back your data and recover OS try again.

SpeedyPC
03-22-2013, 04:16 AM
I was thinking if you've might have installed something on you're computer by mistake, some drivers can cause problem slowing down most case when installing a software can trigger to slow down problem and I'm not 100% sure about Memtest86+ that I've heard about??

Clintlgm
03-22-2013, 04:16 AM
Have you run any hard drive analysis on your hard drive you may be having some bad cluster that are causing problems? Also what AV are you using, that can cause problems. If you can eliminate any hardware problems it just might be time for a fresh install of windows or a roll back to a time when you just had windows installed and your main software running with no problems?