PDA

View Full Version : G73SW DCP_WATCHDOG_VIOLATION when mouse inactive for 4min20sec - Windows 8.



Edgeman
03-25-2013, 12:50 AM
When ever I don't move my mouse for about 4 minutes 20 seconds, my laptop crashes and comes up with "reboot & select a proper boot device or insert boot medium in selected boot device".
Sometimes I get this message: "The Windows must now restart because the Remote Procedure Call (RPC) service terminated unexpectedly system process terminated unexpectedly"
I've had a look at the event viewer and this problem repeatedly appears:
asus Provider Name="Microsoft-Windows-Kernel-Power" Guid="{331C3B3A-2005-44C2-AC5E-77220C37D6B4}" / EventID>41 /EventID Version 3 /Version Level 1 /Leve Task 63 /Task

It always restarts OK after powering off and rebooting, sometimes collecting info to send off to MS. Other than that, it's working fine, so long as I keep my mouse moving. Very frustrating as I use this PC for work and must always remember to SAVE. This laptop has already had the mobo replaced under warranty with a defective charging port, it's now about 20 months old.

I've searched extensively on this issue and haven't found anyone with the same consistent problem with this error, theirs is usually a random crash or happens during gaming.
Most people seem to startout thinking it's a software issue as I did, but the majority of resolutions are pointing to hardware issues.
This particular Laptop has two 750GB HDD's that aren't SSD.

I'm using a Logitech MX Revolution mouse, have tried disconnecting it with the same result.
I've tried a system restore to a date before the issue began (had installed AcrobatX Pro, Skype 6.1, latest Nvidia Drivers, RaceRoom Racing & Java 7 update after this restore point).
I've tried an automatic repair using the Windows 8 disc.
I've tried turning off all hibernation, screen sleep, disc shutdown, screen savers, etc.
I've scanned my machine with spybot S&D, I use Avast antivirus.

I guess next is a full reformat and rebuild to prove if it's definately hardware or software related before a return.
I'm hesitant to do this as I am in the middle of some big design jobs and don't really want to load everything back on, but I'll have to anyway after a longer wait if I do return it.

Any ideas before I bite the bullet and try a full rebuild?
Let me know if you require any more info (minidump/memorydump etc.)
Cheers.

Pitcher@asus
03-25-2013, 02:31 AM
i hope this is able to help you http://www.eightforums.com/bsod-crashes-debugging/6903-windows-8-dpc_watchdog_violation.html

Edgeman
03-25-2013, 11:49 PM
Thanks for the link. I followed another link from there which gave me a few more ideas.

https://www.asus.com/support/Knowledge/3/252/G73Sw/CA115EA3-0E98-99A6-0D5B-3BE9438294D8/

I have never used Daemon Tools or Alcohol % on this machine.
I use Avast AV which is for Win8.
I don't have an SSD drive installed which seems to be the most common cause of this error (firmware), though my drives may be hybrid.

I ran Asus Notebook PC Driver CD from C:
installed all drivers - except Express Gate Cloud and Bluetooth which failed.
Enabled .Net Framework 3.5
On reboot, message: "P4G only on Asus", & "install ATK0100 driver"
Repaired ATK driver (already had latest version), rebooted, no more messages.
Ran Asus update utility, no updates required.
Just on desktop with no aps open, after idle for 8 min 20 sec, PC error DCP_Watchdog_Violation.

This morning my PC has been running idle for over 30 mins with no BSOD ... perhaps my problem is solved, but I wont get too excited just yet.

Cheers.

Edgeman
03-26-2013, 11:29 AM
Glad I didn't get excited - it's not fixed.
I didn't realize at the time, but my laptop was running on battery this morning - charger plugged in to laptop, but powerpoint off. Later on I had it on mains and the error occurred again. Tonight I tested it on battery, left it for over 20 mins with no problem. Turned on the powerpoint and in 4mins20, FAIL.
The "violation" only seems to be happening with the charger on.
I got the DCP_watchdog sad face, then it restarted - but no WLAN. I restarted it again, WLAN OK.

Does this point more toward a hardware issue or should I still be faffing around with software?

dstrakele
03-26-2013, 01:11 PM
1) Does Logitech offer a more recent driver or software for your Mouse?

2) Is there a "Power Management" tab in your Mouse "Properties" in Device Manager where you can UNcheck the "Allow Windows to turn off the device to save power" option?

3) If you uninstall Avast Antivirus, does the issue persist?

Edgeman
04-08-2013, 11:43 PM
Thanks for your help and suggestions.
After a few more problems began developing, I bit the bullet and did a reformat and clean install of Windows 8 and all my problems have stopped.
I believe the problem was laziness on my part in the first place. As I'd only recently rebuild Windows7 after a Mobo replacement, I installed Win8 over the top as an update (I never normally do this). This kept all the Win7 legacy drivers and Logitech bloatware which I now believe was the problem. After a clean install, all this was removed.
The only ASUS drivers/utilities I've had to install to date are:
the ATK package (for function keys),
Card Reader (for SD slot),
Touchpad Synaptics (so it auto turns off when mouse connected)
Realtek HD Audio drivers.
All availabe from HERE. (http://www.asus.com.au/Notebooks/Gaming_Powerhouse/G73SW/)

I haven't yet tested Bluetooth or USB3 as I don't have any USB3 devices.
I don't seem to need the Creative THX MUI for audio.
LAN_Realtek & Chipset_Intel must already be in the Win8 install as I've had no issues.

Cheers.