PDA

View Full Version : Asus G46VW Unable to Play Far Cry 3 Even on Low Settings



d34ds3c
03-25-2013, 05:05 PM
I am getting really frustrated with the new Asus G46VW laptop that I have, that is allegedly a gaming PC. I used to build and OC pc's in the early 2000's, but haven't done much gaming in 5+ years. I am a systems administrator in a health care facility, and know how to operate and configure a computer, although I can't make this game playable no matter what I do.

My issue is an incredible amount of lag, on any settings. I have gone to the xml file for my profile and edited it so that it will show fps, but it does not. Also, in this XML file all of the settings are high or above, but in game they are all medium or low. I have tried changing it from DX11 to DX9, I have turned off vert. sync and anti-aliasing, but all to no avail. I have uninstalled and reinstalled the game, and set UPlay to use the nVidia 660M by default instead of the Integrated Intel GPU. This machine has 8gb of ram, the nVidia 660m, and an i5 processor. I know an i7 would be ideal but is this game really unplayable with my system settings?? It is so laggy that it is unplayable, and it is getting extremely frustrating.

Has anyone else had this issue? Are my system specs really so low that I can't even play a modern game on low settings? I would love some help, or next steps as far as troubleshooting what the issue is. Thanks.

Nivaku
03-25-2013, 05:40 PM
Have you tried playing some other game instead, and does that perform similar to FC3 or poorly?

GottiBoi55
03-25-2013, 05:56 PM
I am getting really frustrated with the new Asus G46VW laptop that I have, that is allegedly a gaming PC. I used to build and OC pc's in the early 2000's, but haven't done much gaming in 5+ years. I am a systems administrator in a health care facility, and know how to operate and configure a computer, although I can't make this game playable no matter what I do.

My issue is an incredible amount of lag, on any settings. I have gone to the xml file for my profile and edited it so that it will show fps, but it does not. Also, in this XML file all of the settings are high or above, but in game they are all medium or low. I have tried changing it from DX11 to DX9, I have turned off vert. sync and anti-aliasing, but all to no avail. I have uninstalled and reinstalled the game, and set UPlay to use the nVidia 660M by default instead of the Integrated Intel GPU. This machine has 8gb of ram, the nVidia 660m, and an i5 processor. I know an i7 would be ideal but is this game really unplayable with my system settings?? It is so laggy that it is unplayable, and it is getting extremely frustrating.

Has anyone else had this issue? Are my system specs really so low that I can't even play a modern game on low settings? I would love some help, or next steps as far as troubleshooting what the issue is. Thanks.


Do you have the lastest drivers from nVidia, or Asus? (nVidia are better)
Are you playing on battery, or pluged in to A/C ? (battery doesn't have enough power for gaming)
Most video intensive games (DX11), and not so intensive games (DX9) don't play well on battery.
BTW, most "G series" don't play well on battery, my G75 gets extreamly laggy on battery (FPS below 10).
It's like watching a "slide show" ....LOL

BTW welcome to ROG Forum!

JwPwns
03-25-2013, 06:29 PM
is your laptop plugged in? if it's not , any game that turns optimus to GTX660m will lag. You will need to have it plugged in to enjoy it's full power or else gaming is not possible on battery mode, however i did able to get sc2 on high performance for an hour before batter goes out but an hour doesn't really do much.. you will have charger with you everywhere you go anyways so that shouldn't be a problem

HK-47
03-25-2013, 10:20 PM
Are you sure the game is running on the discrete gpu? For the game Tera/few others. I have to delete the profile with Nvidia Inspector then add it manually to get the game to use the dedicated gpu. I have to repeat this process every time I install a new Nvidia driver.

If you have not tried this here is the instructions:

1.) Download Nvidia Inspector

2.) Open Nvidia inspector

3.) Then NEXT TO THE DRIVER SECTON, there a Icon with a SCREW DRIVER Click that and it opens a new window with profiles.

4.) On top left side, there a slider, just type in "GameNameHERE". When you found the profile, on the same toolbar of the slider, there a icon with a red "x" on it. Click it to delete "GameNameHere" profile.

5.) Then open Nvidia control panel, go to 3D Settings. Go to program settings.

6.) Click the "add" button, go to your "GameName" folder and add "GameName.EXE" application file.

7.) After you added GameName.EXE in your control panel, Look down, there is a option to pick which processor you want to use.

8.) Click the drop down, and select Nvidia GPU.

9.) Click apply

This should force the game to use your discrete GPU. I found a few game that even though they are set to use discrete GPU they still use the integrated GPU until this is done.

Also here is a application called Optimus Tools. It is a small application that lets you see what gpu is being used. When a game is running you can just ALT+Tab out to see what is being used and if your Nvidia gpu is off.

Windows 7 64 (http://files.laptopvideo2go.com/Nautis/Optimus/OptimusTools_64bit.exe)

Windows 7 32 (http://files.laptopvideo2go.com/Nautis/Optimus/OptimusTools_32bit.exe)

Hope you get your issue resolved and welcome to the forums!

JwPwns
03-26-2013, 03:15 AM
fyi, i just tried Far Cry 3 on highest setting it's smooth and performaning great. so may be it is your optimus isn't installed correctly, just download the gpu drivers from asus website it should swich to the gtx660m automatically