PDA

View Full Version : System process causes high disk acticity, ASUS G75VW



ThS
03-26-2013, 12:52 AM
The system process (PID 4) causes a high access to the hard drives with more than 1 MB/sec. This drastically reduces the performance and the computer takes a long time to respond. Very annoying. This high disk activity lasts for about half an hour.

When the disk activity drops back to almost zero, the computer can be used normally again; however, after a few hours the high disk activity starts again. What's going on and how can it be resolved?

Cheers
Thomas

Windows 7
ASUS g75vw

chrsplmr
03-26-2013, 01:42 AM
This is something 'listening' @ port:80. Most likely your antiVirus or someSuch thing.
First I would go through 'msconfig' to see what is in 'startup' .. disable or uninstall (through programs and features)
anything that is not necessary.
Next I would look at my antiVirus .. This simply does not need to scan your computer everytime you boot.
The other is 'realTime' protection .. for the most part, only imho, if you are online doing 'trusted site' things
then this is not necessary .. If your surfing and are unsure where your searches will take you or are downloading
'things' then turn it back on.
But all in all as stated above .. SomeThing is aLive and monitoring port:80 .. this is seldom good. Kill it.
Welcome to ROG.c.

ThS
03-27-2013, 01:23 AM
I checked the Resource Monitor that comes with Windows: Local Port 80 is basically not used. So it is probably something else than what you described. In general, there is not much network activity and some of it is even blocked by Symantec Endpoint Protection.

Scanning the system for viruses led to no result.

Switching off the antivirus software (and endpoint protection etc.) for a couple of minutes, the System disc access remains..

The files that are accessed are random. It includes files that I haven't touched in weeks (such as an outdated Matlab version). I have no idea what's going on....

Tomorrow I will try the other things you suggested.

For now, do you have any further ideas?

ZeroBarrier
03-27-2013, 01:28 AM
Type msconfig in run dialog, click diagnostic startup and reboot. See if it still happens, if not it's definitely a rouge program on your notebook. Start turning back startup programs one by one till you find the culprit.

ThS
03-28-2013, 12:58 AM
I used the laptop in diagnostic mode for about 8 hours. (no network, very few processes etc.). The laptop was very fast and System did not access the hard drive.

I just rebooted in normal mode, and System accesses the HD a lot, just like before. In fact, booting took almost ten minutes.

The next step is to prevent processes from starting until the culprit is identified. Do you know any better method than randomly guessing?

ZeroBarrier
03-28-2013, 01:04 AM
Not randomly guessing, start them up one by one in the startup tab within msconfig.

Go back again and hit diagnostic startup, apply; then go to startup tab and go through the list 1 by 1, restarting your notebook after each change until you find which program is doing it. It's time consuming, but 100% effective in finding exactly which program is the culprit.

ThS
04-02-2013, 09:29 PM
Looks like the problem is solved. This is what I did since my last post:

- deactivated multiple programs from the startup menu is msconfig. This included programs that did not sound crucial (e.g. by manufacturers other than Microsoft, Asus, nVidia or antivirus). After rebooting and waiting a couple of hours, the problem remained.
- installed Process Monitor (procmon.exe):
-- in Tools --> Process Tree, only one other process is running under System (PID 4), namely smss.exe (432) ==> looks normal
-- in main view, configured to only show File System Activity (i.e. deactivate Registry, Network, Process and Thread, and Profiling Events)
==> during the high disk activity, files from the antivirus program Symantec were very active
==> Conclusion: Symantec is the culprit
- uninstalled Symantec
- installed other antivirus program

The computer looks goods after one day. I hope that it stays like this.

It turns out that it was the antivirus program after all. What was mean is that even briefly deactivating the antivirus program had not helped (post #3). Thanks for your help.

Cheers.