PDA

View Full Version : G75vw: Linux Mint Installation from Hell (very long post)



Sycokinetic
03-26-2013, 05:52 AM
So, last Monday I decided to try a couple things in C++ on Windows 7 and, once again, stumbled upon more "missing .dll file" errors. Sick of these, I decided to dual boot some version of Linux, did some looking around, and decided upon Linux Mint 14 KDE (second choice was Ubuntu 12.10).

Simple enough right? Yeeeeaaaaah no. It took my friend and I three days to get Linux and Windows 7 to both boot from GRUB, and I figure I should post what we had to do.

To start, some of my PC's stats at the beginning of this:

Unit Model: G75VW-BBK5 (stock hardware)
BIOS / UEFI: version 207
OS: Windows 7 Home Premium

So, if your PC matches this, you in particular might want to read on.

If you load Linux Mint from a boot disk, launch it, and get stuck with a gray background with a blinking underscore for 10 minutes or so.... read on. That's what initially happened to me.

Also, if you get stuck on any variant of this:
https://photos-4.dropbox.com/t/0/AAC9oVrUf-z8RGaotO8ECjpIeMTJpKLgl3lkNyKRLnRFRA/12/13174267/jpeg/1024x768/3/1364274000/0/2/IMG_20120829_022902.jpg/LGd1Ntktj2-T7R_WuQhbAlEgLW8qAyhNsYzX3SJlQ2s
read on. My laptop also did this at one point.
- Note that the appearance of a heiroglyphic screen in general is normal. I'm referring to it getting stuck on this screen for about 10 minutes in the same manner as I just described.

Finally, read all of this before doing anything; and I'm not taking responsibility for any problems that arise from following my lead. The problems I had appeared to be extremely hardware dependent, and I do not trust these steps to even be "portable" to an identical model. Nor do I know how many were truly necessary. This is simply what worked for me, and it may help some other poor soul to figure this out with less trial and error.

I would also suggest having someone experienced alongside you while you do this. I consulted a friend over IM on a separate PC, and he helped me tremendously.

Be aware that this is not an in-depth guide. I've linked detailed instructions where vital, but things like making your partitions and running the Linux installer should be easy to find elsewhere. This post is long enough as is.
_____________________________

The first problem I had was with a Linux Mint 14 KDE boot disk. The problem was that "gray screen w/ underscore" I described above. I tested this with 3 different CD's and 2 downloads of the .iso. All three yielded this result.

I then tried loading it from a flash drive. This produced the heiroglyphic screen.
- It also did this for 64-bit Ubuntu 12.10.

After much digging, contemplating, consultation, and prayer, it appeared that I needed to update my BIOS from v207. This was because I had no option to toggle CSM or SecureBoot, both of which had been reported by others as necessary toggles to run Linux.

I followed this thread's instructions, updating to v223: http://rog.asus.com/forum/showthread.php?28046-ASUS-G75VW-NEW-BIOS-v223&country=&status=

My research found two methods of updating the BIOS that were provided by Asus. One was the WinFlash utility launched within Windows. The other was the Easy Flash utility launched within the BIOS. I suggest the Easy Flash method because it distances the process as far from Windows as possible and is simpler to carry out.
- It isn't instructed in the OP of that link, but remember to extract the BIOS file DIRECTLY to the USB drive. The reason for this is the same reason for using Easy Flash - distancing from Windows. Extracting to \Downloads or whatever and copy/pasting to your USB drive gives Windows more opportunity to screw up your file.
- If you must use WinFlash, use the latest version of the Windows BIOS Flash Utility (v2.41.1 for G75vw) provided by Asus. Use the guide they provide for your model. The G75vw's is here: http://support.asus.com/Documents/detail.aspx?SLanguage=en&p=3&m=G75VW&s=388&hashedid=gkyI9iViQxXxueTd&os=&no=1802

Do not update your BIOS unless you are 100% sure you need Linux. If you mess this process up, you will brick your laptop and will have to get it repaired. "Mess this process up" can refer to something as mundane as copying the file into the USB drive rather than extracting directly to it.
- Later I'll add an md5 hash here for v223, so you can check the file in your USB drive.
- I personally do not advise doing this is your laptop is no longer under warranty. If it is still covered, then problems using WinFlash or Easy Flash should be covered. Using any third-party program will certainly not be.
- There is a reason people can be ritualistic about the process of updating their BIOS. Don't take shortcuts.

Following my BIOS update, I still did not find any CSM or SecureBoot options. However, both Mint and Ubuntu now loaded from their DVD's properly; so I was happy.
_____________________________

The next step was resizing the Windows partition. This was the only part of the installation that went according to plan. I suggest using Windows to resize the partition because, well... you're resizing the Windows partition. Use Linux for all the other partitioning stuff, but I let Windows handle itself to minimize risks to that OS.

Shrink it by the amount of storage you want to assign to Linux plus the amount you want to assign for swap. Remember that this value is in megabytes within Windows.

After doing this, make sure Windows still works.
_____________________________

I'm going to go out of order of my experience and skip straight to what you need to do now. Don't worry. It was just more trial and error stuff that you don't have to worry about now.

You want Linux and Windows booting in the same mode if at all possible, either in EFI mode or in Legacy mode. This means you need to figure out what mode Windows is booting into. (Hint: it's probably EFI, but you want to make sure.)

The only way I know to do this with 100% certainty in Windows 7 is to find the file X:\Windows\panther\setupact.log. Open it in notepad and find the value "Callback_BootEnvironmentDetect." A value of "FirmwareType 1" or "BIOS" means it's in legacy mode. "FirmwareType 2" or "UEFI" means EFI mode.

My G75vw unfortunately did not have this file, however it did have a 200 MB "EFI" partition listed in Windows's disk manager. This is a good indicator that Windows is booting into EFI mode.

I myself ran into a hiccup when trying to boot Linux Mint 14 KDE into EFI mode with a CD. For some reason it did not have the option. However, booting with a flash drive DID provide the option.
- My Ubuntu 12.10 disk did not have this issue. I can boot it into either mode. (I will also be filing a bug report to Mint soon.)

To boot Linux into the appropriate mode, open your BIOS and go to your Boot Order. Load the appropriate drive first. Note that there should be TWO of the same drive - one with the prefix "UEFI:". Load the "UEFI" one if Windows boots in EFI mode. Load the other if it does not.

If you are booting in Legacy mode, your startup screen will resemble this one from Ubuntu (i.e. it will be colored and pretty and such): http://pix.toile-libre.org/upload/original/1347445119.png

If you are booting in EFI mode, your startup screen will resemble this one (black and boring and GRUB): http://pix.toile-libre.org/upload/original/1347445084.png
_________________________________

Now Linux should be booting properly, and you are ready to install.

Launch the installer. If you are dual booting, remember to click "Manual" on the partitioning options. The default option is to use your entire disk for Linux... which would erase Windows.

Remember to select the free space that you created when you resized Windows. Make your ext4 partition and your swap partition. If you are booting in Legacy mode, you will need a 2 MB boot partition (Mint will use 1 MB of this as padding, leaving your 1 MB boot). If you are booting in EFI mode, Mint 14 and Ubuntu 12.10 will use the 200 MB boot partition created by Windows.
_________________________________

If you restart your PC now, you should find that you have options to boot Linux, Windows, and a few other maintenance things. However, I was not able to launch Windows from here (i.e. GRUB). I could still load Windows if I changed the boot order, but GRUB could not boot Windows.

This means you need to run Boot Repair in Linux, which means you have to install it.

In Mint, open Konsole and type "sudo add-apt-repository ppa:yannubuntu/boot-repair". Enter your password and type y. Let it download and install it with whatever package manager you choose.

Run it. My friend checked its settings, and the defaults were correct (i.e. I honestly have no idea what they should be). Choose "Recommended Repair" and let it run. When it is complete, you should have access to Windows again after restarting.

https://help.ubuntu.com/community/Boot-Repair
________________________________________________

After all of these, I had a fully functional dual boot of Windows 7 and Linux Mint 14 KDE. Everything after this point was tweaking Mint for stability and is beyond the topic.

________________________________________________

TL;DR

1.) Update G75vw BIOS to v223 with Easy Flash
2.) Resize Windows partition with Windows
3.) Boot your installation CD/USB in the same mode Windows boots in (EFI or Legacy)
4.) Install Linux
5.) Install and run Boot Repair

f.schultz0
04-17-2013, 01:32 AM
These are some hash sums for the 223 BIOS image that I used. Unless there are some extremely latent issues, it worked fine for me.

MD5: 7602C51DB239D6C3B7353F3DB51CFA5B
SHA1: 44C74431D6F5061B86179605EE48FE7F34906FC7
SHA256: 7497a5f273d5916dded4005d58fdc288ae622e31031572645b 0cc78a6db9421d
CRC32: 52411C86
Tiger: 6a3cc5be8e2ab0d8291d9e761dd94d20966b83808fa3ab52
Whirlpool:8cd522693c5f0a52c878410fba6e4c7e57ffa154 7dcc0805b4fd5dc2d21fb7dccca86326aa1a47f70025fbc6d8 62b78eef3efd6e22737937c0aca24d6aeff373

Note: the page is adding spaces into the hashes for some reason.

AndyMac82
07-08-2013, 12:50 PM
Hey I've flashed my bios to 2.22 and it runs fine, but how did you put linux on the flash drive? I use unetbootin and it works every time on any other pc. The option doesn't appear in UEFI or legacy to boot from the usb drive. I took Windows 8 off caz its crap, but my win 7 installation screws up once i install the display drivers. Then I have to reinstall the whole thing. Trust me there's no quick fix. So now my only options are win 8 again or linux. BTW do you know if coreboot is safe to use on this asus piece of ****? Then I wouldn't have to see the letters UEFI ever again.

Thanks in advance...

slayer2333
07-15-2013, 06:37 PM
I Managed to install Linux Mint 15 on a separate HDD from the Windows one and i can say it works pretty well except a few things:
-Installing Linux in Legacy would not provide functional Fn+F5 and Fn+F6 keys, but the boot process is the pretty one (no line codes...).
-Installing from the UEFI option (i burned a Linux DVD and i can see 2 options, 1 UEFI and one legacy) will provide semi-functional Fn-F5/F6 keys (you see the Bezel without change in brightness intensity, but you get full control after wake up from sleep). With this mode you get the ugly boot with the few selection lines and you get a verbose boot mode whatever you do(you see all the boot code lines to the Linux Desktop). You also get EFI boot by adding the boot option /EFI/linuxmint/grubx64.efi (sometime it is created automatically) on the windows drive.
Except that, everything works flawless except some minor issues with HDMI audio out (it doesn't work if you wake up from sleep when connected to HDMI) but Linux is not to blame, the exact same problem happens in Windows 8.

Quasimodem
07-15-2013, 09:03 PM
MBR is much easier.