PDA

View Full Version : Help - G74sx Thai User



kingmagister
03-26-2013, 12:28 PM
since 6/8/2011 button "shift+(percent)%" (Thai key board layout) doesn't work! please help!!:p

dstrakele
03-26-2013, 01:00 PM
If I were in your situation, I'd try changing the Windows keyboard language (see http://support.microsoft.com/kb/258824), then changing it back to Thai.

kingmagister
03-26-2013, 02:35 PM
nah , That is only button Thai prople used to change between two languages ,I can't type shift+.....
http://upic.me/i/kx/26032013003.jpg (http://upic.me/show/43975031)

Pitcher@asus
03-27-2013, 03:48 AM
please download KB Filter Driver for G74 model in utility at asus support site try again.

kingmagister
03-27-2013, 06:27 AM
KB Filter Driver v.1.0.0.3 Same condition.....already try.

kingmagister
03-28-2013, 04:15 PM
not working........

cl-Albert
03-29-2013, 08:55 PM
Did you buy the notebook locally with the same keyboard and have you already tried checking with your store or local support to see if it's an issue they have heard of?
You can check this link (http://support.asus.com/Hotlines.aspx?SLanguage=en) for contact information.
I'm not sure about the Thai keyboards, but sometimes the ASUS factory may need to do something with the bios to support all the keyboard functions, so you may want to check if the local service center is aware of this.

Otherwise, if you can't find a solution (if you purchased locally, your local ASUS service center should be able to help you figure it out), can you manually switch keyboard languages from the taskbar (bottom right with arrow) in Windows as the screenshot below? It's from my G75VW Win7 English keyboard notebook, but you should be able to do the same thing.

18963

kingmagister
04-01-2013, 05:44 AM
I can switch keyboard languages by that button but the extra character which use shift+.... at top second line of that button is only problem , if I use another way to switch languages that is very inconvenient , so I have already tried update BIOS since I have the button issue(and ROG 3D swich was resolved) and already contacted Local ASUS service center but can not figure it out, I really need to do something with the bios.

cl-Albert
04-01-2013, 11:29 PM
Send me (cl-albert) a private message (PM) with your notebook serial number if you are interested, but if other G74Sx units were sold in Thailand, I would think the local service center should know about solving this issue. If they aren't sold in Thailand and you purchased the unit somewhere else, it could be a different story though.

So do you mean the '%' will not appear for that key and can you get all those characters to type on the nearby '1' and '2' keys in the same row? You probably already know, but just wanted to make sure you were using the correct key combinations to get all those characters to appear.

indianacarnie
04-02-2013, 01:27 PM
since 6/8/2011 button "shift+(percent)%" (Thai key board layout) doesn't work! please help!!:p

Did it work prior to this? If so you may try a sfc/scannow system file check to find and repair corrupted system files. Or you could try a repair installation of Windows. All this is based on it working before.

kingmagister
04-04-2013, 03:41 PM
Send me (cl-albert) a private message (PM) with your notebook serial number if you are interested, but if other G74Sx units were sold in Thailand, I would think the local service center should know about solving this issue. If they aren't sold in Thailand and you purchased the unit somewhere else, it could be a different story though.

So do you mean the '%' will not appear for that key and can you get all those characters to type on the nearby '1' and '2' keys in the same row? You probably already know, but just wanted to make sure you were using the correct key combinations to get all those characters to appear. , Another key no problem,Thank you.

kingmagister
04-04-2013, 03:43 PM
Did it work prior to this? If so you may try a sfc/scannow system file check to find and repair corrupted system files. Or you could try a repair installation of Windows. All this is based on it working before.

Now I'm Original windows 8 pro. I hopefully with new BIOS .....or another things

cl-Albert
04-04-2013, 07:01 PM
Now I'm Original windows 8 pro. I hopefully with new BIOS .....or another things

Thanks for sending me your serial number and I can see it was purchased in Thailand and you are still covered under the 2-year warranty, but did you say you are using Win8 now?
Does the problem also happen in Win7?

Unfortunately, ASUS has not approved Win8 for the G74Sx, so just wanted to make sure the problem does not only happen in Win8 if we need to get your local service center involved later, but we can still work on it in the forums.

kingmagister
04-07-2013, 07:50 AM
Now i'm using win8 because I've to try my best , I have that issue since win7 ,I think windows aren't the root of problem, that supposed to be BIOS

1.since I bought this, it had some issue ROG 3D switch key near I/O not working and also this issue.
2.after that I try my best to change new BIOS update 3D switch key working but still problem with this issue.
3.I've try to change language setting but everything also set as good
4. I've try to using win 8 for hoping win 8 resolve but still the same
5.That's why I think the problem is BIOS

cl-Albert
04-11-2013, 10:13 PM
You've probably tried this if the other keys are working okay, but do you mind confirming you used the CTRL+SHIFT combination with that key (does it sound correct?) and the '%' symbol still doesn't appear?

What do you see if you try the CTRL+SHIFT combination with the '1' or '2' keys?

Actually, you only mentioned using SHIFT with the '%' key in your original post, but I'm not familiar with the Thai keyboards or the correct combination to use myself, but was asked to check this before we investigate more, so please let me know. thanks.

kingmagister
04-12-2013, 04:07 PM
"You've probably tried this if the other keys are working okay, but do you mind confirming you used the CTRL+SHIFT combination with that key (does it sound correct?) and the '%' symbol still doesn't appear?"

I confirming used shift + (second row) combination not ctrl+shift with that key and the '%' symbol still doesn't appear
and I used "grave accent" in hot key switching between languages and also supposed to type '%' (I can copy from above)and "~" (I can copy from google)

"What do you see if you try the CTRL+SHIFT combination with the '1' or '2' keys?"
I have tried in notepad nothing happen...(what's supposed to be? I can type "1" and "2" or "!" and "@"

cl-Albert
04-12-2013, 04:58 PM
Sorry I'm not more familiar with Thai keyboards and thanks for your patience.
Basically, just wanted to confirm you were using the correct key combinations (Shift + <key> or Shift + Ctrl + <key>, etc.) to show the keyboard characters you want (I'm trying to find a way for you to type the '%' key, but not sure if you are trying to do something else).

1. Yes, if you press Shift + '1' it should show "!" and Shift + '2' should show '@' and I expect Shift + '`' (the '%' key left of number '1' key) will show '~' (?).
Anyway, are you able to type any of the circled characters in the image below (I believe you cannot type the '%' key, but how about those characters on the number '1' and '2' keys? If you can type them, what key combination do you use (It should not be shift+ in my opinion (unless your right 'shift' key and left 'shift' key are different, but they are the same for U.S. keyboards that I am using) because that will show the characters in the top left of each key like '!' for '1' key, '@' for '2' key, etc. )?
The picture is a little fuzzy and I cannot see the characters very clearly (if it is easy to include a better picture that would be great, but don't worry about it right now).
If you cannot type any of those circled characters, we will want to confirm you are using the correct keyboard combinations to type them as well as check other things.

2. I'm checking your earlier replies and it sounds like you may not be able to get any of the characters for the '`' key left of your number '1' key to work? The '`', '~' or '%' characters will not appear for that key? Did it ever work and do you think it could just be a defective key/keyboard? Sorry, I'm still trying to understand exactly what is not working. Thanks.

19484

kingmagister
04-13-2013, 09:01 AM
In the green circle (sorry for picture) , I can switching to Thai keyboard layout and type it "+" "๑"(Thai number 1) "๒" (Thai number 2) I can
type all of it but "~"(in U.S. layput) or "%"(Thai layout) or "`" (clearly I can not type any of that). The problem key used to switching between two languages.

I can use all combination Ctrl,alt, left Shift , Right shift .....no problem

kingmagister
04-23-2013, 11:04 AM
Hi there , In this case I must hold a little bit more (shift+.....) that symbol would be appeared , case resolved thank you.