View Full Version : G75VX Help!

04-13-2013, 09:20 PM
I have recently purchased a laptop G75VX and I am trying to use Nvidia 3d Vision 2. It says on my computer that there is a lightboost technology and the guy who sold me this computer from Memory Express said that I can play 3D games on this computer. I am trying to play games in 3D but I cannot seem to locate Set-Up Streoscopic 3D on the Nvidia Control Panel. I tried to read what other people posted but I have no clue what people are saying...I am very new to the computer vocabularies. Please help. Thank you.

04-13-2013, 09:40 PM
What is the exact model of your VX?

04-13-2013, 09:51 PM
Asus G75VX V3GM Intel Core I7 - 3630QM 2.4 GHz 12 GB RAM Nvidia GEFROCE GTX 670MX 670M Windows 8 - 64 Bit

04-13-2013, 10:21 PM
It probably has 3D capable screen but just to make sure:


RH71 or DH72 or FH71? Which one of these. V3GM is not sufficient for me to differentiate the model.

04-14-2013, 03:01 AM
It is the first one RH71. I got an answer from ASUS they told me that I need a 3D Monitor...Anyways regarding this laptop. Do you know why it gets a bit choppy when I play games? I play on high quality and even if i lower my settings it still is choppy. By choppy I mean like small lags in between games but no that often happens every 3-4 minutes

04-14-2013, 02:19 PM
Yes, your laptop has 60Hz screen and not a chance to play 3d games on it. The laptop is only 3d capable if you decide to attach a 120Hz (or higher) capable monitor via HDMI or similar.

The games could be laggy because you did not connect it to the wall (A/C) while playing. Gaming only on battery is not so nice on our laptops because the graphic card downclocks.

04-14-2013, 05:16 PM
It's always plugged in though...I updated my drivers and the games I play CoD Black Ops, MW 2, 3 meet the minimum requirements.

04-15-2013, 08:49 AM
Yes, your monitor runs 60Hz and you will not be able to enable 3D. For gaming lag, try to update video drivers,maybe there's something wrong while changing parameters for searching to enable 3D ^^

Download lastest driver from nvidia website and select, when prompted, "clean install". Give a try.