View Full Version : I'm not 100% sure where to post this Comodo Rescue Disk problem with G75VX

04-25-2013, 06:12 AM
G'day all I need you're help please,

I've burnt the latest Comodo Rescue Disk ISO file to DVD and I cannot boot with CRD, because I'm having the same similar problem from these people see link https://forums.comodo.com/comodo-rescue-disk-crd/cannot-boot-with-crd-t93874.0.html

Has anybody having the same problem on the ASUS Gaming laptop because all my drivers and BOIS are fully up to date, for those who is willing to trying COMODO Rescue Disk (CRD) is a bootable disk image with COMODO Cleaning Essentials (CCE) for Linux embedded. CCE for Linux is a powerful virus, spyware, rootkit scanner and cleaner which works in both GUI and text mode. CRD works more efficient than CCE for Windows because it cleans your system before Windows operating system is loaded. It is designed to be used when malware embeds itself so deeply into your system that CCE for Windows cannot clean it or Windows cannot start because of any infection or abnormal system change. CRD also provides you with tools to explore files in your hard drive, take screenshot and browse web page.

Latest Comodo Antivirus Engine for Linux v2.0.272069.1 Download link:
size: 55.9 MB (58,707,968 bytes)
md5: ab796907df83fea76869ee585999c7a3
sha1: 20419a3daec806364d8506868c3fea5b07bae544

I can boot from Macrium Reflect Free Windows PE Rescue Disk, I haven't tried boot from Macrium Reflect Free Linux Rescue Disk yet I'll get back to you asap.

Thank you

PS. Edit: As I said I can boot into Macrium Reflect Free Windows PE Rescue Disk, and also I had to double check if I could boot into Macrium Reflect Free Linux Rescue Disk 'YES' I can I wasn't to sure if this was a Linux related problem. Could you please confirm me if you can or cannot boot into Comodo Rescue Disk image with COMODO Cleaning Essentials (CCE) for Linux on you're ASUS G series gaming laptop as I cannot.

04-25-2013, 06:47 AM
hope this thread can be hlep you.http://betanews.com/2013/01/22/comodo-rescue-disk-2-0-combats-even-deeply-embedded-malware/
and download form http://www.downloadcrew.com/article/29293-comodo_rescue_disk.

04-25-2013, 11:08 AM
See PS above for more update detail problem.

Thank you.

04-28-2013, 06:57 AM
It seem like all the ASUS G series laptop users are getting very quite on the "Western Front' and it seem like nobody isn't coming out of the fox hole, confirming me if you can or cannot boot into Comodo Rescue Disk image with COMODO Cleaning Essentials (CCE) for Linux on you're ASUS G series gaming laptop as I cannot :(:p:confused:

04-28-2013, 07:53 AM
I only know you can do the same with AVAST but without a CD and it works no problems. But that’s on Windows.

Uhm i could try it with my virtual system if you want you only need to give me that download link and i can test it.

04-28-2013, 10:10 AM
I can boot regular LINUX installations on my G53SX usually. There are a few versions of the LINUX kernel that have bugs on the G-series hardware.

04-28-2013, 10:34 AM
Short answer: Can't boot into.

Long answer:
Linux is not equal to Linux. Depending on Kernel option and Kernel modules/drivers a Linux is build with it can work on a specific hardware or not.
The problem in this case is the nvidiafb version used by COMODOs linux distro. It did not support the 670MX.
For a strange (better: IDIOTIC) reason even the boot option for text mode set by COMODO did not use/fall back to vga.
If you have, or know someone with, linux knowledge the boot options (inside of isolinux.cfg) have to be modified to not use nvidiafb modul.

04-28-2013, 08:26 PM
Thanks for that great workout - just wanted to ask how to change that? I mean the command(s) i have to set to exclude that module? Checking http://xpt.sourceforge.net/techdocs/nix/disk/btmk/btmk07-MultiBootingWithIsolinux/ f.e. maybe i could use "forcevesa" if that isn't just forcing res modes. Or could it be "video=ofonly" as i also found some "video=intelfb:1024x768" string. But as there are so many forums, wikis etc. i can't find a site explaining these commands in detail. Ah - i just found http://clonezilla-sysresccd.hellug.gr/boot-params.html so forcevesa should do the trick either "noload=modulename" might be better option - but i am unsure if the second command is just as simple?

And yeah - you're right the text mode should be way more compatible.

Btw: someone knows how to boot with that commands using Grub4Dos? It seems it doesn't know these commands. Okay found out just kernel allows commands and initrd does not? So taking the following as a mix:

kernel /comodo/boot/bzimage rw root=/dev/null vga=normal forcevesa
initrd /comodo/boot/rootfs.gz
it started booting but did halt at same state again. So any tipp on that? Else i'll try to get a boot on the iso file directly.

Changed the iso (with another entry to boot with forcevesa), set up loading with memdisk, got it to start booting but even doesn't boot that far. As with the screen posted here (http://forums.comodo.com/comodo-rescue-disk-crd/cannot-boot-with-crd-t93874.0.html;msg679000#msg679000) it halts at interpreter enabled. So this is some problem with memdisk? Or what to do now? Don't wont waste another CD again.

04-29-2013, 12:05 AM
forcevesa should be the best.
noload is not as good, since you won't know what it will use instead.

That's my slightly-educated $0.02.

04-30-2013, 05:59 AM
Thank for the feedback and I thought their were further problem with Comodo Rescue Disk image with COMODO Cleaning Essentials (CCE) for Linux, however thanks to Karrde for pointing out the problem because I couldn't be able to understand the software issue and how to find the problem. Hopeful diNovoM and myself will try and report the issued with Comodo, problem is Comodo aren't listening when I try to report a bug problem on CRD & CCE.

04-30-2013, 01:30 PM
Found out why forcevesa/noload didn't work:

I thought there are so much linux distros, maybe CRD's doesn't know these commands and so it is. I searched and found out it uses Silatz Linux. The available commands are listed on their hp (http://doc.slitaz.org/en:handbook:livecd). Btw. no idea why comodo left an french version of the options in the isolinux folder.

Anyway i tried " vga=795 no387" " vga=normal no387" "vga=791", non of them helped, resp all of them didn't boot that far as the original image (first/third entry just showed black screen after loading the kernel, second halted at trying to load the kernel).

What i might try next (don't got time now) is a normal boot with irqpoll, maybe it is even another problem. Still i wanted to ask if anyone got an idea how to do that with these less available commands? "boot options (inside of isolinux.cfg) have to be modified to not use nvidiafb modul".

I even do wonder that module shall load reading the options of Silatz Linux "The SliTaz-built kernel has few core modules, compensated by loading others on-demand. This means few modifiable parameters are available at start-up."

Btw. another link helpfull for boot-problems/graphic options: https://wiki.ubuntu.com/PowerPCKnownIssues

04-30-2013, 02:26 PM
Keep on digging diNovoM and keep sending the screenshot to Comodo about the CRD problem, just remember to follow the Comodo bug format report guidelines the way they want it see link as example see link while you report the issue on CRD forum in a new topic.


PS. I've already post my bug report issue with CCE, and still didn't get any feedback.

04-30-2013, 09:22 PM
My first try:

LABEL Enter the Graphic Mode
kernel /boot/bzImage
append initrd=/boot/rootfs.gz rw root=/dev/null vga=normal nofb nodrm video=ofonly xmodule=vesa

Working so far. (I have not tested comodo application itself but it starts now.)

04-30-2013, 11:49 PM
Thanks for the commands. They do work - could boot and run a scan. I wonder why either some commands aren't listed on Silatz HP or no list of commands for Comodo CRD (if they added some) are available.

Well i could have taken a look into http://ftp.uni-kl.de/pub/linux/knoppix-dvd/knoppix-cheatcodes.txt. I guess the most/all isolinux commands can be executed not matter what the Silatz HP writes ... To bad i found that link just now, on direct search of commandlist for nofb nodrm etc..

05-01-2013, 05:49 AM
Karrde I'm gunna kiss you in a minute ;) now how am I going to explain this issue to Comodo, diNovoM have you manage to explain the issue with Comodo as Karrde gave you the magic key to open the door on CRD.

05-01-2013, 10:10 AM
To be perfectly honest, I'm more curious why they took such an esoteric distro. I've heard of a lot of different distros, but that one was new to me. The bigger distros like Ubuntu, Mint, Fedora, etc usually have better support for hardware (well, maybe not Fedora so much).

05-01-2013, 01:28 PM
I guess that "bigger" is the point. It wouldn't be possible to make such a small boot cd. Parted Magic f.e. uses 6x of space, well to be fair the non-graphic base-distro consumes just 2x of space, it seems to have better support but sure not as much as one of the big players and can't image on one of the rescue/test/.... live cds using such a big distro. Anyway at least a compatible boot option (which vesa allows when it comes to graphics) should be minimum.

SpeedyPC - you probably saw i posted everywhere but yet the novice has to wait for them to make a new release (which might be just with a new CCE version), still anyone having problem can make such a change easily. Just edit the iso - on windows like with ultraiso - by adding the known commands in isolinux.cfg, burn (or what ever way you boot the iso directly, while using the Comodo-copy-2-usbstick/Grub4DOS boot you have to add the commands in "menu.lst" to the "kernel /****/boot/bzimage" line instead of initrd - and just kernel commands will work - none of Silatz), boot and u're fine.