PDA

View Full Version : Cannot power on Asus G75VW Notebook



Alpha17x
05-03-2013, 03:19 AM
Hi guys,

I've taken good care my notebook, made sure it was clear of dust, always powered it off entirely if I was going to be gone for more than 2 hours, etc. Today I shut it down by closing the lid (I had it set to do that in power management options) it seemed to power off, everything was fine, I went to get my groceries. I come home and press power after opening it... nothing.
I look at the power supply, no light though I'm not sure it ever had one because I rarely looked at it and it doesn't have a visible LED. Either way it's either not drawing power or has no light to indicate that it is....

So I went to bestbuy and bought an after-market power supply with a clearly obvious led indicator on it, getting power, so that doesn't seem to be the issue...

So I find some instructions online on the asustek website, the usual; unplug everything, try ac with no battery, try only the battery, etc.

I eventually get to the point where it says to push the reset hole on the bottom of the notebook. There is no picture of where this supposed reset hole is, there is no label the only reference I've found for it is people very angrily demanding to know where it is on various support forums. So i'm assuming it is either very poorly labeled, buried behind components or non existent on the g75vw even though it was the g75vw support page I was reading.

Is there anything else I can try, or is there actually a supposed reset pinhole? This notebook was working fine before, I've taken good care of it and now this. And I haven't checked but Im' going to assume that its ---just--- out of warranty because that's the store with computers, no matter how much warranty you get. it will break right after.

Sorry for the pessimism this thing is just really making me mad. I just want to push power and use the damn thing. Can anyone tell me if there's anything else I can do before I throw it out and buy something else.

dstrakele
05-03-2013, 04:41 AM
Check out http://rog.asus.com/forum/showthread.php?5396-Magnetic-sensor-switch-issue-on-Asus-G53SW-XN1-when-closing-the-lid.

Pitcher@asus
05-03-2013, 06:12 AM
i think you should send back to service center to repair.