PDA

View Full Version : Asus G75 Screen has green fuzzy lines; dissapears then reappears.



HowlingKing
05-03-2013, 09:02 AM
[URL=http://s201.photobucket.com/user/DaviiPi___/media/20130503_184917_zps8c5e67f3.jpg.html]

This is what happens, when I play games or when I first boot up my laptop. It has fuzzy green lines, dissapears for a bit and then reappears again. Does anyone know how to fix this?

Before this happened, I was just using my laptop to write my assignments, I finished my assignment uploaded it and handed it in, shut my laptop screen. Walked into the bathroom with my laptop, placed it on to a bench, used the toilet (pee'd), washed and dried my hands, walked downstairs to a computer lab, proceeded to turn my computer back on and then all these lines appeared.

:(

Notes.

I have found out that, when I lift my laptop on the bottom right hand corner, off the table the screen becomes fine, but when I let it touch the table it goes all pixel-lated(?) again.

Pitcher@asus
05-03-2013, 09:31 AM
is always happen or random when you play game or boot up? it think you can use pannel check tool to check it.

HowlingKing
05-03-2013, 09:40 AM
is always happen or random when you play game or boot up? it think you can use pannel check tool to check it.

This is the first time it happened, just about 30mins ago. This green pixel thing, happends randomly. Where is the panel check tool?

Matrix Leader
05-03-2013, 10:39 AM
This happened to me on my previous G73SW when I took my laptop to the ASUS Service center to upgrade the RAM. It seems when reconnecting the laptop screen, the cable was lose.

take it to the service center to fix it

HowlingKing
05-03-2013, 10:46 AM
This happened to me on my previous G73SW when I took my laptop to the ASUS Service center to upgrade the RAM. It seems when reconnecting the laptop screen, the cable was lose.

take it to the service center to fix it

Yeah I will just do that, but have to do it on a Monday, since tomorrow will be Saturday and Sunday. I was really motivated to finish my assignment, so I could spend the weekend gaming! :(

HowlingKing
05-03-2013, 04:32 PM
So now I have found out that, when I hook up my laptop to an external screen, it works fine, but the laptop screen is still pixilated with fuzzy green lines.

Therefore it's my actual screen itself?

Apexing
05-03-2013, 06:44 PM
can still just be the connector as matrix suggested.
Hopefully it is just that, should not take a whole lot of time to fix, that is ofc if they have the time.

chri5d3an
05-03-2013, 09:15 PM
Does anyone know where to get replacement screens for the G75VX-CV012H Mine is starting to get a bad flicker.

Apexing
05-04-2013, 06:07 AM
Does anyone know where to get replacement screens for the G75VX-CV012H Mine is starting to get a bad flicker.stop trying to ninja threads.
I would guess ebay, craigslist or such sites. or directly from asus. (as in write the rma department hear if you can buy a screen)

chri5d3an
05-04-2013, 09:39 PM
wow ninja threads yeah that's what i did... and what do yeah mean "threads" it like my second post the only other post was asking about an unlocked bios. And the guy who started the thread pmed me with good news. And if it was a "ninja" then why did you even type an answer to my question?

Erian
09-12-2013, 09:57 PM
Hm, I've been having the exact same problem but it only ocurrs when I start playing games on my laptop at the highest-end specs. During Diablo III, SC2 or WoW this happens, and after a while during LoL, too. Alt + Tabbing returns the screen back to normal, but obviously when I get back the problem reocurrs. This does not happen during other times, .i.e. watching videos, using normal office suite, etc.

I think the problem appeared just after installing WoW, because my laptop was brand new for 2-3 months before that and it never happened at that time.

Based on all of this, is it also a laptop screen cable problem? I want to know before even taking it to service to back-up my data and stuff.

andrew21kg
05-16-2015, 10:48 AM
can still just be the connector as matrix suggested.
Hopefully it is just that, should not take a whole lot of time to fix, that is ofc if they have the time.
I looked into what you said, Not to long ago I got a new Grapics Card a GEFORCE GTX 260M. And I had to take my screen off to put it in of the process.
I think doing that maybe caused it to do The Green Lines.