PDA

View Full Version : Battery not charging



tcfd0415
05-09-2013, 12:28 AM
Hello all,

I've done some searching here on the forums but have not been able to find a thread which covers the exact same issue, but if there is a thread that covers this just send me there.

I'm pretty sure I know what the answer to this is going to be, but I thought I'd give it a try anyway.

Just got a refurbished G75 from New Egg and every thing is working great except that the battery does not charge. Upon initial start-up it the battery power level indicator shows 0% but says that it is charging, but within 5 min it changes to not charging and still shows 0%.

I've taking the battery out and making sure that the contacts were clean on both the battery and the port, and double and triple checked that the battery seats properly. I've run the computer without the battery in and it just shows that it is plugged in as expected.

My next step after this is to contact New Egg and see what they propose, but thought I would try here first and see if anyone else has had this issue and to make sure I'm not missing something completely obvious

Thanks for the help.

dstrakele
05-09-2013, 01:14 AM
Does the laptop start up and run on the battery alone? If so, run the laptop until the battery is completely discharged, then plug in and charge it. Does Windows now indicate it charges to 100%?

If the laptop will not start and run on battery alone, or still fails to display as fully charged, contact Newegg and request an exchange or refund. Do not let them talk you into sending the laptop to ASUS for Warranty repair. Once you do that, the laptop with its problems becomes yours and Newegg is off the hook.