PDA

View Full Version : Keyboard "working properly" but not responding



ShigityShank
05-11-2013, 04:54 PM
I have a G74sx that I got a while ago. I had to take in my computer to a shop to have the power jack replaced, and when I got it back today, the keyboard and touchpad weren't working. They are both shown to be "working properly" in my device manager, and the keyboard backlight is on. The other thing that's weird is that the keyboard will function when I go into the BIOS, but not once Windows starts up (regardless of regular or safe mode). The only way I can use the computer is with a usb keyboard and mouse. Does anyone have any suggestions on what to do to fix this?

Thanks,
ShigityShank

addendum: there have been two times in which the keyboard has worked in the OS, but as soon as i restart the problem begins again, so im pretty sure it's software not hardware.

dstrakele
05-11-2013, 08:13 PM
You could have an intermittent bad connection (heat expansion related?), but could try the following to attempt a software fix for your problem:

1) Enter the BIOS (F2 at startup) and choose to "Load Optimized Defaults", then Save & Exit.

2) Reinstall the keyboard and touchpad drivers.

If you boot up to a Linux "LiveCD" distribution and the keyboard and touchpad fail to respond, it would indicate the problem is most likely hardware. Being able to type in the BIOS makes a Windows software cause more likely, however.

Pitcher@asus
05-13-2013, 02:32 AM
could you try uninstall driver and install again, alos flash new bios and load default.
if hot help, press f9 to restore os try again.