View Full Version : I think my 3D nVidia Vision 2 glasses died...

05-23-2013, 11:49 PM
Can't seem to get the 3D Wizard to recognize the glasses being turned on. Tried just enabling via the nVidia control panel, but it still does nothing. I get the actual 3D screens, but the glasses do nothing to the image. It just looks the same as it does when you take the glasses off with 3D.

Everything used to work fine, but I haven't used the glasses in months and just tried them today. Made sure they were fully charged before using too. The little green light lights up fine, but otherwise nothing seems to work.

Has anyone seen a problem like this? Is there a way to reset the glasses hardware or something?

05-24-2013, 12:59 AM
Have you tried updating video drivers from asus support web page?

I believe that 3D glasses have a button, have you pressed it?

When you connect them to your system, what does Windows say about it?

05-24-2013, 03:12 AM
are you sure you have right connect between glasses and laptop, you mean you originally are able to use, but you can not use for put a month?
please check your 1. SW setting 2. 3D glasses IR3. 3D glasses is no problem.

05-24-2013, 05:40 PM
I haven't used them in over a month because I wasn't using the 3D feature, not because there was anything wrong with them. They worked just fine in the past. Previously I had used the glasses for several months with no issues.

As I stated above, the little green light on the sidearm of the glasses lights up when pressed indicating it is fully charged and operational. However, when I go through the Setup Wizard, and it asks to show what is out the left lens and then right lens, there is nothing different. I just see the combined images.

So for some reason it seems the 3D will not initiate anymore. Don't know if it is a hardware or software issue, but the Wizard seems to think it is hardware related. I's also using the latest drivers from Asus support page for G74sx: Version V9.18.13.1100.02