PDA

View Full Version : Solution to Slow right click menu in Windows 8



Matrix Leader
05-24-2013, 06:38 PM
One of the problems I've always faced with Windows 8 was the fact that when I right click on any file, there is a huge delay anywhere between 5 to 7 seconds until I see the right click context menu.

I did some research and some say that it may be one of the programs I've installed which adds an entry to the right click context menu that causes this slow down; but this wasn't my case as I am talking about a freshly installed Windows 8 system with no programs installed, just the drivers.

After digging around I found out the cause of the slow down and the solution.

Cause: there seems to be a problem with the Atheros Bluetooth Driver right click context menu that is causing it. Even though the moment I install the Bluetooth Driver, I disable Bluetooth completely from the Wireless control menu but that doesn't help as its context menu entry are still lying there in the Windows registry so here is what I did to get it resolved and now my right click is instantaneous.

Solution:

1) Download Autoruns (http://download.sysinternals.com/files/Autoruns.zip) then extract the zip file contents

2) Right click on autoruns.exe and select "Run as Administrator"

3) Un-check the startup item for the context menu as shown in the image below:

20886

4) Exit Autoruns then restart your computer

Enjoy instant right click speeds from now on :)


Edit: Simply upload images from your system, do not use image hosting services please.

Chino
05-24-2013, 11:15 PM
An alternative is to open regedit, navigate to HKEY_CURRENT_USER > Control Panel > Desktop and change the MenuShowDelay value to 0. Restart Windows and you're good to go.

bdubs
06-19-2013, 02:41 PM
An alternative is to open regedit, navigate to HKEY_CURRENT_USER > Control Panel > Desktop and change the MenuShowDelay value to 0. Restart Windows and you're good to go.

This worked Great. Thank you

Psychor
06-21-2013, 06:36 AM
The issue was the Atheros Bluetooth Driver. Modifying the delay was not the issue for me.

I uninstalled the driver and all is well with the world. Thanks.

TeleF
11-28-2013, 12:20 AM
Thanks for that...I just moved to Windows 8 and the right click menu was very frustrating. I don't have the Atheros driver, but did the same for my Bluetooth driver and it worked perfectly. I also tried the Regedit option, but that didn't work until I deactivated the BT menu. Appreciate your help!

TokoDude
12-03-2013, 09:15 AM
Nice got it on my G75VW and on my dad's pc Sony Vaio. so anoying.

il try to edit the register when i'm home.