PDA

View Full Version : G73jh Stuck at 1.6 GHz - Turbo Boost doesn't seem to be working



Misterturtle
05-26-2013, 08:22 PM
Hello,

I've noticed my computer running slow for the past year or so. I've finally decided to do something about it because I'm starting to play Starcraft 2. My computer starts running extremely slow when alot of units are in the game.

I'm pretty sure my Turbo Boost isn't enable, or at least isn't working. I have downloaded the Intel Turbo Boost Monitor software to see how fast my CPU is running. However, the GHz bar never changes. There is just a small bar that doesn't move no matter how many processes I run. Energy Saver symbol is always there too.

When I use CPU Speed Pro, it reads it at 1.6 GHz. I should be able to Turbo Boost to 2.8 GHz.

I have:

1.) Flashed the latest BIOS (213), however not the vBIOS, as I'm not really sure what that even does haha.
2.) Enabled Easy Over Clock Turbo Mode in the BIOS.
3.) Installed the Intel Turbo Boost Monitor Program
4.) Installed Power4Gear software/drivers.
5.) Installed Intel Chipset Drivers


Some problems I've been having:

1.) The Intel Turbo Boost Monitor doesn't change at all.
2.) I can't find a patern to it, but sometimes when I check the BIOS, the Turbo Mode is back to "Normal" instead of "Turbo".
3.) I tried to install Turbo Boost Drivers from the ASUS website, but whenever I run the setup, it says "Your computer fails to meet the minimum system requirements"
After looking into the this problem, alot of people said you don't need to install the drivers on the G73JH. I couldn't find drivers that worked, so I assume I don't need them/can't use them
4.) I cannot find "Turbo Boost" as a service in System Configuration. I've read that some people have gotten Turbo Boost working even though it wasn't being shown as a service.


Questions:

1.) Should I look into flashing my vBIOS? Would that help in this situation?
2.) Do I need to install a driver for Intel Turbo Boost? Whenever I try to install the listed driver, it says "This computer fails to meet the minimum system requirements" I was told this is normal.
3.) What is another program to monitor my CPU GHz calculations besides Intel Turbo Boost Monitoring software?
4.) Should I look into ThrottleStop? I think thats only for the G74 series right?
5.) Should I look into SpeedStep? I'm pretty sure the G73JH doesn't support SpeedStep.
6.) Why does God hate me? :P

I'd really appreciate any and all help. My computer should be running much faster than it is. Being stuck at 1.6 GHz makes my computer very very limited. I've been looking around the internet for hours now and havn't made much progress.

dstrakele
05-26-2013, 10:38 PM
Were you tinkering in the "Boot" tab of MSCONFIG? If so, return it to the default settings. See http://rog.asus.com/forum/showthread.php?24400-G74SX-Not-boosting-above-2.0-GHZ-after-reinstall.

But Hey! Slow and Steady wins the race....

Misterturtle
05-26-2013, 11:56 PM
Thanks for the response!

I haven't been messing around in the boot options, but I checked it anyways and the number of processors is unchecked like suggested in that thread. :(

I really have no idea what to try next. Twin Turbo Boost is different than Intel Turbo Boost right? I have Twin Turbo Boost installed with power4gear, but I really haven't done anything to install the Intel Turbo Boost, besides install the latest Intel Chipset Drivers.

I'll try anything at this point if anyone has any suggestions!


Is there a different way to check how fast my CPU is running besides the Intel Turbo Boost Monitor? I downloaded CPUID from this site, but not sure how to see what GHz my computer is running. Maybe the Intel Turbo Boost monitor software isn't reading the CPU correctly, therefore it isn't moving the bar at all. Can someone explain how to check my GHz on CPUID?

dstrakele
05-27-2013, 04:38 AM
1) What Power4Gear power profile are you currently running? Confirm it is set to "High Performance".

2) What is the temperature of your CPU at idle (no other applications running)?

3) What is the temperature of the CPU when running slow in Starcraft 2?