PDA

View Full Version : ASUS G75VX Windows 7 downgrade WIFI issues (Atheros AR8151)



Castle92
06-03-2013, 08:16 PM
Hi, I'm having issues with my wifi after downgrading from windows 8 to windows 7. APPERRRRRANTLY Support has no clue how to fix it (Because ASUS decided not to offer the newer G75VX's in windows 7) and that may be because I was talking to outsourced support who has clue about anything, So I figured I'd try here where the real tech people are. The network adapter is the Qualcomm Atheros AR8151 PCI-E Gigabit ethernet controller (NDIS 6.20). I've tried several things but from what I can see the other network adapter that the laptop came with was having a similar issue but it was solved, and that thread can be found here.

http://rog.asus.com/forum/showthread.php?29827-**SOLVED!**-Wi-fi-Problem-on-G75VX-Windows-7-%28plus-fn-f9-problem-solved-too%29

This ofcourse being for the 802.11ac + Bluetooth 4.0 network adapter, IN ANYCASE. I am pretty good with technology but when it comes to drivers and hardware windows can be pretty complicated, I finally got it to stop updating to the newest "best" driver for my computer which does NOT work. If anyone can help I'd really appreciate it. Also I'm not sure if I could try using a windows 7 driver for a different model ASUS if there would be any similarities or enough similarities for it to work.

If I'm doing something wrong and the link above should work for the AR8151 could someone please go through the steps of manually installing it to my laptop as windows does not think it is a possible driver for the adapter nor is there a setup file inside of the zip provided in the thread above.

rewben
06-04-2013, 02:51 AM
@Castle92, first of all, Atheros AR8151 is the ethernet card, not wifi. you can use the atheros driver for LAN at asus' support page for this.

as for your wifi, from what i have learned, there are 2 to 3 different types of wifi adapters for a g75vx (depending on the different models). i suggest you check it out from the device manager and starts from there. if you are not sure, just do a print screen of the device manager that shows the wifi adapter, or simply copy the hardware id and put it here. it might be useful to help us determine which driver to go for.

Castle92
06-04-2013, 02:46 PM
Oh wow thanks for pointing that out, I was of the belief that those were in the same card! I suppose thats why my lan works fine and my wifi doesnt lol. God im such a noob hold on let me look it up... ( minutes later )

If I had to guess from the hardware list, It's either a BCM20702a0 or a device simply noted as "network controller" in hardware. That is under "other devices" which I suppose is where the wifi will be showing up as it is not working properly. From what I have looked up the BCM20702A0 is bluetooth which I guess is wifi? again I'm not very good with hardware but maybe this information can help you help me. =]

Castle92
06-04-2013, 02:54 PM
OK herp derp I got it working, I tried installing the driver from the link on the two "other devices" and it turns out the network controller was the AC wifi which took the driver! so yay wifi! thank you so much aswell as thanks to the guy who made the driver, and someone please for the love of god tell asus support about this the guy I was talking to had no ****ing clue. In anycase Thanks a million!

rewben
06-04-2013, 03:16 PM
ah yes, that's the broadcom bluetooth. what you need to check out is the network controller in 'other devices'. i suspect the correct driver is this one (http://dlcdnet.asus.com/pub/ASUS/nb/DriversForWin8/WLAN/WLAN_Broadcom_Win8_VER6309529.zip). please try that.

edit: oh i was wrong haha! good for you :)