PDA

View Full Version : Vulcan Pro (RoG Spitfire) Stereo only and slight microphone problem



Rode
06-16-2013, 08:58 AM
Hi there!

So I bought a Vulcan Pro yesterday and plugged it in with the USB soundcard that followed (RoG Spitfire). I am however abit worried that i'm not getting the best out of them! (I have windows 7 on swedish, but ill try my best to translate)

When I go to 'Control panel' - 'Hardware and Sound' - 'Sound', the first thing I notice is that my RoG Spitfire is recognized as a speaker. Perhaps that is normal though.

When i right-click it and select 'Configure Speaker' however, under Soundchannels, all there is, is Stereo! I'd like the option of choosing quadraphonic, 5.1 and 7.1
If I go back to my RoG spitfire in 'Sound', right-click, and this time choose properties instead, go to advanced. All options presented to me in sound quality is 16 bit sound, no 24 bit sound, I run Windows 7 64 bit

Microphone. This is more of a question than problem. When i activate my mic, I can hear myself slightly! perhaps this is a normal function? its barely audible! only if I blow air on the microphone i hear it clearly! its kinda like one of those headphones hunters use to hear more clearly! so perhaps its normal?

So basically:
Why only stereo?
Why only 16 bit sound?
Why this minor feedback from microphone?

Looking forward to hearing from you guys!

Raja@ASUS
06-17-2013, 05:00 AM
Put the sidetone slider to 0 to stop hearing yourself.

You cannot assign more speakers to the Spitfire as it is only a two channel device.

There aren't any "true" 24 bit DACs left in the market (all noise shaping delta sigma types now instead of R2R ladder types), so I wouldn't worry about the bit rate being at 16 bit.

Rode
06-18-2013, 06:10 PM
Thank you for the information! Dont have to worry anymore :)

Raja@ASUS
06-19-2013, 10:38 AM
No problem :)