PDA

View Full Version : G 75 Bluetooth Driver Sleuthing,,,WITHOUT great success!!!



Drog
06-28-2013, 09:14 PM
Problem:::
Bluetooth doesn't work

Details:::
Windows7 64
G75VW-BBK5
Driver: Atheros 7.4.0.115 and Intel 1.0.13.30079
Wireless console 3 is uninstalled
Bluetooth Radio - Bluetooth Module - Hardware ID - USB\VID_13D3&PID_3362&REV_0001
Network adapters: Bluetooth Device(Personal Area Network), Bluetooth Device (RFCOMM Protocol TDI), Qualcomm Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20), Qualcomm Atheros AE9485WB-EG Wireless Network Adapter

What I have tried:::
I have already tried uninstalling and re-installing 7.4.0.115
I have even tried installing 7.4.0.150 which is for the VX and not the VW
I have tried installing just 7.4.0.115 and not the intel driver
I have tried installing just the intel driver and not the atheros
Just for kicks I have tried installing the Azurewave V7.4.0.122 driver.
EDIT 1:
I have tried running broadcom drivers from here as well http://www.broadcom.com/support/license.php?file=SetupBtwDownloadSE.exe

Questions:::
Is there anything I havent tried?
Does my bluetooth hardware ID match any drivers that I need that I am unaware of?

cl-Albert
06-29-2013, 12:58 AM
Welcome to the forums!

Just wondering why you uninstalled Wireless Console 3 and if you can reinstall it, or what problems were you having with the bluetooth (can't enable it or can enable bluetooth, but can't connect to other bluetooth devices, etc.)?

If you're having problems to enable the bluetooth, I'm using the same G75VW-BBK5 and can enable bluetooth by pressing Fn+F2 and then clicking on the bluetooth icon before the onscreen display disappears to enable it.
It's a little bit like a video game if you aren't used to it.
Hopefully the screenshot below helps, but unfortunately my mouse icon doesn't appear in the screenshot.

22431

Drog
06-29-2013, 07:59 AM
Hi cl-Albert,

1. To clarify, I can enable but I cant connect to anything. For example, I tried with and without Wireless console to turn bluetooth on, that was never the problem, however it would never detect anything, even things I know are detectable.

2 I also want to point out that when I right click the bluetooth icon in the system tray, I only get 7 options, of which "allow a device to connect is greyed out. Strange, because I have my comp set to be detectable. Is it the same for you?

3. Some extra info is that I have done a clean install when I first bought my laptop and I only reinstalled essential drivers and important utilities...I never installed the bloatware back....could it be that one of the programs I thought was bloatware was actually needed?
Anyway, I really appreciate you trying to help and I sincerely hope someone will find this post helpful if I am able to resolve it. But its looking grim.

4. One possibility is this...of the 4 bluetooth devices on my device manager only the bluetooth module is the atheros driver....the rest are microsoft 6.1.7600.16385...it seems like when I updated the drivers it only affected the bluetooth module radio and not the other 3 items. Can you confirm with me that all 4 items of yours are indeed the 7.4.0.115 atheros driver???

See pic for more info.

22446

cl-Albert
07-01-2013, 10:40 PM
1. To clarify, I can enable but I cant connect to anything. For example, I tried with and without Wireless console to turn bluetooth on, that was never the problem, however it would never detect anything, even things I know are detectable.
Hi Drog, Just wondering what kind of bluetooth devices you are connecting to (and how far away?), or if you can detect your notebook with a different notebook using bluetooth.



2 I also want to point out that when I right click the bluetooth icon in the system tray, I only get 7 options, of which "allow a device to connect is greyed out. Strange, because I have my comp set to be detectable. Is it the same for you?
Yes, check the screenshot below, but the same for me, so I wouldn't worry about it.



3. Some extra info is that I have done a clean install when I first bought my laptop and I only reinstalled essential drivers and important utilities...I never installed the bloatware back....could it be that one of the programs I thought was bloatware was actually needed?
Anyway, I really appreciate you trying to help and I sincerely hope someone will find this post helpful if I am able to resolve it. But its looking grim.
Hmmm...not sure about this, but hopefully my reply to item #1 above can help us figure it out. Everything you need should be posted on the ASUS download site although I don't know what else you would need if anything.
If you're still under warranty and want to go the RMA route for a hardware issue, this is always an idea, but hopefully we can get more ideas from others and figure it out first.



4. One possibility is this...of the 4 bluetooth devices on my device manager only the bluetooth module is the atheros driver....the rest are microsoft 6.1.7600.16385...it seems like when I updated the drivers it only affected the bluetooth module radio and not the other 3 items. Can you confirm with me that all 4 items of yours are indeed the 7.4.0.115 atheros driver???

Please refer to my screenshot below, but my bluetooth module is also using Atheros driver 7.4.0.115, and my Microsoft Bluetooth Enumerator is using Microsoft driver version 6.1.7601.17607 while the other 2 bluetooth devices are using Microsoft driver version 6.1.7600.16385.

22594

Drog
07-05-2013, 08:29 PM
OK I want to make a correction, these are the drivers that I have:

7.4.0.115 Module
6.1.7601.17889 Enumerator
6.1.7600.16385 Personal Area Network
6.1.7600.16385 RFCOMM

So it turns out that the only difference between you and me is the enumerator, yours being 6.1.7601.17607

I will try to match your drivers to see if that makes a difference.

cl-Albert
07-05-2013, 11:03 PM
Yes, I recovered the original factory image and have those driver versions listed previously. If you have an easy way to re-install the ASUS factory image, this is an idea, but it probably will not be easy or painless for you to try this.

cl-Albert
07-22-2013, 05:56 PM
fyi.
Don't know if this will make any difference, but the ASUS G75VW download site (http://support.asus.com/Download.aspx?SLanguage=en&m=G75VW&p=3&s=388)lists newer Atheros Bluetooth drivers (you should be using these if you have the Atheros AE9485WB-EG Wireless Network Adapter which is on the same card as the bluetooth, but my G75VW unit doesn't list Qualcomm anywhere if we want to double-check your wireless driver version too) that you might consider trying.

The site mentions you should update your atk driver for the newer Atheros Bluetooth driver if you want to check/try this too.