PDA

View Full Version : Asus G46 keyboard/screen not responding.



Brodidily
07-08-2013, 12:28 PM
Hello all, this is my first time requesting support here. I recently upgraded the drive on my Asus G46 to an SSD, I watched an instructional video for disassembly and added an SSD that I had cloned from the on-board HDD. I plugged the SSD into the SATA connector and powered the laptop on before snapping the keyboard back into place to ensure I had gotten it connected properly. Everything appeared to be fine so I proceeded to put the laptop back together. While doing so, the connector for the speaker component that also covers the screen hatches came off and I wasn't able to reconnect it, I powered the laptop back on to check and see if it had affected anything else - but it was just the speaker so I powered the laptop back off and continued to reassemble.
After I finished reassembly I pushed the power button and the power lights came on, but this time the screen did not. I tried plugging a monitor in through both the VGA and HDMI ports but did not get any signal, the BIOS screen did not even come up. I then realized that even pushing the power button did nothing at this point. I disassembled the laptop again and checked to ensure everything was connected the way it should be. I noticed the cooling fans were not spinning while the power was stuck on, so I disconnected the power (the power wires run over the drive bay, so I had to disconnect them once before) to prevent any overheating. I tried disconnecting and reconnecting several wires which did not change anything. I can provide screen shots of the laptop's inside later today for a better look - but perhaps someone has an idea in the mean time as to what could have caused this to happen? Any input is appreciated.

Pitcher@asus
07-09-2013, 07:05 AM
you just change HDD, why you need dismantle others?

Brodidily
07-09-2013, 11:46 AM
Dismantle others? The G46 doesn't have a drive bay hatch and so you have to disassemble the laptop in order to add a new disk. This is all I did, and when I finished reassembly and powered the laptop on, the power lights would come on - but nothing would come up on the screen (not eveven BIOS), keys were unresponsive, and the power button wouldn't even power the laptop off.

Dreamonic
07-09-2013, 08:31 PM
This is my take on it, but powering your NB up during the reassembly with certain connectors not connected that you may have missed or other will cause error messages during POST and will stop the boot process from continuing. Now add a new drive into the equation while during controller communication of this device, you power off because it booted so that you could reassemble everything in working order knowing it should work after, may have corrupted something in the BIOS. I would suggest unplugging power and start disassembling your G enough to get access to remove the CMOS battery to clear it and or double check to see that you didn't pull any female pin connector ends out and that all the connections touched in the disassembling process, are properly mated back in place.

When you say, "Everything appeared to be fine" are you saying that it booted successfully into Windows or that it just made POST before shutting it down?

I need this clarified.

Brodidily
07-10-2013, 12:02 PM
Dreamonic, thanks for your reply. When I said "Everything appeared to be fine" that was meant as a successful boot into Windows - that was how I was able to confirm that only the speaker component was disconnected as I tried to produce sound but did not get any. I wasn't too concerned as I use either a headset or a monitor with speakers when using this laptop. I had thought about trying to reset the CMOS battery, but since I have minimal experience with Asus BIOS I didn't want to tamper with it and risk doing even more damage. I will try resetting the CMOS battery and QC all female connectors again when I get home from work this afternoon.

Edit: If after resetting the CMOS battery I am able to get video on the screen and responsive keys - are there any settings in particular I should verify in the BIOS? Or should the defaults suffice? Thanks!

Dreamonic
07-10-2013, 04:35 PM
Thanks for clarifying.

Yes, check and re-seat everything again and then clear the CMOS.


Edit: If after resetting the CMOS battery I am able to get video on the screen and responsive keys - are there any settings in particular I should verify in the BIOS? Or should the defaults suffice? Thanks!

Just be careful when taking it out of it's holding socket. Defaults will suffice.


PM sent.