PDA

View Full Version : Asus G74sx USB 3.0 not working properly [solved]



Bekarasha
07-08-2013, 08:27 PM
Hello,
Recently I re install windows 7 because I've got new SSD. I did Install all drivers from CD that comes with laptop and than did live update. Now I've notice that is I plug in my iphone or camera to usb 3.0 devises get energy and start charging but if I go to "My computer" to get phonos I do no see devises. I did try external HDD its not working as well :( What can be a problem?

Pitcher@asus
07-09-2013, 02:03 AM
please remove USB charger+ try again, also download from asus support site to new drivers and utilities version.

Bekarasha
07-09-2013, 09:04 PM
I did uninstall all USB chargers and all what related to USB 3.0, restarted laptop and installed fresh drivers that I've got from asus support site, but still same problem, I can charge devises but not view my photos

fakunchas
07-11-2013, 04:51 PM
try again with other usb 3.0 device.
I have 2 HDs in an exterior case. One works perfectly in USB3, the other performs in USB2.

cl-Albert
07-11-2013, 07:04 PM
I did uninstall all USB chargers and all what related to USB 3.0, restarted laptop and installed fresh drivers that I've got from asus support site, but still same problem, I can charge devices but not view my photos

1. Not sure if this is really the problem, but expecting your devices don't charge on battery power, standby, or shutdown mode (?) if you've removed the USB charging software, so if they still are, double-check under add/remove programs to confirm both the Asus USB Charger Plus and ASUS Ai Charger software have both been removed. We may also want to check your bios settings.

2. If nothing else works, you might try installing the critical/important updates for Windows (don't worry about the optional updates), but maybe we should check driver versions and device manager screenshots with other G74Sx owners first.

fakunchas
07-12-2013, 12:09 AM
hope this helps..
like i said i removed all asus crapware and installed the driver (which in a windows update was updated. I didn't have any major problem, except 1 hd that only performs in USB2.
23163

cl-Albert
07-12-2013, 12:20 AM
Thanks for the help, fakunchas.

Also, if you get the chance, can you please confirm if you are using the G74Sx Fresco USB 3.0 driver V3.5.30.0 or V3.5.73.0 from the ASUS download site?

Just want to make sure everyone is using the same USB 3.0 driver version.

fakunchas
07-12-2013, 09:10 AM
Fresco Logic USB 3.0 v3.5.4.0 from this thread. http://rog.asus.com/forum/showthread.php?5224-Drivers-Apps-and-How-to-s
i don't use any of the included software in the asus page except the wireless console 3 and the ATK.
It works fine.

Bekarasha
07-12-2013, 09:22 AM
Now all USB ports are not working :( Here step by step what I'm done.

I did uninstall all USB 3.0 programs, than I restarted my laptop.
Than I did download from asus support website USB3_Fresco_Win7_64_Z35300 after installation restarted again.
Went to windows update and downloaded only update available http://i.imgur.com/PaFADLH.png restarted again.
Checked devise manager and saw this http://i.imgur.com/Jc62yUf.png
If I go to asus live update program I see this http://i.imgur.com/6J3IpbI.png if I press install, it install well but after pressing "Check update immediately" its come's again. I can install it over and over again...

fakunchas
07-12-2013, 09:30 AM
i do not use any of the asus software. they are useless.

i think in your case you have to do some trial and error.. if i were you Bekarasha i would:

uninstall all usb drivers.
run driver sweeper and eliminate any potential USB entry you have.
reboot
install intel chipset drivers.
reboot
check if windows (somehow) detects your USB and install its drivers..
if usb keeps not working, then install the USB3_Fresco_Win7_64_Z35300
reboot
check if usb is working.. if not, update usb driver with the windows update
reboot
check if usb is working.. if not, download lateste usb3 fresco drivers..
install

if all this fails.. well, windows dvd to the rescue! let's Clean Install Windows..
In the past the only issue i had was that the only USB3 port was behaving like a USB2 port.