PDA

View Full Version : G73Jh No Asus Logo



cocoy
07-10-2013, 09:35 AM
Hi! I have a 2 1/2 year old asus g73Jh, Now I am problem during power on there is no asus logo, I set up an administrative password for my security but black screen appear. If i type my password even in black screen windows 7 run and start up sound started it means windows is ok but still no display or black screen, what I am doing usually I turn it off and on again several times until the asus Logo will appear and and then the administrative password proceeds so that I can start the windows 7. What is the problem of my unit is needed to repaste the GPU? Please help me before the my problem worsen. thank you. Please give me a detailed explanation how to fix my problem.

JamesNgkk
07-10-2013, 10:10 AM
I have never encountered a problem like this before. What i can suggest is when you screen is actually working, try to update your graphic card's driver. After that if you still encounter the problem, i would suspect it could be either your LCD is dying or the cable that connects your lcd to your motherboard is loose or faulty. Try to update your driver first and report back again if the problem persist.

chrsplmr
07-10-2013, 03:55 PM
Isn't the G73 the only one with the gpu in a slot, not sodered ? have you checked the internals ?
This could easily just be a connection issue as suggested or a matter of reseating the card.c.

cl-Albert
07-10-2013, 04:07 PM
Actually, sounds like everything is working except for the screen intermittently?

Attach an external monitor to confirm everything is working okay and that there is just some intermittent problem with your noteboook screen.
You may want to try adjusting your screen positition or moving it around to see if you can get a display, but this would still indicate some problem with the screen or LCD cable.

Good luck!

Dick Head
07-10-2013, 04:11 PM
Do you have an HDMI or VGA cable connected to another monitor?

Try HOLDING the Fn Key and then pressing F8 and see if it comes on.

If not you can try HOLDING the Fn Key and then press F7.

There is also the possibility that the ribbon cable to the LCD is loose. A drop of the laptop would easily unseat this connector.

You'll have to disassemble the laptop if the cable is loose. Click HERE (http://www.youtube.com/watch?v=Tp90M_N6dzs) for the procedure.

If you aren't comfortable with repairing the laptop yourself then your next option is an ASUS Repair Center. Find the closest one to you HERE (http://support.asus.com/ServiceCenter.aspx).

cocoy
07-10-2013, 05:28 PM
Thanks guys! I will try go to the asus service center to fix this issue and I think It also should be done a re pasting of my CPU and GPU because the GPU temparature is reaching high upto 90 c while I am playing crisis 2 and skyrim.

cocoy
07-10-2013, 09:47 PM
HI JamesNgkk! May I know what is the latest version of ATI Radeon 5870 driver updates? My AMD Catalyst version is 13.4. Is It the same for the display adapter driver? My adapter BIOS Version 012.017.000.004
Thanks.