PDA

View Full Version : ELAN Touchpad Settings not available



gboss
07-12-2013, 10:27 PM
Hi there!

Is there any chance to get some ELAN Settings in the Control Panel?
For me the tapping is to sensitive. I often mistap accidentally.

Is there any solution?

Thanks Gerald

cl-Albert
07-12-2013, 11:55 PM
Welcome to the forums!

I find it a little unusual, but double left-click on the touchpad icon in the notifications area of the taskbar to pull up the ASUS Smart Gesture touchpad settings software as in the screenshot below.

You can change the categories at the top, but I haven't seen anything to adjust touchpad sensitivity, so you may either want to disable the 'tap to select' function if you don't use it or press Fn+F9 to enable/disable the touchpad while typing.

Hope this helps.

23233

Flea0
07-13-2013, 08:38 AM
yeah those options are pretty laughable compared to the amount of customization I had available on my older synaptics touchpad.
No disabled zones, no cursor momentum, no sensitivity selector, no customizable gestures.
Not to mention that for some reason the touchpad fails to register movement for about one second after I click on some webpage elements...

DeltaActual
07-13-2013, 09:51 AM
Is there a way to disable it?

MikeV
07-16-2013, 05:01 AM
You can download the "vanilla" Elantech drivers from: http://www.station-drivers.com/page/elantech.htm

When installed, an "ELAN" tab will appear in Mouse settings window

Using regedit you can enable more options in the options window under:
- HKEY_CURRENT_USER\Software\Elantech\SmartPadDispla y (enable setting visibility in the UI)
- HKEY_CURRENT_USER\Software\Elantech\SmartPad (enable even more settings in the UI and directly set the option values)

I used these to set reverse (natural) scrolling on the touchpad and disabled the TP while typing.

Bigike
03-29-2014, 07:36 PM
Hi, i'm trying to fix my g750jx... LOVE THE COMPUTER, the ASUS GUI for Elan touchpad, well lets just say that its a bit of a disappointment.

The only resson i went with this over the MSI offering was because of the MSI touchpad reviews..

Any way someone could link to drivers that would work? I'd like the get the elan icon in mouse properties and be able to manipulate settings....

When I manipulate settings in Regedit, they don't do anything and revert to stock when i exit out or reboot..

Any help would be appreciated...

Bigike
03-30-2014, 01:55 PM
Found a fix

http://www.hwdrivers.com/ftp/fd_-slash-Laptop-slash-Acer-slash-Aspire-slash-V3-7710-slash-Drivers_Win8_x64-slash-/fl_TouchPad_ELANTECH_v11.6.11.002_Win8_64bit.zip

derceto
06-21-2014, 12:41 AM
Found a fix

http://www.hwdrivers.com/ftp/fd_-slash-Laptop-slash-Acer-slash-Aspire-slash-V3-7710-slash-Drivers_Win8_x64-slash-/fl_TouchPad_ELANTECH_v11.6.11.002_Win8_64bit.zip

Thanks alot for posting this link. Had issues with my settings not showing up also. This did the trick. :)

hexafluoride
07-05-2014, 09:47 AM
Exact same problem with my g750jm. I am downloading your fix now....Fingers crossed. I am hoping it also solves my other issues with this touchpad. It never disables when I type and thats quite annoying. Hopefully getting the settings back will help.

Bigike
07-22-2014, 03:30 PM
Grrr. Asus please just put a Synaptic touchpad in your next machine...

I tried to update drivers to newest Elan vanilla drivers and they are all junk, the one that actually works returns my user adjusted settings back to stock as delivered garbage...

So I came back here to download my original fix...

Stick with that one yall, it's really the only option to make you TP work and enable smart zone...

I don't care how good the hardware or what the price point is, I'll never purchase another machine with Elan anywhere in the spec sheet...

ELAN = NFG

Guest
07-27-2014, 01:24 PM
It's not a problem with Elan per se, the "full" drivers have various tweaking options. It's just that Asus decided to limit their variant of the drivers. But yes, ultimately it's a pain in the arse. Hunting on the internet for drivers from other manufacturers, tweaking INF files and registry, trying to compare versions.

Elan: Please release standard unified drivers with all settings exposed. Yeah, we are not your customer, the OEMs are, but ultimately the end user sentiment is "Elan is crap". Just like everyone uses stock Radeon or Geforce drivers, the same should happen with touchpads.

Alternatively, maybe Microsoft could include real touchpad drivers in their OS, and we'll just skip the manufacturer or OEM junk.

Anyway, I'm trying to find the latest or best version for use on another ASUS notebook. I used MSI or Gigabyte version on Win8, but now on Win8.1 I have to reinstall. The newer versions of the drivers from other OEMs I found refuse to install. I'm trying to figure out why even after editing the INF files it doesn't work.

By the way, versions numbers such as 11.6.28.201 (Acer) seem meaningless. Each OEM has its own versioning. Going by the DLL version of ETD.SYS gives more consistent versioning across OEMS. The latest I found so far is 11.142.0.0 (Aorus) from April 2014.

The second part of the OEM version number is the OEM code:
1 = ?
2 = HP
3 = Dell
4 = Lenovo
5 = ASUS
6 = Acer
7 = Samsung
8 = Toshiba
9 = LG
10 = Sager
11 = Sony
12 = ?
13 = MSI
14 = Gigabyte

Bigike
08-05-2014, 07:18 AM
I fixed it a long time ago... Using stock drivers and acer drivers for the acer or toshiba control panel i was able to get smart area to work...

Well I tweaked with it and turned on free scroll... Trying to get rid of it, not knowing what I'd messed up to turn on free scroll I reinstalled drivers... I've been trying to put the smoke back in the box for the last month now...

I hate this Touchpad, I want to find out if I can swap in a Synaptics touchpad... I like the edge swipe, but i can't activate it without smart area due to issues while I'm typing reports daily for my job...

PLEASE ELAN/ASUS Fix this to where everything is active or at least I'm able to turn everything on and have it work!

I've tried to edit EDS and some other files in the system32\Driverstore... But it wont allow the changes...

What a horrible choice for a touchpad on such an awesome machine... I'd have paid another 100$ for a Synaptic gesture touchpad...

Fail Asus... SHAME! LOL back to driver hunting...

Guest
08-07-2014, 01:29 AM
The touchpad is okay. The driver mess is not. I didn't mess with it recently so I don't remember exactly, but try the following.
I'm not sure which of the three root keys is the one to tweak, maybe more than one is needed, but they are:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Elantech\
HKEY_LOCAL_MACHINE\SOFTWARE\Elantech\
HKEY_CURRENT_USER\Software\Elantech\ (probably overrides the above)

Under the above you have "SmartPadDisplay", which includes stuff like "EdgeSwipe_Display". Setting to values to 0 or 1 might be what decides what's shown or not in the configuration GUI.

Under the above keys you also have "SmartPad", which includes stuff in the format *_ShowItem, like "ClickPad_Four_Finger_Click_ShowItem". Setting this to 1 shows an item in the GUI.

I don't remember the specifics. I'll have waste time on this again, but I haven't yet.

bill777
01-11-2015, 09:17 PM
Elan touchpad properties has no device settings tab. Need this to disable touchpad when external mouse is plugged in. Cannot find a driver download to add this tab. No other options to disable that I can find. Currently have a thick pad over the touchpad to make it useless so that I don't involuntarily switch screens while I type by rubbing against the pad (all windows options already tried). Help?

GottiBoi55
01-12-2015, 04:27 AM
Elan touchpad properties has no device settings tab. Need this to disable touchpad when external mouse is plugged in. Cannot find a driver download to add this tab. No other options to disable that I can find. Currently have a thick pad over the touchpad to make it useless so that I don't involuntarily switch screens while I type by rubbing against the pad (all windows options already tried). Help?


How to disable touchpad when mouse is plugged-in

1. Open Asus Smart Gesture
2. Click last tab "Mouse Detection"
3. Check on box "Disable touchpad when mouse is plugged-in"

http://kmpic.asus.com/images/2014/11/05/d620414a-688c-47aa-b041-ba60fd354f42.PNG

cl-Albert
01-12-2015, 05:16 PM
More information at this sticky thread below about the touchpad if anyone is interested.
https://rog.asus.com/forum/showthread.php?46928-Collection-of-Some-Touchpad-and-Touchpad-Button-related-Threads

Jaitsu
01-14-2015, 11:55 PM
To G750JM users (and possibly others): this is the driver I've been using for my touchpad. http://download.gigabyte.asia/FileList/Driver/nb-driver-u2442d-win8-touchpad-11.14.1.3.zip

With that driver, if you go into RegEdit as MikeV explained, you can enable a lot of features you can't get on the ASUS-provided driver. Not all of them actually work or are relevant to the touchpad the G750 series has (like the options for buttonless touchpads) but most do. SmartArea works much better than TP Rejection, for anyone that uses the touchpad to play games and finds that the touchpad shuts off when you use WASD controls, just FYI.

Death12312
01-19-2015, 12:28 PM
Do these fixes work for G751JT?