PDA

View Full Version : ROG CG8480 incompatible with my monitor?



Innterfere
07-14-2013, 09:48 PM
Hello everybody.

So the story is I bought an ASUS ROG 8480 two days ago from my local Best Buy after hearing good things about it from a friend & also knowing that it was on sale.

So when I got home, obviously I went to set it up and such. It worked like a charm for the day, until I went to sleep.

The next morning, I turned on the PC and heard its glorious humming. Next, I went to turn on my monitor and the screen showed nothing. A few seconds later it said "No Signal". I figured well, okay. Cables must of been disconnected or something. Nope. Everything was perfectly intact, as I had left it the night before.

Some troubleshooting before I decided to talk on LiveChat

- Tried multiple cables (2 VGA & 1 HDMI Cables)
- Tried using the TV function (That worked fine)
- Tried using the monitor showing "No Signal" on another desktop. (My Old one - It worked)
- Tried using another monitor on the computer - Did not end up working, said No Signal as well.

At this point, I figured that I might as well contact tech support. Nothing got done & I was stuck with the same problem. At this point, both me and tech support summed up my problem to do with the Video Card on the motherboard.

So what happened is I ended up returning the computer today, and receiving a replacement. To my dismay, when I got home, the daunting "No Signal" message came up on my monitor. AGAIN.

Some more troubleshooting that I tried

- Mess around with the Screen Quality on my old desktop (The one that I'm currently using to type out this message) and transfer those settings over to the new desktop (The ROG 8480) - Did not work. Tried all of the settings possible.
- Tried using the monitor on another computer (This is where things become complicated.) - The monitor ended up working on my old HP computer, however, it does not work on anything other than that.

Right now, I'm at a standstill and really don't know what I should do. Please help :confused:

TL;DR: Monitor didn't work on desktop. Summed up the problem as video card had blown out. Got a replacement. Went home, same problem occurred. Monitor does not work on any other computers except my old HP one. Unsure of what I should do now. Buy a new monitor, or scrap the idea of using the ROG 8480 & return it altogether.

Chino
07-18-2013, 12:53 PM
Welcome to the ROG forums, Innterfere.

What is the exact brand and model of the monitor that you're using?

gdantas
10-21-2013, 10:17 PM
Hi there, I got my ROG CG8480 today and it stopped working with my monitor too, it just says no signal, my model of monitor is hp pavilion 22xi ips monitor. I have tried the monitor on other computers here in my house 2 of them are even asus, what can be wrong???:confused: