PDA

View Full Version : Bluetooth and WiFi interference?



LLothar
07-19-2013, 05:27 PM
[SOLVED] Bluetooth, Wifi and BIOS update mitigated the interference and WiFi is at acceptable speeds now (still reduced though). Problem not present on all units/models.

Hi

I just got my G750 but I have issues with Bluetooth Audio. When I connect to Logitech Bluetooth Audio Adapter (in essence it's like bluetooth headphones but outputs to stereo) my WiFi drops suddenly to a screeching halt. This is a typical problem of Bluetooth - WiFi interference as they share frequencies. I e-mailed Asus support but they only suggested Windows reinstallation or returning or fixing the machine. I don't want to send it back, because it will take time (duh...) and probably its a design issue.

Could some of you test if you experience the same problem? Just connect to any bluetooth audio (so it will constantly stream) and run a speedtest for your network through Wifi. I get 25MBit without bluetooth and 0.2Mbit with.

hmscott
07-20-2013, 06:56 AM
LLother, I run with Sennheiser MM550/450 Blutetooth headphones most of the time I am on the G750, and connect via both 802.11ac on 5Ghz @ 880Mbits connection with 60+Mbit/sec throughput (thanks Comcast!), and 802.11n 2.4Ghz at 130Mbits connection with 50+Mbits/sec with no BT interference - I have sound coming through the headphones while running the tests - speedtest.net .

The 802.11ac connection is to an Asus RT-AC66U and the 802.11n connection is to a Dlink DIR-655.

LLothar
07-20-2013, 07:34 AM
LLother, I run with Sennheiser MM550/450 Blutetooth headphones most of the time I am on the G750, and connect via both 802.11ac on 5Ghz @ 880Mbits connection with 60+Mbit/sec throughput (thanks Comcast!), and 802.11n 2.4Ghz at 130Mbits connection with 50+Mbits/sec with no BT interference - I have sound coming through the headphones while running the tests -speedtest.net .

The 802.11ac connection is to an Asus RT-AC66U and the 802.11n connection is to a Dlink DIR-655.

Thanks for the info.

I actually solved the problem - I updated BIOS, WiFi drivers & Bluetooth drivers. I get 8Mbit with Bluetooth ON, which is good enough for me, a big improvement from 0.2Mbit and still enough to watch movies on Netflix. In future Ill switch to 5GHz network anyway.

hmscott
07-21-2013, 03:17 PM
LLothar, if you have reduced throughput, then you are still getting interference.

I set my 2.4Ghz router to 20mhz bandwidth, narrow instead of wide - your router might say either or both. This is enough bandwidth for me to get 50mbits/sec through the internet, I don't need faster throughput via the local LAN, so this works for me. I also set the Advanced Wireless => Transmit power to lowest setting.

Then, in the Change Adapter settings - get there through "Open Network and Sharing Center" when right clicking on the systray wireless icon - then right click on the Broadcom 802.11ac Network adapter - Click on Configure - and check/set these options in the Advanced Tab:

Bandwidth Capability: 11a/b/g 20Mhz
Minimum Power Consumption: Enabled
Disable Upon Wired Connect: Enabled (no sense keeping Wifi powered and transmitting when ethernet is active)
Power Output: 25% (that is what I use, bump it up as needed)

Those are the changes, but check these just in case I am not remembering if I changed them:
20/40 Coexistance: Auto (you could likely set this to disabled)
40mhz intolerent: Disabled (I think this could be Enabled, but doesn't matter when you set the Bandwidth to 20mhz as above)

The idea is to only use 20mhz bandwidth to reduce interference with BT, and to keep transmit power as low as possible too

Here is a note that indicate BT headphone maker Turtle Beach also recommends reducing from 40mhz to 20mhz:

http://www.turtlebeach.com/support/entry/830516923/

And, a short part of a longer article: Interference Issues Between Bluetooth and 802.11b/g/n Wireless
http://www.tomshardware.com/reviews/local-area-network-wi-fi-wireless,3020-6.html

I should note that I didn't have interference problems before I tweaked my router and the G750 wireless adapter, I just do it to be a good wireless citizen - there are a number of other wireless routers in both areas I connect in.

That brings up another idea, view your local wireless landscape to see where everyone else is parking their center channel. Putting your center channel elsewhere if there are strong stations within your channel footprint will help as well.

I use inSSIDer 3 on Windows, and WIreless Analyzer for mobile devices.

Please let us know if these changes eliminate the interference between BT and 802.11

LLothar
07-22-2013, 08:25 AM
Thanks for that great advice, Ill give it a try today and report back, so others may use it as reference.

I live in a apartment block in Norway, so one can safely assume at least one WiFi router per apartment, so there is plenty of traffic.