PDA

View Full Version : Win8 Games Minimizing because of touchpad [solved]



Aletreus
07-21-2013, 04:50 PM
I recently purchased a ASUS G750JW-DB71 and while it runs smoothly, I am running into issues while playing games. My games keep on minimizing randomly. I'm not sure why, but it's just becoming an annoying issue. How do I get rid of this issue? Any help will be appreciated. Thank you in advance.

EDIT by cl-albert: Solutions mentioned in this thread are summarized below.
1. Check post #6 below by cl-albert on this page, but the touchpad for this Win8 notebook is 'edge' sensitive and if you want to disable this feature, double-click on the touchpad icon to open the touchpad Smart Gesture software and disable the setting there. A screenshot is included on this page further below.

2. Check the next page for the post by 'TheRealVader', but if you use an external mouse and don't need to use the touchpad, set the Smart Gesture software to disable the touchpad when the external mouse is plugged in. You can also disable/enable the touchpad through Fn+F9 if you prefer.

3. This is a slightly different issue related to the touchpad occuring only in Win8.1 (not Win8), but for those playing games like Minecraft and seeing a delay to left-click after using the keyboard, check this thread G570 Left Click issues when typing [solved] (http://rog.asus.com/forum/showthread.php?39641-G570-Left-Click-issues-when-typing-solved&country=&status=) about changing the delay before the touchpad buttons will work after typing.

z3540
07-21-2013, 05:03 PM
What games do you play? Try GeForce Experience: http://www.geforce.com/geforce-experience. Let it "optimize" your video settings according to the game/video card. Be careful when if you choose fullscreen vs windowed. In fullscreen, you lose the pointer arrow. Also note that the latest driver from Nvidia may not load. You need to use ASUS' own Nvidia driver.

Aletreus
07-21-2013, 05:08 PM
I'll definitely give it a shot. I just disabled the TouchPad, I'll see if that works. I usually play Skyrim, Fallout, Final Fantasy XIV, Guild Wars 2 and World of Warcraft.

RogersaurusRex
07-21-2013, 06:10 PM
I had this issue - if you're doing the same as me you're left thumb may be resting on the trackpad whereby any rightward movement of your hand makes Windows switch between your running apps. I thought my games were randomly minimizing for a while before I figured it out.

I also note that I think some games must have this feature disabled because I didn't see it across the board; only with certain titles.

tnili
07-23-2013, 05:42 PM
I had this issue - if you're doing the same as me you're left thumb may be resting on the trackpad whereby any rightward movement of your hand makes Windows switch between your running apps. I thought my games were randomly minimizing for a while before I figured it out.

I also note that I think some games must have this feature disabled because I didn't see it across the board; only with certain titles.

I think I am having the same issue. How did you work around it? I use WASD keys in WoW to move around so my left thumb is always hovering over the track pad. Can you disable this feature in Windows? I would rather not disable the track pad.

cl-Albert
07-23-2013, 08:01 PM
The touchpad for this Win8 notebook is 'edge' sensitive and if you want to disable this feature, double-click on the touchpad icon to open the touchpad Smart Gesture software and disable the setting there as in the screenshot below.

Hope this helps (and keep on gaming!) !

23851

tnili
07-25-2013, 05:49 PM
I disabled Switch Running Applications. Your post saved me a lot of aggravation. Thanks!

cl-Albert
07-25-2013, 06:22 PM
Thanks for the feedback and glad to hear it helped!

Whiteouttx
07-26-2013, 03:43 AM
Yeah this helped tremendously, it got annoying when in critical moments I would accidentally swipe and my game would leave.
Thankyou!

Musicmatters
07-27-2013, 11:48 AM
Bravo Albert!

I could not understand why I was suddenly transported to the Windows 8 Start screen or some other random app without doing anything unusual....

Problem solved!

Craig

x70xchallengerx
07-27-2013, 06:43 PM
Since this is pinned, you should put the solution in the OP.

TheRealVader
07-28-2013, 03:39 PM
What might also help, if you click disable trackpad when usb mouse is plugged in might help. I like the gestures on the trackpad, and yes it would help if it didn't work while gaming. I'm not at home to see, but my daughter gets pissed while PVPing in GW2.

tului
07-28-2013, 05:19 PM
What might also help, if you click disable trackpad when usb mouse is plugged in might help. I like the gestures on the trackpad, and yes it would help if it didn't work while gaming. I'm not at home to see, but my daughter gets pissed while PVPing in GW2.

Classic shell, disable all the Win 8 gesture crap, set touchpad to disable when a mouse is plugged in et voila.

hozer
01-09-2014, 02:38 AM
I have the same problem. IE: Playing BF3. I have a mouse install and had to disable the touch pad and what happen if I touch pad it shoot my weapon without pressing any buttons on my mouse WTF is up with that? :mad:

cl-Albert
01-15-2014, 05:32 PM
Sadly, I'm not too familiar with BF3, but if you weren't aware of it, just wanted to mention you can left-click with your touchpad by tapping on the pad (takes a little getting used to, but something I use a lot), so wonder if this may cause the inadvertent weapon discharge problem you were seeing.

If necessary, check those Smart Gesture touchpad settings that have been mentioned earlier in this thread, and go to the General Gesture section/One Finger to uncheck the Select/Tap to select option to see if this can help with the problem.

LAMINI
03-17-2014, 10:40 PM
New ASUS G750 user posting that this resolved his issues ^_^