View Full Version : G74sx Ram Issue

07-23-2013, 12:05 AM
Hi, I have face planted on my ASUS 74sx-BBK8 with a i7 2670QM @ 2.20GHz processor. When I attempted to upgrade my RAM by adding a PNY 8GB DDR3 1600 (PC3-12800) to the Computer. With the card installed computer powers on, and a second later shuts off. I tried it alone, paired with a stock, all three, and moved all around to different slots to no success. I put a stock in the computer it boots like normal.

It might be my stupidity buying the wrong card, but everything I finds shows it should be compatible. But i'm pretty much a noob since the last time I screwed with computer hardware was Mid-90s. So any slaps to the head or help would be appreciated. Thank You.

PNY Memory Card Specs:
204-Pin DDR3 SO-DIMM
8GB, DDR3, PC3 12800, 1600 MHz, CAS 9, 1.5v

07-23-2013, 01:58 AM
for the spec as DDR3 1333 MHz SDRAM, 4 x SO-DIMM socket for expansion up to 16 G SDRAM (Quad Core), 2 x SO-DIMM socket for expansion up to 8 G SDRAM (Dual Core), i think 1600 could or could not using.

07-23-2013, 01:53 PM
So you're thinking the 1600 MHz is causing the issue

07-23-2013, 08:08 PM
You might have just gotten a bum SODIMM module. 1600 MHz RAM should be easily backwards compatible to a 1066/1333 MHz socket.

07-29-2013, 05:06 PM
Every RAM stick seems equal but they are slightly different and some pcs are more tolerable than others.
i would return that RAM stick and buy another one. That's why sometime it's better to buy RAM in a shop instead ordering from the web. You just try 'in locus' if it works or not.

07-30-2013, 01:53 AM
Just to update and share knowledge.
I did go to a local computer store with my laptop and my POS, I mean PNY card and asked the guy if he ran into this issue .
He laughed, disappeared into the back room and gave me a Corsair card (8GB Vengeance 204-Pin DDR3 SO-DIMM 1600Mhz) to try and it worked with the stock two with no problem. His quite long theory had to do with the memory card timing was causing to overload the socket shutting down the computer. If he is correct, hell if I know. All I Know its working with 16GB. I miss the days of "If it fits, it'll work."

07-30-2013, 10:33 AM
You're right. The issue is the memory latency. And usually laptops have a very basic BIOS that makes impossible to control these parameters. The only solution is to keep tryin the RAM sticks until they work.