View Full Version : Used G53Jw no ROG drivers on windows reinstall [solved!]

07-25-2013, 03:44 AM
Hi, I recently bought a used G53Jw from someone and it doesn't seem to have any of the extra Asus drivers that should be on it, they said that they re-installed windows on it (I think they said it was from the factory partition), but none of these buttons work the way I think they should

The one on the left only toggles the lights for those three keys and the power button, and the other two do absolutely nothing when pressed. Is there any way I can get the correct drivers for this laptop installed so that they will work correctly again?


07-25-2013, 06:30 AM
please download drivers and utilities from asus support site.

07-25-2013, 01:25 PM
Thanks for the reply, Pitcher!

Okay, do you mean this page (http://support.asus.com/Download.aspx?SLanguage=en&m=G53JW&p=3&s=282)?
Which ones should I get? Would it hurt to install all of them even if they are already installed? Will it say something like "this program is already installed on this computer" or something?

Thanks again!

I tried installing the Power4Gear driver, is that one of the ones that should work with the laptop keys at the top left? If it is, it's still not working, is there a config I need to change or something to make it work?
Can you tell me what the drivers are that I need to make all three of those keys work again please?


07-26-2013, 04:49 PM
I haven't dealt as much with the G53Jw, but can you check if your screen brightness changes AND (sorry for the caps) you see the onscreen brightness indicator appear while you change it?

I just want to make sure you installed the ATK driver and your screen brightness should still change without it, but you will not see the onscreen indicator.

Otherwise, just to go the G53Jw ASUS download site and make sure you installed ATKACPI driver V1.0.0005 from the 'utilities' section.

Expect 2 of the buttons to work after the ATK driver is installed and according to the G53Jw user manual the third button should be for the ASUS Splendid software, so make sure you install this program if you want that button to work although not everybody likes Splendid (I don't use it myself).

07-26-2013, 05:26 PM
Thanks cl-Albert!
I installed those drivers and everything is working now!

07-26-2013, 06:26 PM
Glad to hear that helped Kinesis22, and thanks for letting us know how it turned out!