PDA

View Full Version : ASUS G75VW Battery Not Charging, After MOBO Replacement



wasd123333
07-27-2013, 02:33 AM
Hi, a while ago my computer fried and I replaced the motherboard. Everything was fine and perfect until I found out that the battery was not charging. When I plugin the AC Adapter, it does not charge and instead it is just on "Battery Mode". If I take out the battery, the computer works fine without the battery, so I assume the AC Adapter isn't faulty here.

Next, I replaced the battery itself, a brand new one directly from ASUS and this problem still occurred. When I try to take out the battery and put it back WHILE the computer is on, it flickers between BATTERY ON and PLUGGED IN/NOTCHARGING mode.

Finally, I replaced the DC board altogether with a soldered DC Jack, brand new as well. The problem still persists.

I'm starting to think it might be the motherboard because I replaced it when my computer originally fried, but it works perfectly fine.

Are there any other things I'm missing here? Advice greatly appreciated~

wasd123333
07-27-2013, 04:33 AM
After taking apart the computer and rechecking to see if parts are loose, now whenever I turn on the computer (without the battery, since that's the only way it works properly), the light from the Power button does not come on!
However, I did notice that sometimes when I would be testing the power, the AC Adapter's power would suddenly just turn off and I would have to replug it into another outlet for it to revive. Could it possibly be the AC Adapter? This wouldn't explain though, as to why the computer still works without the battery does it?

wasd123333
07-30-2013, 05:06 PM
I also have a new problem now, when I turn on my computer it comes out to a black screen and says "Please select proper boot device and reboot".

However, I just replugged the AC Adapter and now it's fine.

I'm starting to think now it may have been because I bought a bad motherboard, but it still works fine???

Here is the motherboard replacement: http://www.aliexpress.com/item/For-ASUS-G75VW-motherboard-mainboard-60-N2VMB1703-B03-100-tested-free-shipping/968111490.html

wasd123333
08-03-2013, 09:28 PM
Thinking now it's either Charger or faulty mobo replacement.

Need a thoughtful response please...

tavdov2
07-11-2015, 06:55 PM
I have the same problem, my charger stop working and when I tried a generic charger it burned something in the mother board, so I replace it and get a new charger. Now the laptop revive but it doesnt charge the battery, I get a new battery but when I plug the charger it turn down. I dont know if I have to replace the DC board too.