View Full Version : Asus G74Sx RAM Upgrade (8 to 16 GB) now persistent Black Screen

07-27-2013, 11:57 PM
Goal: Upgrade RAM from 8GB to 16GB

Asus G74Sx
Intel® Core™ i7 2630QM Processor
Windows 7 Home Premium, 64 Bit
Intel® HM65 Express Chipset
2 x 4GB DDR3 1333 MHz SDRAM, 4 x SO-DIMM socket for expansion up to 16 G SDRAM (Quad Core)
NVIDIA® GeForce® GTX 560M with 3GB/2GB GDDR5 VRAM

BIOS was updated. (If I remember correctly I have BIOS 202; I had read that the BIOS 203 was buggy)

New RAM: Crucial - 8GB Kit (4GBx2), 204-pin SODIMM Upgrade for a ASUS G74SX (Quad Core) System

What I did:
1) System off
2) Removed plug & battery, pressed power button
3) Discharged my potential static energy
4) Opened back panel
5) Removed original RAM
6) Added new RAM to slots 3 & 4
7) Replaced RAM to slots 1 & 2
8) Closed back panel
9) Replaced battery
10) Pressed power on

1) Black screen
2) No boot, no beeps
3) Can hear optical drive for a second
4) Status indicators:
- Lit up: Power Indicator, Bluetooth/Wireless Indicator
- Not lit up: Battery Charge Indicator , Drive Activity Indicator

What I have tried:
1) Ensuring RAM is securely mounted
2) Checking that other connections are secure
3) Retrying original RAM (slots 1 & 2)
4) Trying new RAM (slots 1 & 2)
5) Trying each individual RAM in slot 1 (4 separate instances)

All of these attempts produced the same result, i.e., Black Screen.

I am pressed for time and therefore called a couple of tech places (to consider taking it in for their trouble shooting).
- One suggested that the "Mother Board is Fried."
Of course they can't know, but is this a possibility? Even with removing all potential power/energy sources?

I contacted Crucial and this what they said:
"Reviewing the parts you are using, they appear to be high-density and manufactured to a standard not available at the time your system was first released, which would lead to the malfunctions you are describing.

One solution to this would be a BIOS update, if available, from your system or motherboard manufacturer. Support for the higher density could have been added in a more recent revision than what is currently running on your system, which would allow those parts to begin functioning as intended immediately after installation.

An alternative solution would be to exchange those parts for a lower density. Performance would be identical but the parts would be built in a way more closely matching what was produced at the time your system was released, so the existing hardware would react more favorably to the parts."

Any thoughts about what the problem may be?

Do you have any suggestions for more trouble shooting?

If the motherboard is "toast" how would I know?

Is this something you would recommend that I take into a Asus Tech centre?


(I am not quite a novice, I have successfully built my own tower, replaced other hardware, and have been successful with other trouble shooting issues, etc. - but I wouldn't say that I am experienced techie).

07-28-2013, 01:32 AM
It is possible, though doubtful. If you retried the original RAM in the original configuration, and there is still a black screen, you may have an issue that needs to be repaired (bad mobo). If the original config works, then you may have incompatible RAM. When I upgraded my G53SX, the new RAM was recognized perfectly without any problems (8->16 GB like you). As to RAM density, I don't know.

Have to ask the obvious: did you restore a power source before you tried to turn it on?

07-28-2013, 05:18 AM
Thanks Zygomorphic.

Yes, I did reinsert the battery before trying to reboot. :D
There was clear evidence of power, but no post.

Do you have any recommendations for next steps?

07-29-2013, 02:21 AM
Try the absolutely original configuration, and see if that works. If not, then you may have a bit of a problem. :(

07-29-2013, 04:56 PM
What I have tried:
5) Trying each individual RAM in slot 1 (4 separate instances)

All of these attempts produced the same result, i.e., Black Screen.

Welcome to the forums!

If you're still trying to find a solution, do you mind confirming the system no longer works with 1 or both sticks of the original memory which were working before you tried the upgrade?

If this is the case, it would seem the issues with the new Crucial RAM is irrelevant for now and we just need to get your system working again with the original memory.

Wouldn't think you have done any damage to the unit/motherboard, so did you make sure the 1 or 2 sticks of original memory were seated well when you tried them again?

Can't think of any other reasons it wouldn't be working although maybe you also want to check or clean the memory contacts, but if they were fine before, it seems like this should not be the problem.