View Full Version : Asus G74SX-A1 Keyboard - Acts Like CTRL Key is Stuck

08-18-2011, 01:18 AM
Hello again,

I just had to reboot my system (in Linux, ouch) because my computer started to act like I was holding down the CTRL key whenever I pressed anything. I'm not really sure what to make of this, but I hope it does not turn into a regular problem (or if it does, that a BIOS update can fix it).

Not sure where else to comment on this, so I just made a new thread. Please move if appropriate. Thanks! :)

- Trip

08-18-2011, 05:24 PM
Does tapping the actual control keys have any effect? Occasionally when I've had a key get stuck in the buffer it's because there was a press down but no release signal. Pressing the actual key issues another down but then an up which resets everything. I know that doesn't really find the cause but it's easier than a reboot. Oh, but I don't have one of those machines so I'm not sure that my stuck key problem is related to yours.

08-18-2011, 07:06 PM
No, I tried pressing it multiple times and that had no effect. I tried pressing both of them, actually, multiple times. Stayed stuck until I rebooted.

- Trip

08-18-2011, 07:11 PM
Ah, worth a shot! :(

Hopefully it never happens again :)

09-10-2011, 05:12 PM
I am having the same issue. It seems to happen most when I'm working, not gaming, and going back and for from mouse to keyboard a lot. If anyone can figure out what's triggering it or how to stop it once it starts, I'd be really grateful. Hard to develop software when you're keyboard doesn't work :)

09-11-2011, 04:42 AM
i am also having this problem. i was playing L4D2 and was continuously crouching. although if i pressed it 5 or 6 times it would fix it for a minute or so. also it was not triggered by my pressing of the cntrl key (it just happpened) wtf??

also on possibly a related note, whilst playing L4D2 and space marine im encountering a problem where after about and hour or so of playing, when i press and hold any key my system hangs/lags for the duration of the key press, when i release it goes back to normal untill my next key press. the only fix for this is to reboot :( i have the latest vbios and bios updates and also have the atk fix etc...

any help on this will be greatly appreciated


Johnny Paranoid
09-11-2011, 08:10 PM
I'm also having this problem. I flashed the BIOS 202 update Chastity has on her drivers page as well as uninstalling and re-installing the ATK package. It's a really annoying problem.

09-12-2011, 12:48 PM
having the same exact problem. even after attaching an external keyboard its still stuck until rebooted.

09-12-2011, 07:11 PM
Sounds like some background process hijacking the keystrokes. I'd start disabling some background processes to find the culprit.

11-24-2011, 12:16 PM
I too have this same issue. From the very first time I've purchased the laptop. This is annoying. Sometimes I have been able to "reset" the keyboard by switching to a virtual machine and typing in it. Other times, this technique does not work.

There must be a way to do a keyboard reset, no?

12-17-2011, 05:58 PM
I have had the same thing happen to me from my purchase date in September. Like the previous poster stated, switching to a virtual machine and typing in there *sometimes* clears the stuck control key. I have also tried using the Accessibility option On-Screen Keyboard, which shows me the laptop believes the Control key is pressed. But that is not a reliable way of clearing the condition.

This is truly killing me, turning a wonderful laptop into a lemon.

Hoping someone posts a solution!

12-17-2011, 06:15 PM
i had that problem BUT ONLY using remote desktop connection. it is a windows bug (in my case of course) .
i was at work with a RDC to another pc in another room and suddenly it started acting as the CTRL key always pressed.

regarding this thread, i don't believe it is a hardware problem, but a software one

01-01-2012, 11:06 AM
Yeah, I too am also having this issue.

I purchased my G74SX about 3 weeks after being released to the Australian market and have always had this problem.

I initially thought it was software problem so i did a restore from the Original 3 or 4 disk image you do when you first obtain your new laptop. Yes yes this is the one that contains ALLLLLL the bloatware.

This had no positive outcome, control key still plays up. I also sometimes get the shift key doing similar action.

Since then I have performed a fresh clean install of windows, reloaded all the latest up to date drivers including the ATK package, recently flashed BIOS.

Once again it wasnt long before this damn ctrl / shift key started playing up all over again.

Ive even thought on the off chance another device conflicting? So ive removed all USB and external components. G9x Mouse, External Hdd, LAN Cable, Audio, etc.

I have tried enabling / disabling: Wireless, bluetooth, 3d mode.

I have tried running with external Monitor, keyboard, mouse, audio, lan, etc all plugged in, with the actual unit and laptop screen CLOSED.
(Even with external Keyboard connected and NOT using internal laptop keyboard this STILL occurs)

I have run the laptop with and without the battery, with no positive effect or outcome as well.

Please note that yes I realise it is highly improbable that disabling 2d/3d on your laptop monitor and doing the same with bluetooth etc is not going to help much, but there were alot of things that I have tried doing this just for troubleshooting purposes.

This problem is really starting to get to me as is with quite a few users.

Surely there is a fix for this??? God these laptops are nothing short of brillant and fantastic. The look / feel / performance, everything is great, but as another user said, this problem is turning this laptop into a lemon.

Asus: PLLLEEEAAASSSEEEEE FFFIIIIXXXX!!!! Release Updates / Patches. Do a recall, Just DO SOMETHING!!!! :)

01-21-2012, 07:14 AM
We really need an official response to this. This is a dealbreaker for me. Over the course of the last 3 days while raiding in SWTOR or WOW this has happened in the middle of a fight where my keyboard just ceases to work because of this bug. I have to restart my PC in order to fix it.

Not going to whine, every system has it's problems, and aside from this the Laptop is.


however.. If this doesn't get resolved I'm going to have to return it. I simply can't have my keyboard just go out on me at random intervals like this I mean.. It's a gaming rig. for gaming.


04-24-2012, 02:57 AM
I am having the same exact problem. First it seems the ctrl key is locked, then I lose all keyboard function so that every key is hot keyed. I bought this for gaming and if it happens again I will be calling customer support if we do not get a fix or solution. If that does nothing, then I will be demanding a full money back return. A gaming platform that fails at gaming?

04-24-2012, 03:20 AM
Are you using a USB Mouse and installed Logitech SetPoint or Microsoft IntelliPoint software to your system? See http://www.tomshardware.com/forum/2678-63-ctrl-stuck-because-mouse-buttons-assignments

It states:

This is an old thread but it might help someone. Both Logitech and Microsoft have written buggy software for their mouse programs: Setpoint and Intellipoint, even the latest versions, cause the keyboard to act flaky--especially the ctrl key. Here is the solution: Remove the Setpoint and Intellipoint software. Install the FREE x-mouse program to program your mouse keys. http://www.highrez.co.uk/ It really works!

I am not promoting the referenced X-Mouse utility, just offering some info to troubleshoot this issue further.

04-27-2012, 01:09 AM
I ensured all hardware drivers were fully updated. It happened again. Customer service will be called in the next few days.

04-30-2012, 10:01 AM
Hello all,

I own a G73SW-XA1 which I bought in May last year and shortly after purchasing it I encountered the Ctrl bug.
This was before owning any external mouse(now I have a G400). I have to admit that this bug increased in frequency at about the same time I got my G400, or maybe I just don't recall further back than that :p.
The only temp fixes for me, besides reboot, are sometimes opening the virtual keyboard and pressing the Ctrl key until it goes away(this doesn't seem to cut it anymore) and just mashing the Ctrl, Alt and Shifts(both left and right) together for about 30 seconds :eek:

I'll try to test for this bug with the Logitech framework closed or uninstalled. Anyway, without an external mouse but with the erratic touchpad the laptop is unusable when this bug occurs(instead of moving the pointer I get zoom).

05-01-2012, 04:43 PM
Please do reply if you call customer service and they tell you something helpful. I am having the ctrl bug on my Asus N55SF that I bought in February and want to throw out the window every time it happens. I contacted tech support via the online thing because I thought this would be a very simple problem (I thought I was just inadvertently activating a "feature" and they could tell me how to disable it). All they told me thus far is to reinstall the KBFilter driver which I just did yesterday and which I'm 99% sure is not going to solve the problem. -.-

PS Don't use the online tech support thing because I got a one-line response after 2 weeks of waiting. Sweet. That's what I get for being a phone-o-phobe, I guess.

05-29-2012, 09:29 PM
Well, reinstalling the KB filter driver does seem to have worked... the Ctrl key getting stuck hasn't happened since re-installing it, that I can recall.

06-08-2012, 07:53 AM
Welp... happened again. Really hate this computer. >:|

07-09-2012, 03:50 PM
Welp... happened again. Really hate this computer. >:|

I ran into the "stuck CTRL key" problem shortly after purchasing this honkin' big G74SX-BBK11 back in March, and I can empathize.

For me it was sufficient to have the touchpad disabled when a mouse is detected. After I disabled the touchpad I haven't seen the "stuck CTRL key" problem once in several months despite full-time use as a work laptop.

The following may work for you:

Open Control Panel
Search for "Mouse" or otherwise navigate to the Mouse Properties dialog
In the Mouse Properties dialog, click on the Device Settings tab (the last one with the red icon)
Check (turn on) "Disable internal pointing device when external USB pointing device is attached"

From what I recall, the CTRL bug occurs if the touchpad detects a certain kind of (unintentional) movement as you're typing. The problem only occurs once in a while, and it's tricky to reproduce intentionally, but if you type quickly and keep your palms low over the touchpad you may see the stuck CTRL problem more frequently. Thanks to my typing style--or lack thereof--I typically have to disable touchpads on laptops because my palms accidentally trigger them. I've had far fewer problems with the touchpads on MacBooks.

On an unrelated note: Targus has a great 17" rolling laptop case big enough to handle this beast. It won't fit in overhead compartments on the smallest commuter planes, but in general it's a great case if you travel with your laptop.

07-09-2012, 04:34 PM
+1 @GaryB - an interesting new look at the possible cause and resolution of this issue!

I'd like to add that Sentelic touchpad drivers prior to have an issue with the touchpad re-enabling itself after being disabled, so be sure to use version or later if you have a Sentelic touchpad and attempt this resolution.

07-24-2012, 02:38 AM
I'd like to say that my experience reflects exactly what GaryB has described. Disabling the touch pad definitely prevents the stuck key issue -- I've also found that once it's stuck it is sometimes possible to give the control key a few slightly longer-than-normal presses to reset it.

07-31-2012, 01:18 AM
I'd like to say that my experience reflects exactly what GaryB has described. Disabling the touch pad definitely prevents the stuck key issue -- I've also found that once it's stuck it is sometimes possible to give the control key a few slightly longer-than-normal presses to reset it.

That, along with clicking the other CTRL key, the alt and shift keys randomly usually resets it. Beats me as to why it would be the touchpad driver. I don't think the touchpad and keyboard use the same driver. :confused: