View Full Version : ASUS G46VW Keyboard LEDs not wrking

08-08-2013, 12:13 PM
Just got my Asus g46vw. Everything seems to be working perfectly EXCEPT my keyboard backlight? Is it a keyboard shortcut I am missing or do I need to download a specific driver?

08-08-2013, 09:16 PM
Congrats on your new laptop. I just got mine a few weeks ago. The first thing about your problem is that the laptop is fine, you have to manually turn on the LED. Im not sure there is a way for the laptop to automatically turn it on.

On your keyboard, the row furtherest down, there is an "fn" key (it is 3rd from the left). This key controls all of the symbols on the f1-f12s. Hold that key and press f4 multiple times. Your keyboard should light up. To turn it off use f3 instead of f4.

08-09-2013, 03:32 AM
when you press Fn+F3 or F4 is work? how is your function key are there work? if function key not work, you will check your have install ATK yet and flahs bios, if other functiion key is work, just KB light, i think you will checnk HW( good send to service center)

08-09-2013, 04:06 AM
When i press the fn key plus the hot key nothing happens. All my other hot keys work fine, its just the keyboard light hotkey that dont do anything. Dont know if this is applicable, but when I pull up settings on the bottom right hand corner(where the wifi, volumer,brightness etc) the keyboard tab isnt available as an option.

As a side note, I dont know how to boot into BIOS lol. My last laptop had the option at startup but this goes straight to the ROG loading screen.

08-10-2013, 06:39 PM
Anyone got ideas? Ive tried removing drivers and software, several times, tried older versions and everything I can think of. There is one unknown device in Device Manager

Could this be the keyboard backlight? If it is, what driver would it use?

04-21-2014, 03:14 AM
Figured I'd try my luck posting in this thread rather than starting a new one. I got a G46VW refurb not too long ago, and am loving it so far, but the backlit keyboard on mine does not seem to work. I'm worried it may be just broken, but I am optimistic because it seems like the increase and decrease brightness hotkeys aren't working. I may just be doing something wrong. I have WIndows 8.1 installed, and ATK package Version V1.0.0027 and BIOS 210.