View Full Version : Downgrade to w7, driver problems.

08-16-2013, 04:17 AM
I just purchased a used/refurbished g55vw that came with w8.

I didn't want w8 but these are getting harder to find for a good price and I didn't think installing w7 would be a problem.

After replacing the stock drive with a newly formatted SSD I installed all the missing drivers in device manager no problem.

Except the Atheros AR9485 REFUSES to install!

I've tried Asus' w8 drivers, w7 drivers, drivers from other websites but device manager continues to tell me that it cant find the software for my device and shows it as an unknown Network controller.

I usually use the Device managers update driver function,
but I also tried the various included setup.exe's,
which would install the software but the device is still unknown.

I know the device works,
becasue I reinstalled the original drive and its working under the oem w8.

Does anybody have any idea what could cause this or how to fix it?


08-16-2013, 04:45 AM
Welcome to the ROG forums, Thobrom.

Which version of Windows 7 did you install? The 32Bit or 64Bit version? Also since you can still plug in the original drive, verify that the wireless driver is indeed an Atheros and not the Intel one. I see two different wireless drivers at the Asus website.

08-16-2013, 05:37 AM
Hello Chino, thanks.

Yes it is the Atheros AR9485 according to the w8 "device manager" (or whatever they're calling it now).

That was half the reason I put the old drive back in was to make sure the WiFi was working and because w7 cant identify it to find out exactly what it was.

@ Intel Dude,
would that be located under services.exe?

I'm not seeing it.

I've got "com+ system application" and then "computer browser" but no "compatibility check service".

Is that what it would be listed as?

08-16-2013, 06:04 AM
please download driver from asus support site, it have all you need both of win 7 and win 8 drivers and utillities.

08-16-2013, 06:05 AM
@ Intel Dude,

okay found it.
Disabled it.

The software seems to install just like it did before,
but I've still got a "yellow warning" unknown network controller.

08-16-2013, 06:07 AM
@ Pitcher@Asus,
the Asus website version is the one I'm trying to use.
(None of the other ones I tried are working either so that doesn't seem to be the problem.)

08-17-2013, 02:14 AM
Check if "Device installation settings" are set to "auto"
Then try again, Windows should auto install drivers then!

08-17-2013, 07:27 AM
Oh well.

I got a good enough price on it that I should be able to get my money back.
What a shame.
This is obviously a half awesome computer, it would have been worth replacing the crappy atheros card.
If they hadn't buried it where no one can get to it.

And I suppose its not Asus's fault that w8 is to intolerably garbage.
I got a hot rod on 2 flat tires and I cant get the lugnuts off.