PDA

View Full Version : Windows 7 Ultimate WLAN Drivers



das9125
08-16-2013, 04:29 PM
Guys,

I have tried everything.
I am formatting a 750jw for a friend, but have no luck with the Wireless Adapter.
I have tried every suggestion here in the forums, including the clean guide

*****************

The symptoms are:

1. When I install the Broadcom driver: I get an exclamation mark and it says Device is not working properly
2. When I install any other driver (including the DR_PCE_AC66_6309526_Win7 that several suggest), Device Manager says that the Device is properly working, however no Wireless networks show up and I get a red X, at the Wireless tray icon. I try FN-F2 with no luck. It almost appears as if the wireless card is booting turned off. But it is enabled in the BIOS.

I am really frustrated. I have been going at this for two days, have formatted twice already, no luck.

Please help me. I really do not want to have to go back to Windows 8. :(

das9125
08-16-2013, 06:24 PM
Intel Dude,

Is there anyway I can tell the exact hardware from device manager?

Network Adapter shows the following Hardware ID: PCI\VEN_14E4&DEV_43B1&SUBSYS_21231A&REV_03

In my previous format I did try all the drivers. But maybe once I install one, it never becomes clean again even after uninstalling, could be

das9125
08-16-2013, 06:28 PM
This is the third time I have formatted.

The bluetooth and the WLAN seem to be directly related. I have not installed either driver in order to test the appropriate one first.

BT device shows up as BCM20702A0, which points to a Broadcom device. However, the Broadcom driver on the tutorial points to a WLAN driver and not BT. The one I have found, will not install in Windows 7. It is giving me an error for wrong windows. I have disabled the Program Detection service, according to instructions.

So currently, everything is installed except BT and WLAN drivers.

das9125
08-16-2013, 07:10 PM
I just ran Ma-Config.

It will not show a Wireless network adapter, unless I install some driver.
So it will not show any adapter as of now. I correct the info above, the Hardware ID for the network card is:

PCI\VEN_14E4&DEV_43B1&SUBSYS_21231A3B&REV_03

das9125
08-16-2013, 07:28 PM
After installing the Broadcom WLAN, I get the yellow exclamation mark on Device Manager, and Ma-Config is still unable to detect the network card :( Asus!!! This is a gaming pc/workstation, and no Windows 7 support??!!! After many years as a customer, I have had it. :mad:

Prostar Computer
08-16-2013, 07:31 PM
You could try a third party utility, such as 3Dp chip or DriverPack Solution. Does it show up as an "unknown device" without the driver? You could try using the utility UnknownDevices if that's the case; it will give you more detailed hardware info you can Google for a driver.

das9125
08-16-2013, 07:32 PM
I have built computers and I have enough experience with drivers. I appreciate your help.
The device appears as 'Network Controller' with the yellow unknown exclamation mark.

When I google the Hardware ID, the very limited results point to a Broadcom device. But that driver does not wwork! :(

EpIcSnIpErZ23
08-17-2013, 12:48 AM
Ok. When you installed the Asus PCE driver, did you uninstall all the previous drivers? If not do that.