PDA

View Full Version : Asus G750JW audio drivers Realtek



Raphenix
08-18-2013, 02:09 PM
Hello everybody,

I've bought an Asus G750JW a few weeks ago, I added a SSD and installed Windows 8 64bits from scratch on it.
The problem is that when I plug my headset (Razer Kraken Pro), I have to lower the volume down to 2/100 not to burst my ears, I hear a "sizzling/cracking noises" as soon as my headset is recognized by Realtek (always the same noise, no matter the volume), and my microphone nearly doesn't work (I made test by amplifying it to the max, and I need to blow really hard in it to hear a slight sound).
The problem doesn't come from my headset nor my microphone, I tested them elsewhere.

Does anybody knows how to solve my problem please ?

Thanks in advance,
Raphenix.

Myroslav
08-18-2013, 04:28 PM
I am not sure if the sound is similar to what has been described here (http://rog.asus.com/forum/showthread.php?35077-Razer-Megalodon-and-Razer-Sabbertooth-not-working-on-my-G750jx&country=&status=), here (http://rog.asus.com/forum/showthread.php?35849-Stange-noise-issue&country=&status=) or here (http://rog.asus.com/forum/showthread.php?35998-Mods-Admins-Is-ASUS-doing-something-about-this-issue&country=&status=). But it seems to be an issue for low impedance headphones and seems to be a special issue for Razer. Never liked that company anyway. Cheap made in china crap getting charged out at premium prices is ridiculous.

In my case, cheap Logitech's (http://gaming.logitech.com/en-ca/product/g230-stereo-gaming-headset) and Sony's (http://store.sony.com/p/Sony-XB-Bass-Headphones/en/p/MDRXB600) and a pair of expensive Sennheiser's (http://www.sennheiser.ca/live/senn/produit/en/1367/14) works like a charm. At the end of the day I end up using H800 (http://www.logitech.com/en-us/product/wireless-headset-h800) because they are wireless and good enough for vent/TS/mumble and skype.

Pitcher@asus
08-19-2013, 07:27 AM
so you mean when you install to new version V6.0.1.6954 from asus support site, it is happen. or old version or Realtek version?

Symho
08-19-2013, 08:02 PM
so you mean when you install to new version V6.0.1.6954 from asus support site, it is happen. or old version or Realtek version?

Don't install latest drivers V6.0.1.6954 because they remove the Maxx audio software. They are bugged! :mad: ASUS what are you doing?

Myroslav
08-19-2013, 09:59 PM
so you mean when you install to new version V6.0.1.6954 from asus support site, it is happen. or old version or Realtek version?

I mean any driver. If you are having issues, you will have them regardless.


Don't install latest drivers V6.0.1.6954 because they remove the Maxx audio software. They are bugged! :mad: ASUS what are you doing?

So bad... Please read this message (http://rog.asus.com/forum/showthread.php?34734-Why-did-ASUS-remove-the-Maxx-Audio-Control-Panel-in-the-latest-Realrek-Audio-Driver&p=283822&viewfull=1#post283822). You will get your Maxx back up.

Symho
08-20-2013, 12:16 AM
I mean any driver. If you are having issues, you will have them regardless.



So bad... Please read this message (http://rog.asus.com/forum/showthread.php?34734-Why-did-ASUS-remove-the-Maxx-Audio-Control-Panel-in-the-latest-Realrek-Audio-Driver&p=283822&viewfull=1#post283822). You will get your Maxx back up.

Why the ASUS'user must solve the problems? Where is the customer sadisfaction? Why you pay for your pc? My seller it is ready for return my pc if the problems that I have noticed on my G750 there aren't solve BY ASUS! There are many other companies...:mad: I'm waiting for ASUS assistance!

PPanda
08-20-2013, 01:12 AM
ASUS won't help. It is important you don't send it for RMA either. First RMA they sent it back with a fried Motherboard. Second RMA they sent it back with a broken keyboard.

Al_Jourgensen
09-16-2013, 11:49 AM
my realtek drivers for win 8 64bit, g750jx, donīt have dolby option, only 2 chanels, in the SPID-INF output, has someone solved this problem?

thank you

Al_Jourgensen
09-18-2013, 08:23 AM
ok now, i install the 7004, and max audio, gone, how to fix this issue?

hmscott
09-18-2013, 09:10 AM
ok now, i install the 7004, and max audio, gone, how to fix this issue?

ok my friend i installed, one by one the drivers that you recommend, but max audio has desapear, i donīt have the program and donīt know how to download it.
regarding the file that you said to delete, it is not inside the realtek installation folder, and i canīt find it to delete it
can you help me with this, iīm on 7004 now.
thank you very much for your attention and patience

Ah, it's not a program, it is an extension to the Realtek Systray program. Double click on the "Realtek HD Audio Manager" systray icon, and when the dialog comes up, click on the AudioWizard tab, and Launch the Wizard, click on settings icon to right of title and get the large expanded settings dialog:

26358

26359

26360

Al_Jourgensen
09-18-2013, 10:21 AM
iīm not at home wright now, i have to see if i have that option, i will give you feed about this, in 3 hours

Thank you very much, but i do not think i have that tab, what version of the program do you have? how can you delete the file they are talking about? i canīt find it....

can you link me to your driver?

i have this Edit, on the read me file of the Version V6.0.1.6976, but they donīt say what file is it....

EDIT: Don't forget to delete the file in the config folder after you unzip the file... Follow the instructions as it says.
EDIT2: You also have to delete the same file from c:\windows\system32\Drivers. If you find that same file in this windows folder, it needs to go as well (it might or might not be there). If you don't delete it, this won't work.


i notice that inside the config file, the folder is empty....

i believe that i never saw that option, on my realtek drivers.........but i tell you wright away in 2:30 hours, when i get out of work


to put my notebook g750jx, in Dolby surround, do i have to buy, an external audio card to do this?

Al_Jourgensen
09-18-2013, 12:33 PM
as you can see, only these option appear with my defaul maxx áudio, that came with the recovery partition

Al_Jourgensen
09-18-2013, 12:47 PM
and this on, only this appears26384

hmscott
09-18-2013, 02:47 PM
as you can see, only these option appear with my defaul maxx áudio, that came with the recovery partition

MaxxAudio is *only* for internal speakers, not for any other output, including digital output.

I have the same view as you do for Digital Output tab

26395

Symho
09-18-2013, 03:53 PM
MaxxAudio is *only* for internal speakers, not for any other output, including digital output.

I have the same view as you do for Digital Output tab

26395

I have this when I had upgraded form driver .6909 to .6976. Bad drivers...:(

hmscott
09-18-2013, 03:59 PM
I have this when I had upgraded form driver .6909 to .6976. Bad drivers...:(

MaxxAudio is only for internal speakers, all drivers, all the time :)

Not bad drivers.

Symho
09-18-2013, 06:49 PM
MaxxAudio is only for internal speakers, all drivers, all the time :)

Not bad drivers.

Yeah, but when I read that message I can't use MaxxAudio (after update to .6976 on ASUS's web), because in the drivers there are bugs, many! Only with .6909 Maxx is it avaible for me, so yes bad drivers! And we customers must find a custom solution... ASUS support? :confused:

hmscott
09-18-2013, 07:19 PM
Symho, you quoted me as saying "MaxxAudio is only for internal speakers", and then you said that was due to bad drivers.

I am saying it is not due to bad drivers, it is the designed service of the MaxAudio application extension to only work with the internal speakers.

Al_Jourgensen
09-19-2013, 12:10 AM
Symho, you quoted me as saying "MaxxAudio is only for internal speakers", and then you said that was due to bad drivers.

I am saying it is not due to bad drivers, it is the designed service of the MaxAudio application extension to only work with the internal speakers.


Thank You My Friend Again, and yes you have the reson, itīs a terrible mastake, and nobody is going to take care of it.....Thank You Again, i will keep trying the pairing..... :)

hmscott
09-19-2013, 09:00 AM
Thank You My Friend Again, and yes you have the reson, itīs a terrible mastake, and nobody is going to take care of it.....Thank You Again, i will keep trying the pairing..... :)

Again, it is not a mistake, it is a choice, probably due to licensing restrictions for the right to use the audio shaping extension - they charge by feature and function, so they limit the usage to only the installed speakers to get the benefit they need (fixing limited speaker size / cabinet size) but don't pay for additional features.

Symho
09-19-2013, 02:19 PM
Symho, you quoted me as saying "MaxxAudio is only for internal speakers", and then you said that was due to bad drivers.

I am saying it is not due to bad drivers, it is the designed service of the MaxAudio application extension to only work with the internal speakers.

I had .6909 driver version, I had gone a new driver .6976 on ASUS web and when I opened my MAxxAudio panel Ita appear: "MaxAudio application extension to only work with the internal speakers", this on a white wallpaper, the problem is that I'm anable to click on panel, It is locked! So, I tried .7004 and .7027 driver versions but Maxxpanel was deleted! I can say BAD DRIVERS?

hmscott
09-19-2013, 02:58 PM
I had .6909 driver version, I had gone a new driver .6976 on ASUS web and when I opened my MAxxAudio panel Ita appear: "MaxAudio application extension to only work with the internal speakers", this on a white wallpaper, the problem is that I'm anable to click on panel, It is locked! So, I tried .7004 and .7027 driver versions but Maxxpanel was deleted! I can say BAD DRIVERS?

1) Uninstall the old Realtek driver, reboot. Use "drive sweeper" if you need to - Al_Jourgensen finally had success getting the new Realtek driver installed with MaxxAudio after using "drive sweeper" Al, what exactly did you need to do/remove?

http://www.guru3d.com/files_details/guru3d_driver_sweeper.html

Once you have all the old Realtek driver pieces uninstalled...

2) Install the new .7004 or .7027 driver, reboot.

Now you should have the new Realtek driver + MaxxAudio.

I think the step people are forgetting to do is the reboot after uninstall / install. Or, they are skipping the uninstall before install.

It says it right there on the download section for the driver: "please uninstall the older version driver before install the newer version driver"

The "Broken" part of the older drivers, .6976 and before, is that Realtek included a file called rtkhdaud.dat with the installer package that disabled the MaxxAudio plugin. you need to remove rtkhdaud.dat from the unzipped installer Config directory first, but if you forgot to do that before installing, you then also needed to search in C:\Windows\ for the rtkhdaud.dat file and delete it, then reboot, before trying the install again.

There are more detailed instructions here in post #15, also a link to another post I made earlier is in that posting:
http://rog.asus.com/forum/showthread.php?37425-Asus-G750JX-software-problems-Need-Help/page2

Keep trying Symho, you can get it to install :)

Symho
09-19-2013, 03:22 PM
...
Keep trying Symho, you can get it to install :)

Thank you! Now I have a question. Why ASUS don't release a "NO BUG" driver? Why we must find a solution for our product? Where is it ASUS's support? We had payed for all service or not? Here I have the 5th RMA module and if I want I can return my G750, for my hardware problem. ASUS don't interested about customer sadisfaction?

hmscott
09-19-2013, 03:26 PM
Thank you! Now I have a question. Why ASUS don't release a "NO BUG" driver? Why we must find a solution for our product? Where is it ASUS's support? We had payed for all service or not? Here I have the 5th RMA module and if I want I can return my G750, for my hardware problem. ASUS don't interested about customer sadisfaction?

Did you get the newest Realtek driver to install, and have MaxxAudio working ok now?

Symho
09-19-2013, 04:17 PM
Did you get the newest Realtek driver to install, and have MaxxAudio working ok now?

Now I'm working, I'll do this evening.

Symho
09-19-2013, 07:54 PM
Now I'm working, I'll do this evening.

It isn't solved! Nothing Maxx panel.

hmscott
09-20-2013, 03:22 AM
It isn't solved! Nothing Maxx panel.

Symho, Ravage6652, post #39 - found and removed rtkhdaud.dat from C:\Windows
http://rog.asus.com/forum/showthread.php?34135-Waves-MaxxAudio-gone/page4

oVrKILL's, Post #36 - deleted old version files/folders left over after driver uninstall
http://rog.asus.com/forum/showthread.php?34135-Waves-MaxxAudio-gone/page4

Symho
09-20-2013, 08:29 AM
Symho, Ravage6652, post #39 - found and removed rtkhdaud.dat from C:\Windows
http://rog.asus.com/forum/showthread.php?34135-Waves-MaxxAudio-gone/page4

oVrKILL's, Post #36 - deleted old version files/folders left over after driver uninstall
http://rog.asus.com/forum/showthread.php?34135-Waves-MaxxAudio-gone/page4

Thank you hmscott but I had done! Now I have update to older version .6909 so MaxxAudio come back. I'm waiting for the end of september for the new driver, that was annunced from Marshall@ASUS.

hmscott
09-20-2013, 08:33 AM
Thank you hmscott but I had done! Now I have update to older version .6909 so MaxxAudio come back. I'm waiting for the end of september for the new driver, that was annunced from Marshall@ASUS.

Ok, I wonder what the problem is that is keeping you from updating. Probably a good idea to leave it alone anyway, it gets pretty frustrating after a while, I know.

At least you have the MaxxAudio from the release version :)

twisteddiana
01-18-2014, 08:05 AM
Hi,

I bought this laptop yesterday (G750JW), it came with a drivers CD and I installed all of them. I was pretty much disappointed with the quality of the sound (internal sub woofer not working at all), and found this thread.

There is no trace of maxxaudio anywhere, also my Realtek HD audio manager has 3 tabs only (speaker config, sound effect and default format), no trace of that audio wizzard I saw in your screenshots.

My driver version is 6.0.1.7037 (up to date). Please help.

Nehmia
01-18-2014, 08:08 AM
Hi,

I bought this laptop yesterday (G750JW), it came with a drivers CD and I installed all of them. I was pretty much disappointed with the quality of the sound (internal sub woofer not working at all), and found this thread.

There is no trace of maxxaudio anywhere, also my Realtek HD audio manager has 3 tabs only (speaker config, sound effect and default format), no trace of that audio wizzard I saw in your screenshots.

My driver version is 6.0.1.7037 (up to date). Please help.


format your laptop. without MAXXXWaves Audio it sounds like crap

twisteddiana
01-18-2014, 10:02 AM
Format? I just installed it yesterday. Bought Win 8.1 separately. This is no solution, starting all over again.

Guest
01-18-2014, 10:08 AM
get latest driver from ASUS: V6.0.1.7119

http://support.asus.com/Download.aspx?SLanguage=en&p=3&s=589&m=Audio&os=41&ft=4&f_name=Audio_Realtek_Win81_64_VER6017119.zip#Audio _Realtek_Win81_64_VER6017119.zip

Torien
01-18-2014, 12:57 PM
Hi, in my case i solved it by installing latest driver from realtek site and i even have Maxxaudio panel :o
http://www.realtek.com.tw/downloads/downloadsview.aspx?Langid=1&PNid=14&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false

twisteddiana
01-18-2014, 06:24 PM
Latest driver doesn't do it. Unfortunately.

I did it by combining the solutions of some people on this forum. I had a driver installation CD which contained the Realtek Driver which had that /Config folder. I removed the file as explained and installed it and MaxxAudio appeared. Yay.

The driver version is 6.0.1.6909 (from 14/05/2013). The latest driver from Dec 2013 doesn't do the trick.

Guest
01-19-2014, 10:57 AM
in the latest driver from asus you dont delete any file for MaxxAudio, see:

http://rog.asus.com/forum/showthread.php?41714-DRIVERS-All-you-need-for-clean-Windows-8.0\8.1-installation&p=354173&viewfull=1#post354173

Download: http://support.asus.com/Download.aspx?SLanguage=en&p=3&s=589&m=Audio&os=41&ft=4&f_name=Audio_Realtek_Win81_64_VER6017119.zip#Audio _Realtek_Win81_64_VER6017119.zip

hmscott
01-19-2014, 01:19 PM
in the latest driver from asus you dont delete any file for MaxxAudio, see:
http://rog.asus.com/forum/showthread.php?41714-DRIVERS-All-you-need-for-clean-Windows-8.0\8.1-installation&p=354173&viewfull=1#post354173
Download: http://support.asus.com/Download.aspx?SLanguage=en&p=3&s=589&m=Audio&os=41&ft=4&f_name=Audio_Realtek_Win81_64_VER6017119.zip#Audio _Realtek_Win81_64_VER6017119.zip

Thanks Guest, works for my G750JH on WIndows 8.1 x64. :)

noone
02-26-2014, 11:30 PM
I'm a little confused about the default audio drivers and Maxx Audio.

If I don't have Max Audio enabled, audio is poor. When enabled the audio is fine (with a little tweaking). The Max Audio is a reasonably CPU heavy program, if I'm not doing much else, it can be the most demanding Application running.

So, is this a unique Asus thing? In order to have adequate audio (not saying it has to be great, but just sound like any other Acer, Dell, Lenovo)you have to have a program that seems to equalise to make it sound more normal?

Even if they were using cheap chip-sets, I've had $100 phones that sounded better...

thundercat
04-29-2014, 02:23 AM
It has to be something with Realtek. I have this issue on both Windows 7 and Linux. I thought maybe it was just a Windows issue.