PDA

View Full Version : Malfunctioning wireless network adapter on the ASUS G75VX-BHI7N11 with stock settings



hatscom
08-22-2013, 07:18 PM
Hey all, hope this is the correct place to ask for advice regarding my computer.

I purchased a ASUS G75VX-BHI7N11 windows 8 refurb computer on newegg on July 22, 2013.

The computer consistently cannot find and/or intermittently drops the wireless internet that every other device has no problem with. It will eventually find it (sometimes going in and out of airplane mode helps, or it will catch on its own), but then it will drop it later. Drops have been occurring about once every 15 min, inevitably during the middle of important tasks and certain games such as Diablo 3 will kick you all the way out of the game when it happens, more or less rendering it unplayable.

Even as I write this post, I have watched the wireless disconnect and connect twice or more. My phone however has a consistent unbroken and healthy connection with this wireless. The situation was exactly the same at my mother's house on the other side of the country with a different wifi.


I'm happy to attempt more settings fixes but I have tried all of the basics. Power settings changed to max performance, driver upgrade, driver downgrade, tried dell drivers, uninstalled back to auto detected ones. Nothing seems to help.

Since its refurb I would not be surprised if the network adapter is faulty. How do I proceed? I don't have the original box, because I moved out to school between the time I bought the computer and now.

The computer's 30 day limited replacement warranty has expired. I had been waiting to try this on several networks and it turns out the problem is the same everywhere.

I could buy a new network adapter but I would prefer to keep the usb slot it would take up free.

Cheers.

Also please request specific further info if you need..

x70xchallengerx
08-22-2013, 08:20 PM
These are the G750 forums, you bought a G75V... similar models but different laptops entirely...

audio_dragon
08-22-2013, 11:46 PM
These are the G750 forums, you bought a G75V... similar models but different laptops entirely...

My G750JX just arrived a couple of hours ago and I can confirm it's doing the exact same thing. It'll grab the wireless connection and then drop it after a few seconds or a few minutes. Very frustrating.

Cjdean
08-23-2013, 02:33 AM
I have a G750jx and my wireless cuts out sometimes too. Not every 15 minutes, but several times a day. The signal strength is 5/5 bars and my other laptop (a mac) right next to it doesn't cut out, so it's definitely the wireless card. Im on Win8, I've ha it for a month.

LLothar
08-23-2013, 05:41 AM
I had WiFi issues when there was a bluetooth connection at the same time. WiFi/Bluetooth drivers & Bios update fixed the issue.

Cjdean
08-23-2013, 06:58 AM
I had WiFi issues when there was a bluetooth connection at the same time. WiFi/Bluetooth drivers & Bios update fixed the issue.

Which update? And I don't use Bluetooth, or even turn it on, so that wouldn't be an issue in my case.

I just checked, and I'm using the latest Bios (207) and WLAN driver (6.30.223.64) as per ASUS support download site. Windows8 came pre-installed.

The Thing
08-23-2013, 08:13 PM
Hiya buddy! Have you tried installing win 8 again?. I don't think it's a hardware related problem so give it a try. Or you should try installing win 7 and see how it fares there. Anyways, gotta go, cya OP and other members.

audio_dragon
08-24-2013, 12:34 AM
I have the G750JX using the Atheros wireless. I solved mine by downloading and installing the drivers from here:

http://www.atheros.cz/atheros-wireless-download.php?chipset=61&system=5