View Full Version : Low FPS on 3D gaming G750JX

08-24-2013, 02:08 AM
Hi, I just got myself what I believed to be a great laptop for gaming to complement my desktop when I am working long missions all around the world, but I can't seem to run games like MechWarrior Online above 10 FPS.
Settings can be low or very High, on medium I have 14FPS, on very high I have 10 FPS.

I checked the power profile, I am on high performances.
I checked the graphic card GTX770M, I have the latest drivers provided by ASUS, the v311.
Nvidia is offering me to upgrade to 330, but the installer systematically fail to recognise my GTX770M.
Dx11, Windows 8, tried compatibility mode with Windows 7, no luck.
I just did all the Windows Updates stuff for framework, problem persist.

Laptop: ASUS G750JX (Brand New)

Time of this report: 8/23/2013, 23:08:33
Machine name: GAULWA-ROG
Operating System: Windows 8 64-bit (6.2, Build 9200)
Language: English (Regional Setting: English)
System Manufacturer: ASUSTeK COMPUTER INC.
System Model: G750JX
BIOS: G750JX.206
Processor: Intel® Core™ i7-4700HQ CPU @ 2.40GHz (8 CPUs), ~2.4GHz
Memory: 8192MB RAM
Available OS Memory: 8110MB RAM
Page File: 3261MB used, 9455MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DxDiag Version: 6.02.9200.16384 64bit Unicode

Display Devices
Card name: NVIDIA GeForce GTX 770M
Manufacturer: NVIDIA
Chip type: GeForce GTX 770M
DAC type: Integrated RAMDAC
Device Type: Full Device
Display Memory: 6799 MB
Dedicated Memory: 3000 MB
Shared Memory: 3798 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: unknown
Monitor Id: CMO1720
Native Mode: 1920 x 1080(p) (60.010Hz)
Output Type: Internal
Driver File Version: 9.18.0013.1141 (English)
Driver Version:
DDI Version: 11
Feature Levels: 11.0,10.1,10.0,9.3,9.2,9.1
Driver Model: WDDM 1.2
Driver Attributes: Final Retail
Driver Date/Size: 3/7/2013 11:46:12, 18061328 bytes

What am I doing wrong?
Also... secondary issue: the game recognise mouse4 and mouse5 buttons from my Roccat kova+, but does not recognize the buttons from my new ROG mouse.

08-24-2013, 04:10 AM
I tried 2 different VGA drivers version from the ASUS website... nothing seems to work.
The official driver installer provided by Nvidia tells me my hqrdware is incompatible.
I am missing every option for 3D vision... or is it hidden somewhere? I used to only have ATI card so I cannot say if this is normal, but I am missing a metric-ton of options from the NVIDIA control pannel.

08-24-2013, 06:11 AM
770m isnt really powerful enough for 3d gaming

08-24-2013, 06:35 AM
Oh... err, really?
But all the benchmark websites were placing it above my workstation or my old desktop. And both can run the game just fine with high settings.
I'm going to install other games to check... could I be CPU limited?

08-24-2013, 07:56 AM
I have been easily playing Borderlands 2, Devil may Cry and Remember Me in 3D with my G750JX. What you need is to be able to get 60 fps in 2D mode since 3D halves them. I could easily get 60 in Battlefield 3 by lowering a couple settings so I am 90% sure it's a driver issue or a problem with specific games since not all of them support 3D well. The 770m is powerful enough to get 60 fps with tweaked settings on most games except with the notorious graphics hogs like crysis, sleeping dogs and far cry 3

08-24-2013, 08:19 AM
If you are running on battery, your cpu will be running at 800MHz..

08-24-2013, 09:33 AM
Thank you ibbi and Anvirol.

I updated the bios and installed the drivers you pointed me. Sadly, the problem persist.
I believe the game might be CPU limited for some reason as low or very high settings do not affect the FPS. How could I check my CPU performances? (I am plugged to the AC)
I know this was the case on my desktop and my FPS went through the roof when I switched CPU.
Still... plenty other players have cheaper/lower laptops, and they can play fine. I should at least reach a decent 40 fps.

(Downloading and installing 3DMark11 and 3DMark)

08-24-2013, 11:47 AM

Here is 3DMark11. 3DMark is still downloading.

From what I understand, even with the proper drivers installed, Windows 8 insist on using it's generic drivers.


Graphics Card Generic VGA
Vendor Unknown
# of cards 1
SLI / CrossFire Off
Memory 0 MB
Core clock 0 MHz
Memory clock 0 MHz
Driver name Microsoft Basic Render Driver
Driver version

Oh, and here's the link if you can access it:

08-24-2013, 12:04 PM
AC power, positive. The laptop would have shut down a long time ago if it wasn't working... and I believe I am in high performance mode. Where do I check this?
The Power4Gear application installed by default show no anomaly:

If I unplug the AC, it switch to battery. If I plug it back... it switch to high-performances.

08-24-2013, 01:38 PM

and the 3DMark. As expected, I am 8 times slower than expected performances.

08-24-2013, 03:59 PM
OK, I found where is the problem, huwever I do not know how to fix it:

Depending on the activity of the computer, the CPU varies between 800MHz and 3200MHz. This is normal.

The GTX 770M is also supposed to vary based on this table:

Pl Graphics Clock Memory Clock
0 405 405
1 405 810
2 405 2004

But the Memory Clock of my GPU never change. It remain forever at 405 MHz, the lowest setting.
What? Why? How do I fix that?

I uninstalled Power4Gear Hybric in case it was conflicting with Windows8, I put myself in High Performances, and I observed something: even in the advanced settings for windows power options, there is absolutely no mention on my Nvidia. Only some "Intel® Graphics Settings" ... it that normal?
Is the card just not waking up and switching performance settings.... or is it windows forgetting to use the GPU?

08-25-2013, 04:10 AM
OK, I modified the official Nvidia 320.49 drivers to bypass security and successfully installed them.

Sadly, the problem persist.

08-25-2013, 04:29 AM
Hurm, I installed MSI Afterburned to see it I could manually set my GPU to normal settings, and I observed my GPU temperature to be at 54°C when idle, and 103° when running a 3D game.

When I start the game, my GPU wakes up for a few seconds, but the temperature jump immediately to 100° and the GPU memory clock goes back to minimal performances.

Maybe my GPU is automatically locking it's performances because of the temp?
That's extra-wierd as the Laptop metal case is cold. Even under the computer it is barely warm.

EDIT: Just saw you post ibbi. Ok, I will try that. Sorry, I'm not very knowledgeable about hardware.
EDIT2: How exactly do I use the -overall -overide command plz?
EDIT3: Nevermind. I found it, and drivers has been installed. Problem persist.

08-25-2013, 05:48 AM
Where do you get all the updated drivers you linked me? I cannot find them on http://support.asus.com/

08-25-2013, 11:44 AM
crap performance AND 103°C temperature readings? This sounds pretty serious...the highest temps should be 30C lower. What makes you rule out a hardware defect?

08-25-2013, 12:13 PM
I did the factory reset. Of course, the problem persist.

Than you for your offer, but this is a brand new laptop. If it is a hardware issue, I prefer to send it back to the retailer withing the week for a full refund or a change.
I have a Win7Pro installation DVD. I can try that... but it is was really a software problem, I wouldn't be the only one complaining here.

08-25-2013, 06:26 PM
Sounds like a faulty GPU, I would advise returning your laptop for replacement.

08-26-2013, 02:14 AM
Yes... but I imported the laptop from France and I am working in china for a couple month. I'm going to have a couple hundreds fee of shipping. I think I will try an Asus Service Center next to my flat. I'm glad they have worldwide coverage.