View Full Version : Tried to install Ubuntu now the bios seems bricked

08-24-2013, 08:56 PM
Hi All,
I tried to install Ubuntu on my new G750JX because I need it for work (horrible, only last version functioning and problems with NVIDIA drivers) and I don't know how but I think that is happened because of win8 and now the notebook seems bricked. I tried to do the recovery procedure (pushing ctrl+home button with an usb drive with the bios file renamed "G750JX.bin") but it still not work. The monitor is black, the computer power on autimatically when I plug the charger and I see the HD led for a nanosecond and then the blu-ray read something and than it stops (If i change CD or DVD it reads with the same time so i can guess that it isn't really reading something). The keyboard light is off. I tried with an usb drive (2GB) with led that don't blink and also with a 1GB usb-drive.
I hope someone can help me cause I don't know what to do.
I have the italian model with the kasko warranty, do you think that the RMA procedure will be with no cost?
Thank you all!
...Sorry for bad english

08-24-2013, 11:16 PM
That is diabolical.

08-25-2013, 12:58 AM
How can this void my warranty? Even if I have the kasko warrany that permit me to drop the notebook on the floor? I just installed Ubuntu, not opening the notebook or flashing the bios, are sure this can void the warrany? Moreover where is written that Ubuntu is an unsupported os?
Anyway is crazy that even not touching the hardware only the software the notebook may be broken! I guess this is due to Windows8, that tried to modify something in the bios otherwise how this could be explained?

08-25-2013, 01:15 AM
@torsy87, no worries about your English, we can easily understand it. We all know that this is an international forum, so English is not everyone's first (self-only) language. As to installing Ubuntu on the G750JX, it should be doable, the key issue is "Secure Boot", which prevents non-Microsoft operating systems from booting.

You need to disable "Secure Boot" and enable "Launch CSM" before things will work.

However, it appears that something has happened to your computer - not Ubuntu installation corrupting Windows. I would contact your ASUS service center and ask them what to do, since installing another OS doesn't void your warranty, it simply changes the OS and invalidates them helping you debug software problems. This, however, is a hardware problem.

08-25-2013, 10:56 AM
Thank you for reply Zygomorphic, as I thought this is an hardware problem. Anyway Ubuntu (13.04 12.04.2 12.10) can be installed without disabling the "secure boot" because it has the key to be safety installed on the machine. I tried to take pushed the power button for all the night but nothing changed. What I would know is: the recovery procedure for the G series works or not? Because there are people with the G55 on this forum that have been able to recover their bios but what about other notebooks? Is the bios different (not amibios?) otherwise why this procedure don't work? Paradoxically Is easier to recover the firmware of a smartphone when bricked respect to a ultrapowerful notebook that costs a lot. It can't be true that I can't do a recovery because I think that there is a constant zone in the bios that can't be changed and that has the function to recover the whole bios in this problematic cases like this but why this don't work (ctrl+home and bios in usb)?

08-25-2013, 01:26 PM
I don't think so, the MBR is located inside the hard-disk not the bios. Even if i disconnect the hd, I can't access the bios. Usually the MBR can be recovered with a fresh installation of the OS or with a repair tool so, in this case, it's a bios problem. I wrote to the assistance but I don't expect to obtain useful info. I think i will call soon the number on the kasko warranty booklet. So frustrating that recovery procedure don't work, because nobody assure you that this can't happen again. I read of people which notebook was bricked because of the asus bios update utility! We're talking about the asus utility not sporadic flash done by themselves! Or people that tried to install the ssd and the same problem occurred.

08-26-2013, 12:43 AM
Ubuntu 12.04.2 works fine with jx-tb71 with atheros. Wireless works and display is responsive without nvidia drivers. I didn't check all features yet.
I will reinstall win8 without uefi and ubuntu will be dual boot. But I have an annoying touchpad problem which is discussed in another thread. I hope I can resolve it so that I can start using this as primary laptop.
I am disappointed that nvidia drivers don't work with this (yet?) Asus advertise this as 770M and nvdia says those are 770M drivers, so who is lying here?
I don't ever expect asus making linux drivers so hopefully nvidia will support it and i can also use it on ubuntu.

08-26-2013, 12:48 AM
@ibbi, thanks for the advice. MBR corruption won't affect any BIOS that I have ever heard of. The BIOS is independent of the HDD, which is why if the MBR gets corrupted, a recovery disk can usually recreate it and rescue everything.

Oh, and the G55 doesn't have a MBR, it uses UEFI, and therefore has GPT formatting rather than MBR.

08-26-2013, 02:32 AM
I tried all that procedure you don't need to reinstall win8 in order to get the dual boot. What you just need is
1) install ubuntu (versions 12.04.2 12.10 13.04) that support the UEFI BIOS without disabling secure boot because these OS has te key to be safety installed on the machine
2) once you install Ubuntu you can anyway boot with win8 but you have to change the boot option in the bios and if you want to reboot again with ubuntu you have to undo this change so you will load again grub
NOTE: win8 boot from grub won't work
3) to make working the boot with grub of win8, so that you have not to change the bios every time, you need to launch ubuntu and to install this utility https://help.ubuntu.com/community/Boot-Repair that will repair the win8 boot option in the grab. Once you have followed the repair option you may set the boot fixed at grub and the option to boot win8 or ubuntu will work both togheter so if you want you

For the NVIDIA drivers I tried different procedures: using the NVIDIA provided drivers, using apt-get, using different kernels, no one working in my case. Anyway ther is no optimus problem, because it seems that the intel video card doesn't really work (it is garbage with respect to the nvdia, haswell improvement is expecially done on this useless video card, so boring).
As a last thing I suggest you: don't abuse of the hard shut-down (pressing the power button for about 5 seconds) expecially when win8 is booting because after this my notebook bricked. I hope my experience could prevent someone else from having the same troubles and that asus would be correct and apply the kasko warranty to my case.

08-26-2013, 03:02 AM
Ubuntu can work with UEFI, I know about it. There is an open bug during installation so as you said, boot-repair needs to be used until they release 12.04.3

I will disable UEFI and reinstall windows due to my own reasons.
UEFI is very new and doesn't provide much security where you have Windows as an insecure OS. I have my Ubuntu partition crypted and Windows is only for gaming. I don't need complexity and potential problems when I decide to change something in future.
I also have vanilla Win8Pro and will take care of wasted space on disk with current setup. I see a 20GB partition with 12GB used for recovery which has no place on my SSD. So no UEFI until Ubuntu LTS assures me that it's fully working and I feel more confident.

08-29-2013, 07:32 AM
You can get any distro to run with Secureboot enabled (dual booting as well). I got Arch running on my G750jx (dual booting win8). Albeit somewhat of a pain to get running, it's doable. I'd recommend using the Linux foundation's Preloader (a signed bootloader) which in turn can load another boot loader (unsigned). There is also Shim, but then you have to deal with signing your loaders.