PDA

View Full Version : Samsung SSD 840 not detected by BIOS in ACHI mode



ak.pp
08-31-2013, 08:18 PM
Hi all,

Just bought a G750JW and asked the resller to install a Samsung SSD 840 (128GB). I've managed to clone the OS partition using SSamsung's utility, installed Samsung Magician which is telling me that 'ACHI is enabled'. However, BIOS doesn't seem to detect the SSD (which works fine within windows 8) in ACHI mode, only in IDE.

Of course since the OS was installed in ACHI, windows won't boot if I switch the SATA detection to IDE.

FYI I've upgrade the BIOS to the latest available (207), but that didn't do the trick.

Is it a matter of a faulty connection? Any advise would be much appreciated.

x70xchallengerx
09-01-2013, 01:05 AM
Have you initialized the drive? I have the same drive (840 series, 240gb) and the computer wouldn't see it at all until it was initialized with 'devices' (right-click 'computer' > devices) if you've done this already DON'T DO IT AGAIN. Lmk if that helps. Once it's initialized, your computer will see it as a hard drive with ~110gb free space.

Wait nevermind >.< just re-read the part that says windows 8 sees it just fine. Ignore all that then ^. I'd call the retailer or samsung...

cosmicmango
09-01-2013, 02:12 AM
Hi all,

Just bought a G750JW and asked the resller to install a Samsung SSD 840 (128GB). I've managed to clone the OS partition using SSamsung's utility, installed Samsung Magician which is telling me that 'ACHI is enabled'. However, BIOS doesn't seem to detect the SSD (which works fine within windows 8) in ACHI mode, only in IDE.

In the BIOS make sure you have it set to ACHI.

Move the SSD to the HDD bay - leave the HDD out and reboot to see if the SSD boots up. If it boots up you can put the HDD back into the second bay.

Of course since the OS was installed in ACHI, windows won't boot if I switch the SATA detection to IDE.

FYI I've upgrade the BIOS to the latest available (207), but that didn't do the trick.

Is it a matter of a faulty connection? Any advise would be much appreciated.

In the BIOS make sure you have it set to ACHI.

Move the SSD to the HDD bay - leave the HDD out and reboot to see if the SSD boots up. If it boots up put the HDD in the second bay.

ak.pp
09-01-2013, 06:28 AM
In the BIOS make sure you have it set to ACHI.

Move the SDD to the HDD bay - leave the HDD out and reboot to see if the SDD boots up. If it boots up put the HDD in the second bay.

Thanks, cosmicmango- that did the trick! The SSD wasn't connected properly, so it was just a matter of sorting that out.