View Full Version : AMD Catalyst won't update

09-04-2013, 04:37 AM
Hi everyone -

I've got a G73JH. I've tried updating the AMD drivers a number of times now. Whenever the automatic update prompt comes up, I start the download, which then starts the AMD updater.

BUT whenever I reboot my computer, the prompt comes up again, saying the last AMD Catalyst update was December 2012, and the version it shows is 12.11 (as of this post, the current is 13.4). Anyone else had this problem? I'd appreciate any help. Thanks!

09-04-2013, 04:58 AM
you need to update GPU Bios before you can install the latest AMD Catalyst from amd.com. I installed the latest AMD Catalyst without problem on my G73JH. I also updated the GPU Bios. you can find the GPU Bios from here: http://rog.asus.com/forum/showthread.php?519-G73Jh-GSOD-Vbios-Update&country=&status=

09-04-2013, 12:46 PM
Hey getjohnalive, does that vBIOS break your hdmi? Can you still use it like normal? Did you use Chastity's version with overdrive, or the first one?

09-04-2013, 02:36 PM
Seriously? Flashing the BIOS is the only option just to update my graphics card?

09-05-2013, 08:28 AM
Updating to this bios, does not break your HDMI. I just updated using the chastity vBios with overdrive. and I have no issue so far. I connect my laptop to the TV through HDMI without problem. if you want to update the vBios, just do it.

09-05-2013, 12:42 PM
That hdmi issue once affected one of the vBios updates. That is what has been stopping me from doing it so far. But I'm glad to hear the Chastity's vBIOS with overdrive is OK. :cool:

BTW, John, I noticed over at Notebook Review (http://forum.notebookreview.com/asus-gaming-notebook-forum/634168-g73jh-vbios-93v-2.html), someone said only ATI 12-3 drive could be used with the vBIOS flash, no later, is that true?

One last question, when you do the flash do you type vflash or od2. IOW, is od2 the complete vBIOS with the updated overdrive?

09-06-2013, 07:02 AM
man. I've installed the latest AMD Catalyst from amd.com. the latest is 13.4 and it is working very well without problem...I also tried the latest AMD Catalyst Beta 13.8 without problem. to flash the vbios just go here: http://rog.asus.com/forum/showthread.php?519-G73Jh-GSOD-Vbios-Update&country=&status= and there you will see how to install the VBIOS. but you will need external USB Flash drive.