View Full Version : G74SX - Intel Turbo boost throttling & driving me nuts!

09-10-2013, 04:30 PM
So Hi guys...

Have had my G74SX for almost two years now and have never had any problems with it until about 2 or 3 weeks ago. I have always kept the machine clean and regularly keep the inside clean of dust as well. But suddenly I am noticing that when gaming or surfing or even just checking email real quick I notice that the turbo boost monitor keeps throttling up from near 0 and up to 3.10 constantly. After it spikes and on the release of the T-boost it temporarily freezes all windows, mouse pointers etc....

I tried doing a clean boot to see if was maybe a driver or software conflict but still does it when started clean after multiple tries. So I tore the whole thing apart thinking maybe it was dusty inside and there was nothing, clean as a whistle inside & put it back together and the problem remains and is now doing it to the point where it is just an absolute nuisance.

Anyone have an idea of what to check next? Or what the culprit might be?

Tried searching in the forums but found really nothing of any value... thanks in advance for any help on this.

09-11-2013, 05:51 PM
No one has anything on this? I hear the problem all over, especially to the i7's but no one seems to have any good answers anywhere...
Anyway to check it's doing what it is supposed to be doing correctly ?
uninstall/reinstall ?
Upgrade/Downgrade ?
Do nothing ?

Someone here has to have at least a minimal answer on what else to check on...

09-14-2013, 11:46 PM
Wow... Sorta sad when you come to the R.O.G. site and all you see are 12 year old kids questions of how fix track pads or make recovery disks...
I can't believe no one here has run across i7 TB.2 issue on their G74's here at some point and time....

09-15-2013, 10:27 AM
Hi onebadbug, if you have had the laptop for 2 years it might be time to re paste the CPU and gpu. Download real temp and report backwhat yyour idle temperature is

09-17-2013, 01:33 PM
Don't think its a temperature problem. The problem actually started when Intel auto-updated something about a month ago, but what was changed I haven't a clue.... I removed the turbo boost thing and it is nowhere near as bad as it was but now you can tell that it is remarkably slow.... And I ran that real temp tool & under full load 2 times 30 mins, 2 times 15 mins and 2 times 5 mins... they all stay the same nothing out of the order and totally stable....


And also ran the the Intel Dig tool and passed with flying colors....

--- Testing Processor 1 ---

--- IPDT64 - rev ---

--- Start Time: 09/17/2013 08:45:38---

--- Skipping Config ---

--- Reading CPU Manufacturer ---

Expected --> GenuineIntel
Detected --> GenuineIntel
Found --- Genuine Intel Processor ---

--- Temperature Test ---

Temperature Test Passed!!!

Temperature = 62 degrees C below maximum.

--- Reading Brand String ---

Detected Brand String:
Intel Core i7-2670QM 2.20GHz

Brand String Test Passed!!!

--- Reading CPU Frequency ---

Expected CPU Frequency is --> 2.20

Detected CPU Frequency is --> 2.19504

CPU Frequency Test Passed!!!

--- FSB NOT Supported on this Processor ---

--- Running Base Clock test ---

Detected Base Clock --> 99
Base Clock test Pass ---
..QPI rate Test not supported..
..Skipping QPI rate Test..

Skipping QPI rate Test

--- Running Floating Point test ---

Million Floating Points per Second, MFLOPS --> 331.2
Floating Point Test Pass ---

--- Running Prime Number Generation Test ---

Operation Per Second--> 5.31663e+006
Prime Number Generation Test Pass ---

--- Reading Cache Size ---

- Detected L1 Data Cache Size --> 4 x 32
- Detected L1 Inst Cache Size --> 4 x 32

- Detected L2 Cache Size --> 1024
- Detected L3 Cache Size --> 6144

Cache Size Test Passed!!!

--- Determining MMX - SSE capabilities ---

--- MMX SSE ---
MMX - MMX Supported --> Yes
SSE - SSE Supported --> Yes
SSE2 - SSE2 Supported --> Yes
SSE3 - SSE3 Supported --> Yes
SSSE3 - SSSE3 Supported --> Yes
SSE4.1 - SSE4.1 Supported --> Yes
SSE4.2 - SSE4.2 Supported --> Yes
--- MMX SSE - capabilities check complete ---

MMX Test Result --- PASS
SSE Test Result --- PASS
SSE2 Test Result --- PASS
SSE3 Test Result --- PASS
SSSE3 Test Result --- PASS
SSE4.1 Test Result --- PASS
SSE4.2 Test Result --- PASS
MMX SSE Testing Passed !!

--- Determining AVX AES PCLMULQDQ capabilities ---

AVX - Advanced Vector Extensions Supported --> Yes
AVX OS Support - AVX Operating System Supported --> Yes
AES - Advanced Encryption Standard Supported --> No ---> No Test Required
PCLMULQDQ - Polys Carry-Less Multiply Supported --> Yes
--- AVX AES PCLMULQDQ capabilities check complete ---

AVX Compare Test Result --- PASS
AES Test Result --- Not Tested
PCLMULQDQ Test Result --- PASS
AVX PCLMULQDQ Testing Passed !!

--- Reading Memory Size ---

Detected Memory Size is --> 8.00GB

--- Integrated Memory Controller Stress Test ---

--- Integrated Memory Controller Stress Test Pass!!! ---

Integrated Memory Controller Test Pass!!!

--- Platform Controller Hub Test Disabled ---

..Query 2..
--- Querying for Intel(R) Integrated Graphics Device (IGD) ---
..Did not detect Intel(R) Integrated Graphics Device (IGD).
..This could be that the test platform is using a discrete graphics card.
..To test IGD, verify that there is an onboard video connector,
..shutdown the test platform, remove the graphics card, and
..move video cable from graphics card to onboard video connector
..Skipping Intel(R) Integrated Graphics Device Presence Test..

--- CPU Load ---

--- Load Level = 8

CPU Load Passed!!!

--- Temperature Test ---

Temperature Test Passed!!!

Temperature = 42 degrees C below maximum.

--- Test End Time: 09/17/2013 08:49:37---

09-19-2013, 08:34 PM
Ok... been doing random running temps loaded and unloaded... and even if I play SC2-HOTs the machine still will not crack the 62'c mark even after a 4 hour match set... and the lagging also does not occur period while playing any game in any maner...


I am starting to wonder if it is the new Nvidia driver that I updated just after when asus used it's updater that updated the Intel components is compounding (or possibly causing) the issue. For the last 2 days I have been playing SC2-hots & Sim City 5.... While playing them the machine plays flawlessly hour after hour on ultra & extreme settings. But as soon as you dumb down to do things like check email, FB or general surfing the problem will suddenly come back after about 5 mins into it. And while just surfing twice today suddenly some crazy polygons flashed up & the screen just went black and then had to re-boot into safe mode to re-start

I am currently running the Nvidia v. driver... I tried to roll it back but it just tells me that there is no prior driver to revert to. So which brings me to anther question, to roll it back, what would be the best tried and true driver to revert to, or, what was its original driver...

I'm really trying to not have to do a clean install as the only way I can do that is with my copy of 7ultimate and the last time I did this on my desktop MS wound up telling me my key was already used and now they put it on their blacklist... I do have my original recovery discs that I made from when I originally bought this machine new from new egg. But after the headache with the other machine I'm really not in the position to go down the too bad sooo sad route a third time.