View Full Version : G75 VW Startup problems

09-24-2013, 08:41 AM
Hi guys, first of all, I already appreciate the time you spend reading this post. Just bought this new G75VW, win8, 12GB, i7 3630QM, 2.4Ghz, 750Gb+750GB, the only time it has startedup properly was after the unboxing, after that, it takes me like 2 or 3 attempts before it boots properly. Once I press the startup botton I see the ROG logo and a bit later the monitor turns off, the keyboard´s lights continue to flash though a couple of times and then they turn off, the light indicartos of hdd, caps lk, num lk, battery and so on at the front panel are still lit and recognize if I press caps lk or num lk. I usually have to turn it off and on again 2 or 3 times to make it work and when it finally starts properly it warns me that windows has recovered from an unxepected error.

I have seen in previous posts that reseting the BIOS by taking the battery away and presing for 40 seconds the turn on botton will fix the problem. I have donde that already, it helped that time, but then the next time I turned it on the problem continued. I thought that it really didn´t matter as per the computer sooner or later worked, but tonight after the same ritual and once windows started the keyboard went all crazy on me... never happened that before... the keys I pressed returned as outpu anything but what they were supposed to... so I shut down the computer and started it again, same old process... but again, the keyboard didn´t respond... did this for 3 times and on the 4th it finally worked properly.

Do you have any advise for me please? I should probably head for the shop that sold it to me but I know they will probably won´t help me out and I´ll hate to have return this beauty. Everything else work perfectly... Today the notebook has 1 week old.

Thank you very much

09-24-2013, 02:07 PM
You really should bring it to the shop, and demonstrate the issue to them.
incase it does not happen all the time, record it on your phone and then show the vid to them.
it could seems like an issue on the mainboard.

09-26-2013, 05:08 AM
do you have make restore OS? if still have problem, i think you take back to shop to change new one.