PDA

View Full Version : G74sx BBK8 Trackpad Buttons/USB 2.0 Ports not working. HELP! [partially solved]



ImmortalBones
09-25-2013, 11:33 PM
So, as the title states, my trackpad buttons and my usb 2.0 ports stopped working, I think simultaneously. At least, last night I noticed the trackpad, and early today I realized the USB 2.0 ports arent working. To clarify, my USB 3.0 port is working just fine, any device I plug into it installs and works properly. I also get power from the USB 2.0 ports, they will charge my phone, just not allow me to browse its contents, and it wont install my external mouse unless its in the 3.0 slot. I've checked all the drivers, updated everything, and the device manager says the hardware is installed and working properly. I haven't made any changes to my computer in this time, other than installing the Bioshock games, so I don't understand wherein the problem lies. Has anyone had a similar problem? The trackpad buttons are annoying, but it could be worse since I have an external mouse. Any help would be greatly appreciated, THANKS!

Pitcher@asus
09-26-2013, 02:48 AM
any usb device plug to all usb 2.0 port are not work or jsut some of useb 2.0 ports can not use? if set use in bios is help or not, how is uninstall usb+ utility, how is restore OS? is it win 7 os?

ImmortalBones
09-27-2013, 10:02 PM
I actually found out the issue with the USB ports. For anyone else who may have this problem, try cleaning your registry. I have win 7 ultimate. I don't know why, but after I ran a quick sweep and cleaned up my computer and registry, all USB 2.0 slots work. I still have the trackpad button issue, but I'm not quite as concerned about that right now.