PDA

View Full Version : Autobrightness based on lightness of items on-screen



x70xchallengerx
10-02-2013, 01:26 AM
So.. I looked through the forums and didn't see any threads related to this, so if I am duplicating a question, please just refer me to the solution and I'll be on my way... now;

I do damn near everything when it comes to computers; games, word docs, video production, 3d modeling and design, photo editing, music, so on and so forth, and I have noticed this issue, not sure if it started when I got the laptop or if it started after formatting or updating nvidia drivers etc but... My screen tends to drop down in brightness if the majority of the screen is a dark color... like when I'm browsing facebook for instance, my screen is bright as can be, because the screen is mostly white, but if I toggle Photoshop ( cc, dark grey UI ), the screen immediately dims. Increasing it manually from the KB changes nothing as it's already maxed. This is really obnoxious considering I do photography and photo editing, and just because I like to be on higher brightness....

Can anyone help me find how to LOCK it at 100% (or whatever I set it at)??

adamsyes
10-02-2013, 04:11 AM
Yeah, its a new update from Nvidia drivers.

you can turn it off under brightness settings where you manually change options under the current power management you currently have (balanced, maximum performance etc)


Click on the battery icon. then Go to > adjust screen brightness > select the power management you want then right below it you will see change plan settings, click that then scroll down and click on display, it will expand few more options.

disable the "Adaptive Brightness" on your desire current settings (plugged in or battery)

Usually, it should only be on during battery saving mode. when under maximum power performance, it should be disabled. I case in your case which power management do you use when doing the work ? and are you using power4gear ?

Prostar Computer
10-02-2013, 03:47 PM
Yeah, its a new update from Nvidia drivers.

you can turn it off under brightness settings where you manually change options under the current power management you currently have (balanced, maximum performance etc)


Click on the battery icon. then Go to > adjust screen brightness > select the power management you want then right below it you will see change plan settings, click that then scroll down and click on display, it will expand few more options.

disable the "Adaptive Brightness" on your desire current settings (plugged in or battery)

Usually, it should only be on during battery saving mode. when under maximum power performance, it should be disabled. I case in your case which power management do you use when doing the work ? and are you using power4gear ?

Adaptive brightness uses an ambient light sensor (typically per the webcam) to adjust the backlight brightness, relative to the amount of light hitting the screen. That's not an NVidia proprietary feature to my knowledge (it's adjusted within Windows Power Options (http://windows.microsoft.com/en-us/windows7/adjust-your-monitors-brightness-and-contrast)).

OP's description sounds more like dynamic contrast ratio, which I think is adjusted via the Intel HD graphics properties (if not, then it should be in the NVidia control panel).

hmscott
10-02-2013, 05:01 PM
X70xchallengerx, I have found using sticky dots on the front sensors works best.

x70xchallengerx
10-03-2013, 07:23 PM
Uh ambient brightness doesn't affect my display any, however I found a solution to my problem,

if you go into Nvidia Control Panel, go to "Adjust Video Color Settings", check "With Nvidia Settings:" and use full dynamic range, and disable "dynamic contrast enhancement." Restart computer and voila!! No more dimming on dark pages/programs!




X70xchallengerx, I have found using sticky dots on the front sensors works best.

hmscott
10-03-2013, 09:09 PM
Uh ambient brightness doesn't affect my display any, however I found a solution to my problem,
if you go into Nvidia Control Panel, go to "Adjust Video Color Settings", check "With Nvidia Settings:" and use full dynamic range, and disable "dynamic contrast enhancement." Restart computer and voila!! No more dimming on dark pages/programs!

How did the "Dynamic Contrast Enhancement" option get enabled?

My config was still set for "With the VIdeo player settings" - I think that was default - I don't recall playing with it on this laptop.

Just for grins I turned it on, yes it is annoying :)

But, now I will adjust the settings with Dynamic Range: Full without Dynamic Contrast Adjustment, thanks for the tip.

spermulator
05-17-2014, 08:47 AM
Thanks for the tips (use full dynamic range), now everything is fine! I've just noticed the same problem after I changed solid color as desktop wallpaper.

JDVizart
05-25-2014, 06:05 PM
Sticky dots don't work.

Nvidia Control Panel, go to "Adjust Video Color Settings", check "With Nvidia Settings:" and use full dynamic range, and disable "dynamic contrast enhancement." Restart computer and... No change.

Fn+A doesn't turn off the sensor.

I've disabled "NVIDIA Stereoscopic 3D Driver Service" and "NVIDIA Streamer Service".

I've turned off dimming in the windows power settings, and in the Power4Gear Hybrid.

It STILL dims when there's a dark screen. This is very annoying as I do video and photo editing on this laptop. I can't do my job properly as it's effecting the colors of what I'm editing.

How do we fix this?

I'm using the Asus G750jw laptop running Windows 8.1, and the latest update to NVIDEA as of May 25, 2014.

PatRaven
05-26-2014, 05:22 PM
JDVizart and others,

See this thread... It might not help you but we're trying to solve it and hopefully we will do it :rolleyes:

http://rog.asus.com/forum/showthread.php?43315-Auto-contrast-is-driving-me-nuts!!/page12

GottiBoi55
07-21-2014, 04:02 AM
You need to go to services and stop the service, and disable it.
(As in the screen shot below)



http://rog.asus.com/forum/attachment.php?attachmentid=39200&stc=1&thumb=1&d=1405914099 (http://rog.asus.com/forum/attachment.php?attachmentid=39200&d=1405914099)

xdon82
07-21-2014, 09:54 AM
Iautobrightness not depended on environment light level can be disabled in Intel graphic control panel - there is already topic on this forum - http://rog.asus.com/forum/showthread.php?49612-auto-brightness-contrast-solved-!-)&country=&status=
However how to do autobrigthness depended on the environment light ?

wednesdayraven
11-27-2015, 04:50 PM
Good day,

Just like you all, I've found that the only way to get rid of it is by installing the latest nvidia driver to rectify this.....i know that many of you are gamers with this hardware and might not want the latest due to some compatibility issue with some games.
(I've did everything from changing the dynamic contrast setting in nvidia control panel, turn off the adaptive brightness setting in power option, press Fn+A .......etc. Non of it worked for me)

Thus recommend use the version of the nvidia (usually not the latest) from the official Asus website to get the driver following your model and walah......dimming is gone !! XD

Hope this helps everyone as i have heard lots of people finding this feature annoying as much as I have !

P.S : I'm using the Asus G751JT gaming laptop with windows 8.1

Cheers

bupthebroker
10-16-2016, 11:36 AM
I am having the same issue, when i switch from a dark pageto a white one the white color is terribly worn out. After a while it will slowly become white.

Where is this "dynamic brightness" in the NVidia settings? This is what i have there (960M):

59802