View Full Version : Atheros WLAN Driver doesn't actually install

10-03-2013, 08:28 AM
Dear ASUS, please inform the drivers team that when you install the Atheros WLAN Driver, if you go to Device Manager, right click on the WLAN chipset, it doesn't actually state the same version of the driver you installed which should be I even tried installing the latest one from the main ASUS Drivers site which is but same result

Instead, it just shows the normal Windows 8 Driver version that comes preinstalled in Windows 8

I tried first uninstalling the Windows 8 Driver then restarting, then I installed the driver provided by ASUS, but that doesn't actually do anything.

What I had to do to get this fixed is download the latest driver from Atheros which is (http://www.mediafire.com/download/w8spx1bddscmqdr/Atheros+WLAN+Driver+ (INF files) and then manually update the driver from Device Manager pointing to that folder

Can anyone who has the Qualcomm Atheros WLAN Chipset verify what driver version they actually have installed by going to device manager and checking?