PDA

View Full Version : G750JW - Blank Screen after BIOS changes [SOLVED]



noideea
10-18-2013, 06:43 AM
Hi guys,

First of all i'd like to thank the great community here for helping me (indirectly) solve my issue with my new notebook.
I decided to create this post because i wasn't able to find this fix for the G750 models (I used the info found in the G55 and G75 sections).

So let's start from the begining.

I bought a new ASUS G750JW (no windows 8 preinstaled) a couple of day ago. Everything went perfect with it until last night, when i decided to instala the Windows 8.1 update. The update itself went on smootly but i noticed the "SecureBoot isn't configured correcly" text in the botoom right corner so, after a quickly looking over the issue on google, i restarded the notebook and enetered bios to activate secure boot.
In the bios menu i made only two changes:
1. I activated the first option in the secure boot menu
2. I changed the option "POST Logo ... " from "Static" to "Active"
After saving the settings an exiting the bios menu, the notebook started, but the screen remained blank. I tried a few restarts but the same issue occured every time: the screen remained blank while the keyboard lit up (and worked, at least the caps and num lock did) and the indicator leds lit up aswell (the power light was on, so was the battery, but the HHD one flickerd for a few seconds and the it stayed off).

I didn't have another PC or laptop around so I started browsing for solutions on my phone. I found and tried a lot of possible sollutions:
- pressing the ESC, F2, F4, F9, F12 or DEL key to try and enter the BIOS
- removing the battery and the power plug and pressing the power button for 2-3minutes then starting the notebook
- removing the SSD and HDD drive and all the other usb devices and trying the above steps again

I the stumbled upon this thread (http://rog.asus.com/forum/showthread.php?27544-G75VX-Changed-boot-order-can-t-access-BIOS&). Where i found a possible sollution in placing an BIOS update on a USB stink and trying to Flash it during start-up. At this point I was pretty discouraged as this sollution didn't work for that guy and I prepared the laptop so i could sent it to service if this last method wouldn't work out.

This morning I went to work and went thru the following steps:
- formated an 8gb USB Stick as FAT32
- downloaded the latest bios update from the ASUS website (208)
- unziped the archive and placed two copies of the BIOS file on the root of the USB stick
- renamed the two files (from the original G750JWAS.208) to G750JW.BIN and G750JWAS.BIN - I did this because I wasn't sure which name would the BIOS recognize.
- placed the USB stick in the USB3.0+Charger port of the laptop
- turned the laptop on while keeping the CTRL+HOME keys pressed

To my utter surprise the screen turned on, quickly displaying the ROG logo, and the notebook entered the BIOS Flash Utility which performed a clean install of the latest BIOS.
After it finished installing and verifying the install the notebook turned off.
I removed the USB stick and powered it on again.
The notebook started (screen on and all) and it works perfectly since.

I hope this post will turn out to be helpful for other RoG G750 owners in the same situation :cool:

jhasrouni
01-29-2015, 05:18 PM
I just bought a brand new ROG G751JT model last week which has Windows 8.1 preinstalled on the PC. I am having the same problem with a blank screen appearing from time to time upon startup and wakeup from sleep mode. It is frustrating that ASUS did not fix this BIOS problem on their newest laptops.

I will have to take my laptop to ASUS service center and let them fix it :(

rawga57
10-20-2015, 07:34 PM
You the man! I couldnt get anything to work from all the ideas online. I just moved houses and after a few months of not using my asus g750jh I powered it on to find the screen black with no bios. After a few hours of trying every method your bios boot worked! Thank you for the post.




Hi guys,

First of all i'd like to thank the great community here for helping me (indirectly) solve my issue with my new notebook.
I decided to create this post because i wasn't able to find this fix for the G750 models (I used the info found in the G55 and G75 sections).

So let's start from the begining.

I bought a new ASUS G750JW (no windows 8 preinstaled) a couple of day ago. Everything went perfect with it until last night, when i decided to instala the Windows 8.1 update. The update itself went on smootly but i noticed the "SecureBoot isn't configured correcly" text in the botoom right corner so, after a quickly looking over the issue on google, i restarded the notebook and enetered bios to activate secure boot.
In the bios menu i made only two changes:
1. I activated the first option in the secure boot menu
2. I changed the option "POST Logo ... " from "Static" to "Active"
After saving the settings an exiting the bios menu, the notebook started, but the screen remained blank. I tried a few restarts but the same issue occured every time: the screen remained blank while the keyboard lit up (and worked, at least the caps and num lock did) and the indicator leds lit up aswell (the power light was on, so was the battery, but the HHD one flickerd for a few seconds and the it stayed off).

I didn't have another PC or laptop around so I started browsing for solutions on my phone. I found and tried a lot of possible sollutions:
- pressing the ESC, F2, F4, F9, F12 or DEL key to try and enter the BIOS
- removing the battery and the power plug and pressing the power button for 2-3minutes then starting the notebook
- removing the SSD and HDD drive and all the other usb devices and trying the above steps again

I the stumbled upon this thread (http://rog.asus.com/forum/showthread.php?27544-G75VX-Changed-boot-order-can-t-access-BIOS&). Where i found a possible sollution in placing an BIOS update on a USB stink and trying to Flash it during start-up. At this point I was pretty discouraged as this sollution didn't work for that guy and I prepared the laptop so i could sent it to service if this last method wouldn't work out.

This morning I went to work and went thru the following steps:
- formated an 8gb USB Stick as FAT32
- downloaded the latest bios update from the ASUS website (208)
- unziped the archive and placed two copies of the BIOS file on the root of the USB stick
- renamed the two files (from the original G750JWAS.208) to G750JW.BIN and G750JWAS.BIN - I did this because I wasn't sure which name would the BIOS recognize.
- placed the USB stick in the USB3.0+Charger port of the laptop
- turned the laptop on while keeping the CTRL+HOME keys pressed

To my utter surprise the screen turned on, quickly displaying the ROG logo, and the notebook entered the BIOS Flash Utility which performed a clean install of the latest BIOS.
After it finished installing and verifying the install the notebook turned off.
I removed the USB stick and powered it on again.
The notebook started (screen on and all) and it works perfectly since.

I hope this post will turn out to be helpful for other RoG G750 owners in the same situation :cool:

noideea
10-26-2015, 08:38 PM
Hey, i'm glad You were able to fix your laptop using this method.

felmilani
09-30-2016, 02:19 AM
Hi,

I have a similar issue on my asus s46cb.

I downloaded the last bios from asus website (K46CBAS.ZIP) and renamed the original file K46CBAS.207 to K46CBAS.BIN and K46CB.BIN.
Then I put then on a usb drive and the usb drive on the usb 3.0 port. Turned on the laptop while holding CTRL+HOME but I got nothing :(

Does anybody know if this solution doesn't work for all asus laptop? What may I be missing? The name of the bios file? Should something appear on the screen
right after I press the power button? Or should I keep pressing CTRL+HOME?

I don't know what to do =(

Any help will be immensely appreciated.