View Full Version : RaidR Express Advice For A Newb!

10-25-2013, 01:31 AM
So I have some questions for the pros about the proper install of the RaidR. The instructions it came with suck so Ive looked through most of the RaidR threads on the forums but am still confused as how I should do the install. First off my original plan for the RaidR was to have faster boot times then I currently have with my OCZ Vertex 3 120GB SSD. From what I now understand according to the forums I wont be able to take advantage of UEFI Boot cause I'm running Windows 7 Pro and not 8, Is this the case?
I also kinda gathered that it doesn't come from the factory with a Raid config set up and that I have to do it myself? So I guess the main question is , If you had the same set up as myself what would use the RaidR for? Then what would be the best way to set it up given my components. Any help or Ideas would be greatly appreciated.. Thanks, Stogie
My System
Asus Maximus VI Formula
Intel i7 4770k
Asus GeForce GTX 680 DCU II TOP
Corsair Dominator Platinum (4x4GB 16GB @ 2400MHz)
Asus RaidR Express 240GB
OCZ Vertex 3 120GB SSD
Windows 7 Pro 64bit

10-28-2013, 02:14 AM
Firstly install it using UEFI - thats half the battle won - yes you have to setup the card as its made for boards that have UEFI or don't - setup RAID0 - you have to setup the dive before using UEFI - in previous post they have good explanations and how to - will get the forum and post it for you - go to - RAIDR install finally working - think he gives a very good explanation and pics-

10-28-2013, 10:20 AM
In legacy mode set up the RAID0

Then switch to UEFI mode and install OS to the RAIDR

My advice is do not have any other devices (storage) connected during the OS install process.

11-27-2013, 11:26 AM
It sounds so simple but i just can't seem to get it to work, would the firmware update fix my prob? or is it some other setting in the bios that i've got wrong?

11-27-2013, 04:18 PM
Boda please list exactly what you have done. So we may be able to help you:)

11-28-2013, 11:34 AM
Ok, I've set the raid array to Raid 0 by ctr M while in legacy then after reboot i set it back to uefi. Secure boot is set to other OS and CSM is set to how the guide is pictured which is enabled. Once i start installing win 8.1 via uefi optical drive i get to advanced options and hit new, giving me the 4 different drives, then i choose the bottom drive which is the biggest. After the instal i reboot into bios the set my boot drive but there's is only the optical drive detected. I'll stay in this thread to Nodens to keep it simple.

11-28-2013, 12:55 PM
disable CSM. you should see Boot manager

11-28-2013, 01:17 PM
Indeed try siabling CSM entirely. By 4 different drives you mean partitions I take it?

11-28-2013, 01:19 PM
Hey Light, i just follewed "RAIDR install finally working" thread to a tea. I could see boot manager & everything then i disabled CSM and shutdown my pc then enabled UEFI on the RAIDR. When i booted up it proceeded to boot from cd, after going into bios again the raidr and boot manager has gone. 2 things that pop to my mind are Firmware on the raidr and a problem with win 8.1? other than that I've got no idea. please persist with me :)

11-28-2013, 01:40 PM
It's neither of those. UEFI on the RAIDR has to be switched prior to the installation of Windows.

Ok. Listen. First of all disconnect any other drives from your system. Leave only the RAIDR and the DVD-RW drive that has your installation media.

Since you have created your RAID-0 array via Ctrl-M, make sure the RAIDR is set to UEFI then follow the guide in my sig.

When you get to the partitioning stage, use the troubleshooting section and do the "clean" procedure. After that restart the installation according to the guide and do it eactly as it says and you'll be fine. Once the installation is done, connect any other drives you may have and make sure the UEFI is set to boot "Windows Boot Manager".

11-28-2013, 07:55 PM
Agree with Nodens completely nothing to do with Firmware strange how you could see the boot manager before disabling CSM cause the boot manager wont appear until CSM ( Compatibility Support Module) is disabled. As Nodens says youve done the hard part when windows is installing and you create new partitions, the first sector of a GPT disk (ie RAIDR) is reserved for protective MBR and if the raidr is in uefi mode should appear in the boot section of bios as Boot manager

11-28-2013, 08:44 PM
@light123: It's possible to see the Boot Manager with CSM on, as long as the suboptions are set to UEFI first. At this point I am not sure he had selected the proper drive during installation. That boot manager/ESP partition may be on another drive. That's why I suggested to disconnect all other drives. He seems to be confused on the concepts of drives and partitions so this is the only way we can make sure he's installing to the RAIDR :)

11-29-2013, 08:58 AM
I really shouldn't post after 8 hr flight lol :o yes your right if the sub menu's are set correctly then the Raidr should appear. starting to think it would be easier just to install as legacy only issue is boot times to be honest my machine is on 24/7 usually cant see any performance gained under uefi install

11-29-2013, 09:33 AM
Hi fellas, just got home from work so I'll give it another shot. I only have the optical drive & the RAIDR installed, no other drives were connected. I'll install windows with uefi on this time but i feel I've done that the 1st time round a few days ago. So if I've seen the boot manager in legacy mode that means more than likely my CSM setting might have been wrong when changing to UEFI? Anyway I'll try again following your instruction & come back with more detailed feedback :)

11-29-2013, 10:56 AM
Tried it again with no luck. I've tried so many combos now it's worrying how many secure erases i'm doing. So after doing the installation i rebooted & still no drive to be found. Turned the PC off & enabled legacy mode causing the drive to re appear :( If it's no performance hit by leaving legacy then i think I'm beat & will leave it in legacy. A lot of money & big headache. I want to thank you both for your help tho fellas :)

12-07-2013, 01:41 AM
Hi fellas, I just wanted to let you know i stuck my raidr in my Maximus V Gene Mobo PC after trying to get it to run UEFI in my Rampage Black Edition & it worked straight away. As far as the CSM settings were concerned they were the same on both mobos so i think there maybe an issue with compatibility or i have to update the firmware on the raidr to get it to work with the Black Edition. Updating the firmware has been a mission as well, I'm struggling hard to get the software working at boot & the internal windows OS updater doesn't recognize the drive. ASUS support just said RMA the thing but i know it works so i'll persist i think