View Full Version : G750JX Boot priority

10-29-2013, 05:24 PM
I've had my laptop for a few months now it was working great, but I was installing linux on a seperate drive last night and woke up tom my laptop not booting correctly so I swapped the original windows drive back into it. Now it will only boot to BIOS and it doesn't give the the Windows boot manager and won't let me create one. I tried reseating, only leaving the single windows drive plugged in, resetting all BIOS settings along with shutting off/turning on fast boot and secure boot, and plugging the linux drive back in. It shows the drive are there, but won't let me choose a boot option. Does anyone have any ideas on what to do with this?

10-29-2013, 05:45 PM
Have you checked your 'secure boot' setting under the bios 'security' menu and 'launch CSM' setting under the 'boot' menu and can you try enabling 'launch CSM' and disabling 'secure boot' to see if it makes a difference?
You may need to save and exit the bios with the changes and reenter the bios before you will see the hard drives in the boot priority area, but you should see them listed under 'advanced'/SATA Configuration at least if they are detected in the hardware.

As far as I can tell, if your bios settings aren't correct to boot to a hard drive on the G750, it will not be listed under the boot menu, so I wouldn't worry too much about this right away and just try different bios settings as mentioned above.

By the way curious if you are using the original Windows 8 factory image or something else if there are still problems.

Well, hope this is able to help.

10-29-2013, 06:19 PM
I tried changing the secure boot and enabling launch csm, then when I reboot in order for it to save, the system starts but I don't get a display and it sits for 20 min. and shuts down. Then when I start the machine back up, it goes back to BIOS with the old settings. It shows the hard drives within sata configuration, but when i go to add them in boot priority, nothing happens. I'm not sure if something is wrong with my bios.

10-29-2013, 09:30 PM
Hmmm... not sure if we can get some better ideas first, but if you have a hard drive you can wipe, wondering how far you can get with a new installation.

I've never found a way to add boot options in the bios myself and they really should show up automatically if your bios and hard drives are set up correctly (after you reboot if bios settings were changed?).
Not sure that I would try this right away, but if you can't find a way to get it working and are resigned to sending the system back for repair, you may want to try a bios update if available just to see if it solves anything or kills the unit (no idea if this would happen).

10-29-2013, 09:47 PM
I was thinking about doing a bios update, but how would i go about doing that if its not able to boot into anything but the bios?

10-29-2013, 10:07 PM
It's as if the BIOs is corrupt because whenever I boot to the BIOs and make changes to the settings, it will reboot to nothing until I have to hard boot it. Then it returns to the bios with no changes. I'm pretty much stumped at this point. I work in IT, Not for too long, and I have not seen anything like this before.

10-29-2013, 10:20 PM
While I don't have the slightest idea if this will work, you can try to downgrade the bios and then to re-upgrade it when/if it works. There's a post on how to do it for older G laptops, I can only hope it's the same for this one - http://rog.asus.com/forum/showthread.php?22444-G55VW-16Gb-1600MHz&p=163278&viewfull=1#post163278

Of course, you'd need to get the G750 bios files. If you are able to boot into linux, you can use that to place the bios file on the drive as instructed in that thread. It just might work, who knows.

10-29-2013, 10:37 PM
I'm not able to boot into linux. It won't let me boot into anything but the bios.

10-29-2013, 10:49 PM
Maybe a live distro off usb? Or is that not working either? Try spam-hitting ESC when starting up to get the boot menu to pop up.

10-29-2013, 10:56 PM
For some reason nothing is working. I spam the esc and it brings up the boot menu, but nothing is in it.

10-29-2013, 11:02 PM
Not sure if your Windows hard drive is doing the same thing, but just guessing that maybe your linux installation was corrupted (or the hard drive is defective) and it's getting stuck booting to that hard drive although this may not be correct if you don't even see it in the boot options.

Anyway, I'm thinking (and hoping) that you can boot to DVD (make sure you insert the DVD before checking the boot menu) or other media to start a new installation if you need to and not even worry about updating the bios (if the bios detects the hard drive at least, hopefully it shows up in the boot options after the installation is complete).

You might even try restoring the default bios settings from the 'exit' menu, but it should only be necessary after updating the bios.

If you still want to try the bios flash and can safely remove your hard drive and connect it by USB to another system to copy the bios file and reinstall it back into your system, you can flash the bios from the hard drive using the bios EZ flash utility, or really just use a USB drive instead, but flashing by USB thumb drive always makes me a little more nervous since it's slower.

10-29-2013, 11:05 PM
Weird. I don't see how installing Linux could have messed up the BIOS/UEFI setup... If you can't boot from any drive, or bootable usb stick, and resetting the bios settings doesn't work (as you said), it may be time to RMA. Looks like you've tried everything you can.

10-30-2013, 02:34 AM
I was really hoping it wouldn't have to come to that. Would it void the warranty if I pulled the hard drives out?

10-30-2013, 10:56 AM
I was really hoping it wouldn't have to come to that. Would it void the warranty if I pulled the hard drives out?

No, it wouldn't.